IXUS 115 HS / ELPH 100 HS request - page 8 - DryOS Development - CHDK Forum

IXUS 115 HS / ELPH 100 HS request

  • 538 Replies
  • 165537 Views
Re: IXUS 115 HS / ELPH 100 HS request
« Reply #70 on: 17 / November / 2011, 07:06:45 »
Advertisements
My firmware is 101 ver3,which one i can use? :blink: :blink:

*

Offline whim

  • ******
  • 2041
  • A495/590/620/630 ixus70/115/220/230/300/870 S95
Re: IXUS 115 HS / ELPH 100 HS request
« Reply #71 on: 26 / November / 2011, 06:20:05 »
My firmware is 101 ver3,which one i can use? :blink: :blink:

ver1 = A, ver2 = B etc.   --> yours is 101 C

Re: IXUS 115 HS / ELPH 100 HS request
« Reply #72 on: 28 / November / 2011, 14:33:25 »
my ver is 1.01c ...
which CHDK ver should i use??

will 1.01b - alpha #5 work ???

Latest CHDK version:
1.00c - alpha #5
1.01a - alpha #5
1.01b - alpha #5

BUGLIST:
  • Issue: Video crashes camera
    Affected:1.01b (alpha4)
    Cause: wrong function addresses in <fwversion>/movie_rec.c
    Fix: alpha5

  • Issue: "SuperFine" quality doesn't make any sense.
    Affected: 1.00c, 1.01ab
    Cause: there is no "SuperFine" quality in elph100.
    Fix: no

  • Issue: RAW files have nothing in them.
    Affected: 1.01a,b
    Cause: Possibly wrong addresses of RAW buffer
    Fix: 1.00c - works properly (but I can't open RAW file, because of unknown format)
    1.01a,b - check alpha5 (fixed addresses a bit)

  • Issue:Won't take RAW passed the first picture
    Cause: unknown (possible - wrong state_shooting_progress values)
    Fix: not available

  • Issue: getting zoom stuck in zoomed position while video recording
    Affected: 1.01ab
    Cause: look here
    Fix: 1.00c - zoom works properly
    1.01ab - no

  • Issue: digital zoom doesn't work while video recording
    Affected: 1.00c
    Cause: unknown (possible - wrong "zoom_unlock" or "af_lock/unlock" function position in <fwversion>/movie_rec.c)
    Fix: no

  • Issue:Scripts don't start every time, but I need to restart the camera to start them successfully.
    Affected:1.01b (tested), 1.00c+1.01a (possible)
    Cause: unknown
    Fix: no

  • Issue:Scripts sometimes don't stop themselves, but need to be stopped after execution.
    Affected:1.01b (tested), 1.00c+1.01a (possible)
    Cause:unknown
    Fix: no

  • Issue: Games screen sqeezed, sometimes no colours.
    Affected: 1.00c, 1.01ab
    Cause: Wrong ASPECT_GAMES_XCORRECTION value in <camera>/platform_camera.h
    Fix: no

  • Issue:
    Quote
    Colors of the palette for the menu background changes - not clear about correlations to going into sub-menus; done before: I changed the background color. Palettes in shooting and playback mode are not the same.
    Affected: 1.01b (tested), 1.00c+1.01a (possible)
    Cause: unknown
    Fix: no

  • Issue:
    Quote
    Zebra mode is working bad, it produces just blinking of red lines in bottom half of screen, not on places it should be.
    Affected: 1.00c (tested), 1.01ab (possible)
    Cause: unknown
    Fix: no

  • Issue: Generating of badpixel.bin doesn't work
    Affected: 1.00c (tested), 1.01ab (possible)
    Cause: unknown
    Fix: no

  • Issue: match values in <camera>/shooting.c
    Affected: general
    Cause: wrong values
    Fix: no


ORIGINAL MESSAGE:

Quote
Hello, kevdog32!

I've just started to analyze firmw dump, and I hope soon will be able to present something useful for this camera.
I can't get ver.req&vers.req to work too, but I've took fw version directly from firmware. Use cBasic udumper (Canon Basic description) and post fw here. We'll see what ver you have.

Stay tuned! =)

John.

Re: IXUS 115 HS / ELPH 100 HS request
« Reply #73 on: 28 / November / 2011, 15:43:58 »
my ver is 1.01c ...
which CHDK ver should i use??

will 1.01b - alpha #5 work ???
You can try 1.01b - its the one most likely to work but its not guaranteed.  Sometime CHDK for one firmware version works on another firmware version but most of the time it will not.  It all depends on what Canon changed between each version and there is no way to tell that.

Ported :   A1200    SD940   G10    Powershot N    G16


Re: IXUS 115 HS / ELPH 100 HS request
« Reply #74 on: 29 / November / 2011, 23:10:25 »
the firmware of my friend is 1.01a and he uses 1.01a alpha5.everything is ok,but he can't enter ALT mode when CHDK is loaded on his camera by press ZOOM IN + FUNC./SET !

my firmware is 1.01c and i use 1.01b alpha5,it worked on my 115HS.I can adjusted shutter although it didn't always work!i adjusted the aperture it didn't work even once... 

i'm waiting for the next version :D :D :D

Re: IXUS 115 HS / ELPH 100 HS request
« Reply #75 on: 29 / November / 2011, 23:32:13 »
i adjusted the aperture it didn't work even once... 
IXUS cameras generally don't have an adjustable aperature.  There is a Neutral Density filter that is used to adjust the exposure.
Ported :   A1200    SD940   G10    Powershot N    G16

Re: IXUS 115 HS / ELPH 100 HS request
« Reply #76 on: 30 / November / 2011, 05:54:59 »
i adjusted the aperture it didn't work even once... 
IXUS cameras generally don't have an adjustable aperature.  There is a Neutral Density filter that is used to adjust the exposure.

 :)Oh,got it!Tks

Re: IXUS 115 HS / ELPH 100 HS request
« Reply #77 on: 30 / November / 2011, 13:18:30 »
I m not able to start in ALT mode...
pls guide me..!

newbie


*

Offline whim

  • ******
  • 2041
  • A495/590/620/630 ixus70/115/220/230/300/870 S95
Re: IXUS 115 HS / ELPH 100 HS request
« Reply #78 on: 30 / November / 2011, 13:39:21 »
@alivehunter

You did read the 1st post in this thread ?

HTH,

wim

where is the source code?
« Reply #79 on: 06 / December / 2011, 07:28:54 »
Where can i find the source code of these alpha binaries?

Obviously JustJ ignored the License and only posted binaries.   >:(
If he's missed in action development needs to be started from scratch?  ???

 

Related Topics