IXUS 115 HS / ELPH 100 HS request

  • 535 Replies
  • 79001 Views
*

Offline sinak

  • *
  • 11
Re: IXUS 115 HS / ELPH 100 HS request
« Reply #130 on: 20 / February / 2012, 07:36:05 »
Advertisements
@RueLue yes optical zoom works in video. I can zoom in & out properly. The mechanical sound is recorded too.

The problem i described:
DNG works fine. Although,  i had a problem with some jpegs. While the content of dng was as expected, the jpegs looked like i used a weird overexposed light effect.

was the same one with (but better explained  :P):
I just found a funny behavior with RAW DNG images: every second image is totally "overexposed" (only the jpg-part).
Canon IXUS 115 HS / firmw.1.01c - using ixus115_elph100hs-101c-1.1.0-2184-full_BETA -CHDK-beginner - Europe/Greece

Re: IXUS 115 HS / ELPH 100 HS request
« Reply #131 on: 20 / February / 2012, 22:28:32 »
Hi, sinak!
I see, that my bug report wasn't clear enough.
I wrote:
Quote
Video recording, optical zoom: zooming in works as expected, zooming out (optical) stops zooming function; switch to playback and back is needed to let zoom work again.
The bug is connected to the digital zoom.

To reproduce:
  • Misc. - reset options to default AND Visual settings - reset files - leave menu, then restart camera!
  • switch to record mode (half press of the shutter button)
  • open Canon-menu (menu button), go to tools-part of the menu, reset to factory defaults
  • go to photo-part of the canon-menu (only for controlling): the setting for digital zoom is "standard"
  • zoom out (it is allready zoomed out, but shows the zoom bar on the display, in the middle of the bar is a white line: the left part is for the optical zoom, the right part for the digital zoom)
  • zoom in (without recording): you can now zoom in up to 16x zoom (including the digital zoom) and back out (all o.k.)
  • now push the record video button (the lenses are adjusted and recording starts)
  • zoom in (optical and digital): all o.k.
  • now zoom out to 1x zoom: digital zoom out is o.k., but optical zoom out doesn't work, same now with digital zoom (in and out)
  • stop recording and try zooming without recording: no function
  • switch to playback mode and back to record mode
  • try zooming in/out: all o.k.

As soon as zooming out affects the optical zoom, the function stops.
Please test this.

If the digital zoom is fixed or switched off (canon-menu, photo-part, digital zoom is set to 1.5x or 2x or off), the optical zoom works also on my camera as should be. Sorry for not being clear

Thank you! Ruedi
Ixus 115 HS / firmw.1.01b - using and testing the new beta - CHDK-beginner - Europe

Re: IXUS 115 HS / ELPH 100 HS request
« Reply #132 on: 21 / February / 2012, 03:09:31 »
my 100 did NOT zoom in video record mode.
It sets its focal range when you press the REC button
and then starts to record.
the 100 does not zoom in video mode .
And will Not.


thats why i went to the BETER 300HS.
« Last Edit: 21 / February / 2012, 03:14:10 by radioman193 »

Re: IXUS 115 HS / ELPH 100 HS request
« Reply #133 on: 21 / February / 2012, 10:16:17 »
First of all I want to offer my thanks to all involved in working on this port; I really appreciate your efforts.

My camera has fw 101.c and I've tried both Just.J's alpha.101.b and Hanulis's alpha.omega builds. Here is some feedback related to saving DNGs, the only CHDK feature that I'm interested in:

- Duplicate and missing images: When I take several shots, the corresponding number of dng files are properly saved BUT the content of some images are replicated inside more than one file, while others simply disappear. This behavior is a bit random as I can take 10 shots and have 3 images in 10 files but, if I clean the card and start again, I may this time have 2 or 3 or 5 images scattered inside my 10 files.

- Badpixel removal - It appear that bad pixels aren't been marked as such. I've generated my badpixels file (29.000!) but the dngs still show all badpixels, everywhere. I've got the same results with options "Off" and "RAWconv" for "Bad pixel removal" using ACR 6.3, LR3.6, LR4.0b, DxO Optics Pro 7 and Capture One Pro 6, all under OSX.

- JPEGs - As others reported, some jpegs have funny colors but not all.

I am available to test all the features on a 101c camera, feel free to ask. Thank you very much.


« Last Edit: 21 / February / 2012, 14:10:07 by Rogerio »


Re: IXUS 115 HS / ELPH 100 HS request
« Reply #134 on: 22 / February / 2012, 02:58:00 »
Hi, coders!
I made more observations:
  • OSD: battery icon/value and movie rest-time (when video recording = recorded time) overlap
  • OSD: MBy rest on card and movie resolution overlap
  • Switch camera off: sometimes (seldom) the objective doesn't move back into the camera; need to switch the camera on and off again to move the objective (still not reproduced)
  • Record movie: display of KBy/sec and remaining time are strange from time to time, e.g. 0 or 1 KBy/sec and remaining time 0 seconds, but it is enough place on the card and the camera is still recording
  • Record movie: value KBy/sec constantly rising or falling, depending on the resolution for the first movie recorded after switching the camera on (not exactly reproduced),  but values are not (or not at once) connected to the video resolution or movie content (still image or moving object)
  • DNG, every second image: as Rogerio wrote: it is a copy of the previous image, sometimes with a clear color fault; but exif-data differ: they seem to belong to the original picture; the corresponding .jpg-file is the same previous image, but extremely "overexposed"; exif-data: same as with dng-file!!
  • BADPIXEL.BIN is created, the camera says "14000 bad pixels; I cannot say, if that file is o.k., but it's size is 39Kby - seems plausible

Question RAW: which values have width/height? Bits per pixel are 10? "Normalized"? Packed? Bayer pattern? File header?
IrfanView promises to open the files, when I answer correctly.

Happy coding! Ruedi
Ixus 115 HS / firmw.1.01b - using and testing the new beta - CHDK-beginner - Europe

*

Offline reyalp

  • ******
  • 10057
Re: IXUS 115 HS / ELPH 100 HS request
« Reply #135 on: 22 / February / 2012, 15:52:31 »
OSD: battery icon/value and movie rest-time (when video recording = recorded time) overlap
OSD: MBy rest on card and movie resolution overlap
You can use the OSD editor to move stuff around.

Quote
Question RAW: which values have width/height? Bits per pixel are 10? "Normalized"? Packed? Bayer pattern? File header?
IrfanView promises to open the files, when I answer correctly.
Last time I checked, irfanview could not display CHDK raws in a useful way using this method, because it doesn't allow you to set the correct byte order / packing. If you get all the values right you may be able to see *something* but it won't be a usable image. There is no header in CHDK raws, they are just a dump of the sensor buffer.

The other values depend on your camera, and can be found in the source if the port is done correctly. Your camera is most likely 12 bpp.

dng4ps2 is probably a better way to get something useful out of the raws. See http://chdk.setepontos.com/index.php?topic=6754.0

The dimensions should be in platform/<camera name>/platform_camera.h. Some of these values are also auto-detected in the build process and placed in platform/<camera name>/sub/<firmware version>/stubs_entry_2.s
Don't forget what the H stands for.

Re: IXUS 115 HS / ELPH 100 HS request
« Reply #136 on: 24 / February / 2012, 12:41:10 »
reyalp wrote (OSD elements overlapping):
Quote
You can use the OSD editor to move stuff around.

It's a solution, when I don't reset the settings all 10 minutes to test something. I thought, that all defaults are built into the binary. O.k., that is fine tuning when all other works good. I took the OSD-editor now, as testing has come to a break.

I wrote:
Quote
Switch camera off: sometimes (seldom) the objective doesn't move back into the camera; need to switch the camera on and off again to move the objective (still not reproduced)

Reproduced, but still not exactly:
It is connected to managing of files/folders:
  • make an image
  • call the CHDK menu -> Misc. -> File Browser
  • go into the DCIM folder
  • move the marker to the folder with the image
  • call the menu for the folder (macro-button) "More ->", Remove dir ! The folder should disappear from the folders list, but often this doesn't happen.
  • Move the mark up/down: the obsolete folder entry disappears. (not needed)
  • Now switch the camera off (play button or main button)!  Most times the objective will not move back into the camera.
You can have the same result, when you
  • mark two or more files, object menu -> delete! (not exactly reproduced)
  • copy and past a file (not exactly reproduced)
  • marker on one file, menu -> rename (not exactly reproduced)
To be sure, that not a faulty directory or FAT was the reason for the switch-off-bug,  I formatted a card and put a fresh CHDK alpha-omega on it.

Oh - one time I tried to rename a folder (menu allows this): Camera crashed (no more reaction to buttons and blinking LED on the back side. Removing of the accumulator was needed (one time reproduced).

I wrote:
Quote
DNG, every second image: as Rogerio wrote: it is a copy of the previous image, sometimes with a clear color fault; but exif-data differ: they seem to belong to the original picture; the corresponding .jpg-file is the same previous image, but extremely "overexposed"; exif-data: same as with dng-file!!
It seems to be the same with CRW files: I compared two of them (only my system's filecompare: fc /b FILE1 FILE2) and it showed, that every second is exactly the same as the previous (o.k., to be expected, as the DNG file is "only" the converted CRW file).

Ruedi

Changed: + observation about the CRW files
« Last Edit: 24 / February / 2012, 17:53:10 by RueLue »
Ixus 115 HS / firmw.1.01b - using and testing the new beta - CHDK-beginner - Europe

*

Offline reyalp

  • ******
  • 10057
Re: IXUS 115 HS / ELPH 100 HS request
« Reply #137 on: 24 / February / 2012, 21:39:19 »
Issues with rename and delete of non-empty directories are expected. "Issues" may include hosing your filesystem.

This is a bug, but not specific to the port.
Don't forget what the H stands for.


Re: IXUS 115 HS / ELPH 100 HS request
« Reply #138 on: 25 / February / 2012, 13:16:46 »
reyalp wrote:
> Issues with rename and delete of non-empty directories are
> expected. "Issues" may include hosing your filesystem.
>
> This is a bug, but not specific to the port.

Is there a common forum thread for this behavior (bugzilla, mantis, ...)? Link? Better: a common bugs list (all builds)?

edit: just found a bugtracker: http://tools.assembla.com/chdk/wiki/ "503 Service Temporarily Unavailable"
« Last Edit: 25 / February / 2012, 17:08:55 by RueLue »
Ixus 115 HS / firmw.1.01b - using and testing the new beta - CHDK-beginner - Europe

*

Offline reyalp

  • ******
  • 10057
Re: IXUS 115 HS / ELPH 100 HS request
« Reply #139 on: 25 / February / 2012, 18:56:38 »
reyalp wrote:
> Issues with rename and delete of non-empty directories are
> expected. "Issues" may include hosing your filesystem.
>
> This is a bug, but not specific to the port.

Is there a common forum thread for this behavior (bugzilla, mantis, ...)? Link? Better: a common bugs list (all builds)?

edit: just found a bugtracker: http://tools.assembla.com/chdk/wiki/ "503 Service Temporarily Unavailable"
There is currently is no bug tracker in use by the developers.  See here http://chdk.setepontos.com/index.php?topic=2357.msg81006#msg81006

I would be open to using the assembla trac or ticket system.

I have not had any trouble accessing assembla today.
Don't forget what the H stands for.

 

Related Topics