IXUS 115 HS / ELPH 100 HS request - page 27 - DryOS Development - CHDK Forum supplierdeeply

IXUS 115 HS / ELPH 100 HS request

  • 538 Replies
  • 218427 Views
Re: IXUS 115 HS / ELPH 100 HS request
« Reply #260 on: 28 / June / 2012, 10:47:09 »
Advertisements
1.01b, third try:
not changed (sorry). The CHDK-OSD and the menus and file manager often change colors and thickness of distorted bars and the scripts menu sometimes flickers a bit.

Oh - vers.2 and vers.3 of the rebuild - are there really changes? The zip files have both the same size (637815 Bytes) and also the diskboot.bin files have both the same file date (Do 28 Jun 2012 05:32:01 CEST). Where is my error?

Ruedi
Ixus 115 HS / firmw.1.01b - using and testing the new beta - CHDK-beginner - Europe

Re: Re: IXUS 115 HS / ELPH 100 HS request
« Reply #261 on: 28 / June / 2012, 11:05:51 »
1.01b, third try:
not changed (sorry). The CHDK-OSD and the menus and file manager often change colors and thickness of distorted bars and the scripts menu sometimes flickers a bit.
Any chance you can take a couple of the screen pictures and post them here?
Quote
Oh - vers.2 and vers.3 of the rebuild - are there really changes? The zip files have both the same size (637815 Bytes) and also the diskboot.bin files have both the same file date (Do 28 Jun 2012 05:32:01 CEST). Where is my error?
Interesting observation - I'll look into it tonight. Quote possible I've made a mistake.

Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline siak

  • *
  • 26
Re: IXUS 115 HS / ELPH 100 HS request
« Reply #262 on: 28 / June / 2012, 11:48:34 »
@waterwingz, tried your latest chdk on my 100hs 101a. here's in attachment what I see when I turn on the camera and click func.set+zoom in.

Re: IXUS 115 HS / ELPH 100 HS request
« Reply #263 on: 28 / June / 2012, 12:33:53 »
Quote
a couple of the screen pictures
:
Ixus 115 HS / firmw.1.01b - using and testing the new beta - CHDK-beginner - Europe


Re: IXUS 115 HS / ELPH 100 HS request
« Reply #264 on: 28 / June / 2012, 12:37:04 »
And 2 more...
Ixus 115 HS / firmw.1.01b - using and testing the new beta - CHDK-beginner - Europe

Re: IXUS 115 HS / ELPH 100 HS request
« Reply #265 on: 28 / June / 2012, 12:51:02 »
... and more:
Ixus 115 HS / firmw.1.01b - using and testing the new beta - CHDK-beginner - Europe

*

Offline srsa_4c

  • ******
  • 4451
Re: IXUS 115 HS / ELPH 100 HS request
« Reply #266 on: 28 / June / 2012, 13:52:01 »
@waterwingz
You could try the bitmap buffer related values in this post: http://chdk.setepontos.com/index.php?topic=6751.msg72551#msg72551 ?

Re: IXUS 115 HS / ELPH 100 HS request
« Reply #267 on: 28 / June / 2012, 13:58:03 »
@waterwingz
You could try the bitmap buffer related values in this post: http://chdk.setepontos.com/index.php?topic=6751.msg72551#msg72551 ?
That was what I used for my build #2.  I still think I'm missing something related to CAM_USES_ASPECT_CORRECTION.  Maybe I'll revert my svn trunk to just before that change was made and see if the published source works correctly then.

« Last Edit: 28 / June / 2012, 14:00:33 by waterwingz »
Ported :   A1200    SD940   G10    Powershot N    G16


*

Offline dnw

  • *
  • 22
Re: IXUS 115 HS / ELPH 100 HS request
« Reply #268 on: 28 / June / 2012, 18:26:07 »
In theory the correct values could possibly be obtained from disassembling the hanuli's alpha omega build (for 101b ... and 1.01c) but whether this is really feasible I am not sure.
A530 & IXUS 115 HS Firmware version, 1.01C, CHDK status:   user

Re: IXUS 115 HS / ELPH 100 HS request
« Reply #269 on: 28 / June / 2012, 18:55:33 »
Oh - vers.2 and vers.3 of the rebuild - are there really changes? The zip files have both the same size (637815 Bytes) and also the diskboot.bin files have both the same file date (Do 28 Jun 2012 05:32:01 CEST). Where is my error?
Looks like I built against the dev trunk but uploaded from an earlier build in the stable trunk.  Let's just say I was either up very late at that point or up really early.

Here's two new builds where I lifted the display values from IXUS220 .

r4 >1.00c
r4 >1.01a
r4 >1.01b

r5 >1.00c
r5 >1.01a
r5 >1.01b

Let me know if either now works for you ?

Sorry for the confusion.  The whole :

vid_get_bitmap_screen_width()
vid_get_bitmap_buffer_width()
vid_get_bitmap_buffer_height()
vid_get_viewport_buffer_width()
vid_get_viewport_width()
vid_get_viewport_xoffset()
vid_get_viewport_height()

is a mess when you look at different camera ports.
« Last Edit: 28 / June / 2012, 19:57:21 by waterwingz »
Ported :   A1200    SD940   G10    Powershot N    G16

 

Related Topics


SimplePortal 2.3.6 © 2008-2014, SimplePortal