IXUS 115 HS / ELPH 100 HS request - page 30 - DryOS Development - CHDK Forum  

IXUS 115 HS / ELPH 100 HS request

  • 538 Replies
  • 220478 Views
Re: IXUS 115 HS / ELPH 100 HS request
« Reply #290 on: 01 / July / 2012, 12:00:14 »
Advertisements
@siak:
1.01b confirmed: works. I was irritated because of "shut_down".
As long, as some script functions stop the script, I use the newest alpha build only for testing, but yes, if you cannot use the alpha-omega build, you need scripts without special commands (I don't know, which they are).
It seems to be interesting to have a set of script commands, which surely don't crash the script.
Ruedi
Ixus 115 HS / firmw.1.01b - using and testing the new beta - CHDK-beginner - Europe

Re: IXUS 115 HS / ELPH 100 HS request
« Reply #291 on: 01 / July / 2012, 12:00:22 »
Cause I've made it for this camera. Where else should I post it?
Well, the normal place would be here : CHDK Forum » Using CHDK » Script Writing » Completed and Working Scripts

But what I should have really asked what whether this script works with the recently posted alpha7 code ?  Or the alpha-omega code ?   Others have posted about scripts not running for long on the ixus115 - I think with both versions.

Ported :   A1200    SD940   G10    Powershot N    G16

Re: IXUS 115 HS / ELPH 100 HS request
« Reply #292 on: 01 / July / 2012, 12:01:52 »
@siak:
1.01b confirmed: works. I was irritated because of "shut_down".
As long, as some script functions stop the script, I use the newest alpha build only for testing, but yes, if you cannot use the alpha-omega build, you need scripts without special commands (I don't know, which they are).
It seems to be interesting to have a set of script commands, which surely don't crash the script.
Ruedi
So this runs on the alpha7 version ?
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline siak

  • *
  • 26
Re: IXUS 115 HS / ELPH 100 HS request
« Reply #293 on: 01 / July / 2012, 12:14:41 »
@RueLue:
Irritated? Take it easy, man :) I've changed this command just to "end". New script is in the attachement.

@waterwingz:
Yes, it works on your alpha7. And thanks, I've posted it in the section you've mentioned above.


Re: IXUS 115 HS / ELPH 100 HS request
« Reply #294 on: 01 / July / 2012, 12:30:24 »
1.01b, alpha7:
works!
limits:
  • the named standard scripts still stop after 2 shots resp. 1 shot
  • video, mechanic zoom: shows function, but doesn't always do mechanic zoom (still not reproduced). Digital zoom is done, when I start with it. Mechanic zooming out or when digital zooming out and going below 4.0 (it does't go below), zoom crashes and doesn't work again (also not with normal shots) until I go to playback and back to record
  • There still seems to be the problem with the file-manager, when deleting a whole folder (http://chdk.setepontos.com/index.php?topic=6751.msg81836#msg81836) I'll test it a bit more
  • badpixel.bin (I search for it in /CHDK/ ) is not saved
  • in german main menu "Scripting Parameters" is missing
  • more?...
Ruedi

« Last Edit: 01 / July / 2012, 12:34:00 by RueLue »
Ixus 115 HS / firmw.1.01b - using and testing the new beta - CHDK-beginner - Europe

Re: IXUS 115 HS / ELPH 100 HS request
« Reply #295 on: 01 / July / 2012, 12:32:45 »
I've posted it in the section you've mentioned above.
Looks good there !   You might want to edit the post to give the full camera name though ?  IXUS115_ELPH100HS.   There are other cameras with 100 in their model # and Canon's use of the hs/is suffix is kind of arbitrary.
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline siak

  • *
  • 26
Re: IXUS 115 HS / ELPH 100 HS request
« Reply #296 on: 01 / July / 2012, 12:37:53 »
I've posted it in the section you've mentioned above.
Looks good there !   You might want to edit the post to give the full camera name though ?  IXUS115_ELPH100HS.   There are other cameras with 100 in their model # and Canon's use of the hs/is suffix is kind of arbitrary.
I did it. Thanks a lot :)

Re: IXUS 115 HS / ELPH 100 HS request
« Reply #297 on: 01 / July / 2012, 12:39:43 »
the named standard scripts still stop after 2 shots resp. 1 shot
Specifically which one(s) ?

Quote
video, mechanic zoom: shows function, but doesn't always do mechanic zoom (still not reproduced). Digital zoom is done, when I start with it. Mechanic zooming out or when digital zooming out and going below 4.0 (it does't go below), zoom crashes and doesn't work again (also not with normal shots) until I go to playback and back to record
Unfortunately, this is a common problem with many cams - goes from mecha zoom to digital and won't go back.  There were a bunch of posts about this a year ago and I think philmoz had a work-around.  I'll look for it later.

Quote
  • badpixel.bin (I search for it in /CHDK/ ) is not saved
If you use the default settings,  you should get the new DNG version selected and it does not need a badpixel.bin file.   Although I can understand that you might want one.

A couple of questions about the RAW problem.

1) Is the saved RAW image valid ? (i.e. can you open it with something ?)   Alternatively,  can you open a DNG ?
2) Does DNG take one picture and hang too ?
3) With CHDK loaded but RAW disabled,  can you take a many pictures in a row (more than 5) ?

TIA
Ported :   A1200    SD940   G10    Powershot N    G16


Re: IXUS 115 HS / ELPH 100 HS request
« Reply #298 on: 01 / July / 2012, 13:02:59 »
Huh? Suddenly "Scripting Parameters" in german is back. Huh - again away! And there again.
The standard scripts in question:
interval.lua
interval.bas
hdr.lua
hdr.bas
motion.lua
motion.bas
Ixus 115 HS / firmw.1.01b - using and testing the new beta - CHDK-beginner - Europe

Re: IXUS 115 HS / ELPH 100 HS request
« Reply #299 on: 01 / July / 2012, 13:58:59 »
Decision time.

I contacted hanulis about what he changed to get alpha-omega running.  Specifically how he fixed the RAW issue.

His answer (slightly edited) was :

Quote
I'm sorry about that, I can't remember where did I change the code.

Basically, I rewrote all the code by comparing with other similar model. ( not sx220hs. )

Not really surprising he does not remember - I wouldn't either.  But it was worth a try.  And I learned that he did not just tweak the alpha5 code.

I took a look at the various C tasks in alpha7.  I'm not sure whether to start for scratch or try to go line by line, clean up the formatting and figure out what's different between this camera's port and other working ports from the same release period.

Either way, its a lot of work for a camera I don't own.   

So if I can get at least 3 people per firmware version to send me a PM saying they are interested in the port and willing to Beta test - with a real email address so we don't have to communicate through the forum's limited PM infrastructure - then I'll start this.

Otherwise,  I'll just post the alpha7 code to for inclusion in the svn as "ALPHA - DO NOT AUTOBUILD"  and wait for somebody else to pick up the project.


Ported :   A1200    SD940   G10    Powershot N    G16

 

Related Topics


SimplePortal 2.3.6 © 2008-2014, SimplePortal