IXUS 115 HS / ELPH 100 HS request - page 38 - DryOS Development - CHDK Forum supplierdeeply

IXUS 115 HS / ELPH 100 HS request

  • 538 Replies
  • 201504 Views
Re: Re: IXUS 115 HS / ELPH 100 HS request
« Reply #370 on: 10 / July / 2012, 10:41:47 »
Advertisements
Quote
One thing that bothers me is the way how the ‘ALT’ menu is activated – having to press 2 keys simultaneously is a pain with this particular camera, because the buttons are so small and flat – in fact, I have to use my fingernail to press the buttons!

If we could use a single key to activate the ALT, it would be great – perhaps, as others suggested, with a long press in the video key or the DISP Key
Actually, it's already done and tested. I was saving it as a surprise for the official beta release next week. There will be a user selectable choice of using the playback, video, or display + zoom key to enter <ALT> mode.  The default will be the playback button.
Ported :   A1200    SD940   G10    Powershot N    G16

Re: IXUS 115 HS / ELPH 100 HS request
« Reply #371 on: 10 / July / 2012, 11:20:54 »
Quote
Actually, it's already done and tested. I was saving it as a surprise for the official beta release next week.

Great! Thank you. :)

Re: IXUS 115 HS / ELPH 100 HS request
« Reply #372 on: 10 / July / 2012, 17:08:11 »
Alt-mode activation key: a thank you from here too! Ruedi
« Last Edit: 10 / July / 2012, 17:50:46 by RueLue »
Ixus 115 HS / firmw.1.01b - using and testing the new beta - CHDK-beginner - Europe

Re: IXUS 115 HS / ELPH 100 HS request
« Reply #373 on: 10 / July / 2012, 19:00:12 »
Hello, I just bought an Ixus 115 HS with the firmware 1.01 c. I've tried to install all of the CHDK alpha 11 versions. There just doesn't seem to exist a version with that version number and letter. Anyway, if I try to make the card bootable with Cardtricks program, and boot the camera with the card in the locked-position, the camera doesn't react in any way. In addition, I have to remove and re-insert the battery in order to boot the camera on the built-in OS after the try. I don't get any kind of "Firm update" option in the menu in any way and not on any alpha version.

Could you please tell me if it's possible to use CHDK on Ixus 115 HS with the firmware version 1.01c? If it were, how should I do it?


Re: IXUS 115 HS / ELPH 100 HS request
« Reply #374 on: 10 / July / 2012, 19:56:08 »
Hello, I just bought an Ixus 115 HS with the firmware 1.01 c. I've tried to install all of the CHDK alpha 11 versions.
There just doesn't seem to exist a version with that version number and letter.
The 1.01b version will work on the 1.01c

Quote
Anyway, if I try to make the card bootable with Cardtricks program, and boot the camera with the card in the locked-position, the camera doesn't react in any way. In addition, I have to remove and re-insert the battery in order to boot the camera on the built-in OS after the try.
That will happen when you load the wrong firmware versions (1.00c & 1.01a).  It should not happen with the 1.01b firmware.

Quote
I don't get any kind of "Firm update" option in the menu in any way and not on any alpha version.
Correct.   The firnware update method is not supported for the alpha version releases.

Quote
Could you please tell me if it's possible to use CHDK on Ixus 115 HS with the firmware version 1.01c?
Yes it is.

Quote
If it were, how should I do it?
Use the 1.01B version on your 1.01c version. 

Did you exactly follow the instructions given here ?

link> Prepare Your SD Card

CHDK For Newbies - How To Install with Card Tricks

For your camera,  you can try SDMinste.exe rather than Card Tricks.
http://stereo.jpn.org/eng/sdm/file/common_files.zip
Using SDMinste to Create Dual Partition SD cards
« Last Edit: 10 / July / 2012, 20:04:18 by waterwingz »
Ported :   A1200    SD940   G10    Powershot N    G16

Re: IXUS 115 HS / ELPH 100 HS request - 1.00C firmware test results needed
« Reply #375 on: 11 / July / 2012, 00:12:56 »
Does anyone have an ixus115 camera with firmware 1.00c ?

I'm ready to submit this camera for inclusion in the autobuild.  With the patient help of dnw , we have finished cleaning up all the little details necessary in shooting.c and main.c  as well as providing a user configurable <ALT> key.

Test versions for firmware 1.01A,  1.01B/1.01C are confirmed to be working.

There have been 12 downloads of the version for the 1.00c firmware.  If you have that version,  please post here or message me to tell me if its working for you.

That's the final step before I can release this.  Thanks.

Ported :   A1200    SD940   G10    Powershot N    G16

Re: IXUS 115 HS / ELPH 100 HS request
« Reply #376 on: 11 / July / 2012, 03:13:17 »
@waterwingz

can you post the available working shutter speed and also the ISO here?

I am trying to use the camera on a bright sunny day with flash to avoid dark face, don't know how to setup the exposure in the most effective way

Re: IXUS 115 HS / ELPH 100 HS request
« Reply #377 on: 11 / July / 2012, 06:23:11 »
I have IXUS 115 HS with firmware 100c. The ixus115_elph100hs-100c-1.1.0-alpha11 works fine. Thank You.


Re: IXUS 115 HS / ELPH 100 HS request
« Reply #378 on: 11 / July / 2012, 08:30:40 »
There was a problem concerning actions in the file manager. I've boiled it down to most problems being connected to image files, which have been shot in the active session and before switching to playback mode.
Reproduce:
  • (fresh formatted and prepared card)
  • Switch camera on
  • make a picture (or more)
  • switch to playback mode and back to record mode
  • make some more images
  • switch to alt mode ( ! you are still in record mode ! )
  • call file manager
  • go to the folder with the images
  • delete one (or more) of the second image series (or the folder with
    these)
  • leave file manager and alt mode
  • switch the camera to playback mode:
  • it shows "busy"
  • after a ~ second, the camera switches off: the objective is still in
     shooting position.
The counter test:
same as before, but delete an image (or images) of the first series (or a folder with these): You can now switch to playback mode and the camera will only display a message "unidentified image" for every expected but deleted image file.
The camera keeps a list of actually shot images in it's RAM. When you switch to playback mode, the camera writes the info from RAM to the card. It makes a file for every images folder in a/DCIM/CANONMSC/, the files have the names M0###.CTG, where "###" are the first three digits of the corresponding images folder. This file is always created/updated (and read), when you switch to playback mode (and also, when you startup in playback mode).

In the first test: When you make another image after the file manager action, you can switch to playback mode without the camera switching off.

Ruedi

Oh - forgot: happy coding!
« Last Edit: 11 / July / 2012, 08:54:14 by RueLue »
Ixus 115 HS / firmw.1.01b - using and testing the new beta - CHDK-beginner - Europe

*

Offline reyalp

  • ******
  • 14037
Re: IXUS 115 HS / ELPH 100 HS request
« Reply #379 on: 11 / July / 2012, 16:19:27 »
There was a problem concerning actions in the file manager. I've boiled it down to most problems being connected to image files, which have been shot in the active session and before switching to playback mode.
Thanks for your careful testing. Does this crash generate a ROMLOG ? http://chdk.wikia.com/wiki/Debugging#Camera_crash_logs_.28romlog.29
Don't forget what the H stands for.

 

Related Topics