IXUS 115 HS / ELPH 100 HS request - page 41 - DryOS Development - CHDK Forum supplierdeeply

IXUS 115 HS / ELPH 100 HS request

  • 538 Replies
  • 181835 Views
Re: IXUS 115 HS / ELPH 100 HS request
« Reply #400 on: 14 / July / 2012, 10:01:06 »
Advertisements
Choosing symbols file icon_16.rbf leads to icons not shown in the menus. Sometimes they reappear, when I choose icon_10.rbf, sometimes I need to switch the camera of and on again, but at other times, I

With the in-built font you can only use icon_10.rbf. icon_16.rbf is for bigger self choosen fonts and works not with the in-built font. In this case CHDK turns off the menu option 'Enable Symbols'.

Oh! Thank you! So splitting visual appearance in two menus leads to some irritation. NoScript (Firefox addon) uses the solution, that some menu topics are in two tabs (at first irritating), so that it is equal, where you change it, but you cannot overlook it.
Ruedi

Edit: just I looked into the NoScript settings and couldn't find this - I wonder if I really saw this some time in the past or just thought it is twice, but it meant something other.
« Last Edit: 14 / July / 2012, 11:46:16 by RueLue »
Ixus 115 HS / firmw.1.01b - using and testing the new beta - CHDK-beginner - Europe

*

Offline reyalp

  • ******
  • 13675
Re: IXUS 115 HS / ELPH 100 HS request
« Reply #401 on: 14 / July / 2012, 14:19:08 »
The display of menu and file manager (alt mode) are often flickering. Sometimes also parts of the menu are disappearing: a block cut out, sometimes the whole menu disappears, moving the marker lets it appear gain. And all while the display is flickering (not the Canon-part of the display, only the CHDK-foreground). Up to now I couldn't see the rules for this and the only idea I have is, that it is connected to a low battery. I'll try to make pictures (or a movie) of it.
Without actually seeing, it's hard to be certain, but this is probably normal. The CHDK drawing and Canon drawing are not really coordinated.
Quote
File manager: Files with a non-ascii letter (e.g. ä, ü, é, ĝ) are sometimes not in the files list; now, when I tried it again, they were shown with cryptic characters and are seemingly not accessible: file size "? ? ?". But this is not really a problem.
Using names like this is probably a bad idea, the Canon OS normally uses very simple names.

Don't know about the other items in your list off the top of my head.

Quote
1,01b-1.1.0r1983: Oh - I just tried the firmware update method to load CHDK, but "Update File Error!!!" (Canon message). The ps.fi2 is there!
This suggests the FI2 encoding is set wrong. Will check.
Don't forget what the H stands for.

Re: IXUS 115 HS / ELPH 100 HS request
« Reply #402 on: 14 / July / 2012, 14:41:55 »
The display of menu and file manager (alt mode) are often flickering. Sometimes also parts of the menu are disappearing: a block cut out, sometimes the whole menu disappears, moving the marker lets it appear gain. And all while the display is flickering (not the Canon-part of the display, only the CHDK-foreground). Up to now I couldn't see the rules for this and the only idea I have is, that it is connected to a low battery. I'll try to make pictures (or a movie) of it.
Without actually seeing, it's hard to be certain, but this is probably normal. The CHDK drawing and Canon drawing are not really coordinated.
You can confirm that its "normal" behavior if it happens mostly in shooting mode and not in playback mode.
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline reyalp

  • ******
  • 13675
Re: IXUS 115 HS / ELPH 100 HS request
« Reply #403 on: 14 / July / 2012, 14:57:29 »
1,01b-1.1.0r1983: Oh - I just tried the firmware update method to load CHDK, but "Update File Error!!!" (Canon message). The ps.fi2 is there!
This suggests the FI2 encoding is set wrong. Will check.
Turns out the platform ID was set wrong (according to the sigfinder). This should be double plus good fixed in changeset 1984.

You can confirm that its "normal" behavior if it happens mostly in shooting mode and not in playback mode.
More specifically, if it happens when the Canon firmware is doing something that redraws the screen, e.g. drawing the face rectangles. Maybe blinking the battery icon too (not sure if canon does this with palette manipulation ?)
« Last Edit: 14 / July / 2012, 14:59:49 by reyalp »
Don't forget what the H stands for.


Re: IXUS 115 HS / ELPH 100 HS request
« Reply #404 on: 15 / July / 2012, 12:48:15 »
Thanks waterwingz for the beta! :D

When I select the video button for alt mode, the play button - while in alt mode - has lost it's function.
I'm confused.   Why do you need the Play button in  <ALT> mode ?  What am I missing ?
Me too! sort of need that thing. (Getting used to get into the play mode by pressing keys in rapid succession!) so won't be a great problem. Video key is working nicely to get into Alt mode! Still I wish to know, why not use the relatively redundant [Disp.] key for Alt mode?

After approximately an hour of trying to make a script with set_focus, I finally found out that there's already working manual focus on WW's firmware!
That's something really awesome! A great news for Macro lovers! The macro autofocus was so difficult and there was greater degree of focus error in it. Now I can click macros seamlessly using this function. :lol

Well, firmware update method not working. Also zoom still doesn't work while in Alt mode? (does that work in any other chdk?)
Ixus 115 HS / firmware 1.01c

Re: IXUS 115 HS / ELPH 100 HS request
« Reply #405 on: 15 / July / 2012, 13:32:05 »
Quote
Well, firmware update method not working.
Auto-build server (trunk part) is out of order at the moment, so we need to wait for the corrected chdk build.
Quote
Also zoom still doesn't work while in Alt mode? (does that work in any other chdk?)
I think when you start a script, zooming should already be done and the camera prepared for the shot.

Flickering of the chdk osd and menus:
You can confirm that its "normal" behavior if it happens mostly in shooting mode and not in playback mode.
More specifically, if it happens when the Canon firmware is doing something that redraws the screen, e.g. drawing the face rectangles. Maybe blinking the battery icon too (not sure if canon does this with palette manipulation ?)
I searched through the forum and found two threads, where the coders point to the two buffers for the display. ( http://chdk.setepontos.com/index.php?topic=4348.msg42344#msg42344 and http://chdk.setepontos.com/index.php?topic=1049.msg10185#msg10185 ) where chdk doesn't know, which one is active.

Ruedi
Ixus 115 HS / firmw.1.01b - using and testing the new beta - CHDK-beginner - Europe

Re: IXUS 115 HS / ELPH 100 HS request
« Reply #406 on: 15 / July / 2012, 14:59:47 »
Still I wish to know, why not use the relatively redundant [Disp.] key for Alt mode?
We tried that during the alpha test phase and it was rejected for being too hard to use.  The problem is that the Disp key is also the "Down" key.  So when you are trying to go through the CHDK menus,  if you don't hold the button down long enough, you get dropped out of <ALT> mode.

Quote
Well, firmware update method not working.
Fixed in the current svn version.  Should be in the autobuild soon.

Quote
Also zoom still doesn't work while in Alt mode? (does that work in any other chdk?)
CHDK prevents all the camera keys in <ALT>  mode from reaching the Canon firmware so that you can use them in your scripts.
Ported :   A1200    SD940   G10    Powershot N    G16

Re: IXUS 115 HS / ELPH 100 HS request
« Reply #407 on: 15 / July / 2012, 18:57:05 »
I don't claim to know much about all the technical details of what is going on here, but I just wanted to say that I am able to load CHDK on my ELPH 100HS (100C) and use it for exposure bracketing which is awesome. Thanks so much for your hard work on this!


Re: IXUS 115 HS / ELPH 100 HS request
« Reply #408 on: 15 / July / 2012, 19:08:06 »
I don't claim to know much about all the technical details of what is going on here, but I just wanted to say that I am able to load CHDK on my ELPH 100HS (100C) and use it for exposure bracketing which is awesome. Thanks so much for your hard work on this!
Thanks for the note.  Not many CHDK ixus115 owners seem to have f/w 1.00C so its good to get a report that its working.

Ported :   A1200    SD940   G10    Powershot N    G16

Re: IXUS 115 HS / ELPH 100 HS request
« Reply #409 on: 15 / July / 2012, 20:09:32 »
Could someone point me on how to use manual focus on this camera? I must be doing something wrong since I can't get this to work.

BTW, I've build lens profiles (ACR/LR) for all focal length/zoom steps and it works very well. Drop me a line if interested.

 

 

Related Topics