IXUS 115 HS / ELPH 100 HS request - page 45 - DryOS Development - CHDK Forum  

IXUS 115 HS / ELPH 100 HS request

  • 538 Replies
  • 169793 Views
*

Offline jamesqf

  • *
  • 10
  • ELPH 100HS
Re: IXUS 115 HS / ELPH 100 HS request
« Reply #440 on: 31 / July / 2012, 01:52:19 »
Advertisements
Help!  I'm trying to get CHDK running on my camera.  It loads, and some functions sort of work, but I can't get to the CHDK menu.  I've discussed this at some length with waterwings on a thread in the newbie section: http://chdk.setepontos.com/index.php?topic=8426.new#new 

Briefly, I can load CHDK via firmware update method.  In shooting mode, I get the OSD, and of the functions described in the PDF Quick Start manual (pg 7):
  Half shutter + right toggles OSD
  Half shutter + down toggles histogram
I also have a sort of zebra display, but with orange blobs instead of stripes.

However, I don't get an <ALT> symbol, or any access to CHDK menus or functions other than those above.  Can anyone suggest what might be wrong, or have similar issues?

I do have most recent (as of earlier today) beta 2023 of the 101c software.

Re: IXUS 115 HS / ELPH 100 HS request
« Reply #441 on: 31 / July / 2012, 09:41:26 »
However, I don't get an <ALT> symbol, or any access to CHDK menus or functions other than those above.  Can anyone suggest what might be wrong, or have similar issues?

i have a version from a week or 2 ago.  i now have mine set to go into the CHDK menus with the video button, but the firmware comes with a 2-button press to get to the <ALT> screen: i press the FUNC. SET button, and while holding that down, toggle the zoom lever briefly all the way to the right (telephoto).  Then the red <ALT> marker shows up at the bottom of the screen, and i let go the FUNC.SET button and hit the MENU button to get into the CHDK menus.  From there i go to the Miscellaneous Stuff menu, where the <ALT> mode button can be set.  i change that to Video.

Then i go into the OSD Parameters submenu and set up the user menu and get it to show up directly instead of the <ALT> mode screen.

EDIT:  The online CHDK manual here goes into detail abt how to set up the user menu.
« Last Edit: 31 / July / 2012, 09:51:34 by bensoo »

*

Offline jamesqf

  • *
  • 10
  • ELPH 100HS
Re: IXUS 115 HS / ELPH 100 HS request
« Reply #442 on: 31 / July / 2012, 13:41:40 »
i have a version from a week or 2 ago.  i now have mine set to go into the CHDK menus with the video button, but the firmware comes with a 2-button press to get to the <ALT> screen: i press the FUNC. SET button, and while holding that down, toggle the zoom lever briefly all the way to the right (telephoto).  Then the red <ALT> marker shows up at the bottom of the screen, and i let go the FUNC.SET button and hit the MENU button to get into the CHDK menus.  From there i go to the Miscellaneous Stuff menu, where the <ALT> mode button can be set.  i change that to Video.

Yay!  I think that worked.  It's a little tricky, and doesn't work every time, but I did get it to pop up the CHDK script menu.  From there I select Back, and get a screen with the orange <ALT> at the bottom.  I'll play around with it some more and see if I can get it down to be repeatable.  Thanks!

Re: IXUS 115 HS / ELPH 100 HS request
« Reply #443 on: 31 / July / 2012, 13:48:46 »
Yay!  I think that worked. 
Hmmm ... that means the default setting is not what I thought it would be. 

In any case,  once you get to <ALT> mode,  I suggest you used the menus to change the <ALT> key to Play or Movie to make things easier.

Ported :   A1200    SD940   G10    Powershot N    G16


Re: IXUS 115 HS / ELPH 100 HS request
« Reply #444 on: 01 / August / 2012, 01:59:28 »
Yay!  I think that worked.  It's a little tricky, and doesn't work every time
Hey, that's great.

--If you don't remap the <ALT> mode button to something else, you'll have to repeat the same FUNC. SET button + zoom-to-telephoto toggle to get out of the <ALT> mode and back into regular cam operation.  If you do remap it then that button it's remapped to will get the cam into and out of <ALT> mode.

It can be a bit fiddly, but what a fantastic piece of software this CHDK is.  A truly worthwhile hack.

Re: IXUS 115 HS / ELPH 100 HS request
« Reply #445 on: 01 / August / 2012, 02:05:10 »
Then i go into the OSD Parameters submenu and set up the user menu and get it to show up directly instead of the <ALT> mode screen.

The User Menu is great.  It lets you group together in one menu all the settings you change the most, and then make it so that the User Menu directly shows up instead of the <ALT> mode screen, when you hit the <ALT> mode button.  Then everything's just one button press away.

*

Offline jamesqf

  • *
  • 10
  • ELPH 100HS
Re: IXUS 115 HS / ELPH 100 HS request
« Reply #446 on: 01 / August / 2012, 14:27:07 »
- If you do remap it then that button it's remapped to will get the cam into and out of <ALT> mode.

Did remap it to the playback button, and that seemed to work great in the little time I've had to play with it. 

Quote
It can be a bit fiddly, but what a fantastic piece of software this CHDK is.  A truly worthwhile hack.

A bit overwhelming, though.  All I really wanted to do (at least right away) is figure out how to do a manual focus so I could take closeup shots of wildflowers.  Canon's autofocus seems to be biased towards focusing on a distant background even if there's a closeup subject.

Then there's the whole question of ISO and shutter speeds.  Most of my real photography experience (anything beyond snapshots, IOW) dates back to the days when ISO was fixed by the roll of film you had in the camera.  Now it's another variable, and from my limited experience so far, seems biased to really low ISO and slow shutter speeds.

Anyway, it should be interesting!

Re: IXUS 115 HS / ELPH 100 HS request
« Reply #447 on: 03 / August / 2012, 17:56:38 »
- If you do remap it then that button it's remapped to will get the cam into and out of <ALT> mode.
Did remap it to the playback button, and that seemed to work great in the little time I've had to play with it. 
As of today (build 2041), the default <ALT> key is the Playback button (changed from the old default of SET + ZOOMIN).
Ported :   A1200    SD940   G10    Powershot N    G16


Re: IXUS 115 HS / ELPH 100 HS request
« Reply #448 on: 04 / August / 2012, 03:48:55 »
Then there's the whole question of ISO and shutter speeds.  Most of my real photography experience (anything beyond snapshots, IOW) dates back to the days when ISO was fixed by the roll of film you had in the camera.  Now it's another variable, and from my limited experience so far, seems biased to really low ISO and slow shutter speeds.

Anyway, it should be interesting!

It will indeed be interesting.  For one thing CHDK, with its Custom Auto ISO settings, will let you change all those AutoISO biases so it manipulates the sensor gain or ISO the way you want it to.  The CHDK user manual online here is very helpful abt these settings.

http://chdk.wikia.com/wiki/CHDK_User_Manual

That's interesting abt the AF: i'm not finding the same focus problem.  i put mine on center point AF and close distance focusing for macro-type photos works quite ok for me.

Re: IXUS 115 HS / ELPH 100 HS request
« Reply #449 on: 05 / August / 2012, 18:36:07 »
Irregular behavior of the file manager:
The file manager shows wrong rest of free place on "bigger" card (here 2Gb-card).
Affected: chdk 1.1 r.2053, and 1.2 r.2055 and already 1.2 r.2010 (oh and firmware 1.01b)
Replay: alt mode, call file manager: shows (in bottom right corner) size of free place on card, e.g. "1.93G (99%)"
make an image, call file manager: shows "1.81G (99%)";
make another image, file manager shows now "1,69G (98%)";
3 more images and it's "1.35G (98%)";
after some more images I'm back to "1.75G (98%)".
Every image has only ~1.1MBy size.
Percent of free place seems o.k., but the size in Gby changes every time and mostly to an inappropriate value. Repeated call of the file manager, switching to normal mode and back or switching the camera off and on doesn't change this behaviour. With a card of 256Mby I didn't observe this behavior.

Happy bug hunting (and thank you for your work)! Ruedi

Edit: the osd shows the correct value
Edit: made clear: bigger card means 2 GBy-card
« Last Edit: 05 / August / 2012, 22:21:03 by RueLue »
Ixus 115 HS / firmw.1.01b - using and testing the new beta - CHDK-beginner - Europe

 

Related Topics