Question about adding Eyefi-config code to CHDK build. - page 7 - General Discussion and Assistance - CHDK Forum  

Question about adding Eyefi-config code to CHDK build.

  • 84 Replies
  • 23840 Views
Re: Question about adding Eyefi-config code to CHDK build.
« Reply #60 on: 26 / September / 2013, 09:53:33 »
Advertisements
Quote
I agree that your solution might work.  Please do put it into your Eyefi code

Do you want me to post the .BIN for the SX150IS or a source patch file?

Re: Question about adding Eyefi-config code to CHDK build.
« Reply #61 on: 26 / September / 2013, 11:56:56 »
Hi buttim,
fastest way would be to post the .bin.  I am not very skilled at applying patches.
Jon

Do you want me to post the .BIN for the SX150IS or a source patch file?

Re: Question about adding Eyefi-config code to CHDK build.
« Reply #62 on: 26 / September / 2013, 12:04:31 »
fastest way would be to post the .bin.  I am not very skilled at applying patches.
Do you want me to post the .BIN for the SX150IS or a source patch file?

.BIN coming...

Re: Question about adding Eyefi-config code to CHDK build.
« Reply #63 on: 26 / September / 2013, 19:00:10 »
Some initial testing.
1. It sees the available and configured networks
2. If I click on a configured network it allows me to remove it, but if I decline to remove it still says it has removed it.
3. I need numbers and lowercase to connect to available networks.
4. Forcing the wlan on  or off seems to have no effect.  The Canon direct mode behavior is still the same.
  If I disable the card in the Canon menu turning on wlan in the CHDK menu has no effect.

Jon

« Last Edit: 26 / September / 2013, 19:04:12 by hiker_jon »


Re: Question about adding Eyefi-config code to CHDK build.
« Reply #64 on: 26 / September / 2013, 19:07:26 »
1. It sees the available and configured networks

Good!

2. If I click on a configured network it allows me to remove it, but if I decline to remove it still says it has removed it.

Very strange; I will check it

3. I need numbers and lowercase to connect to available networks.

The input box is a standard feature of CHDK; you can change character pressing the shoot button at half position, delete by zoomin out

4. Forcing the wlan on  or off seems to have no effect.  The Canon direct mode behavior is still the same

I'm experimenting myself and yes this doesn't really seem to work; I'll let you know; may be an untested functionality by Dave or a trivial bug by myself

Re: Question about adding Eyefi-config code to CHDK build.
« Reply #65 on: 27 / September / 2013, 04:48:32 »
I corrected a couple of mistakes. Now the wlan enable should work.
Updated binaries for the SX150is attached.
EDIT - I uploaded a better version (I just refactored the code for internationalization)
« Last Edit: 27 / September / 2013, 09:57:41 by buttim »

Re: Question about adding Eyefi-config code to CHDK build.
« Reply #66 on: 27 / September / 2013, 12:00:27 »
Success!
When I disable the card in the Canon menu and enable the wlan in CHDK the card works beautifully to transfer in direct mode.  Transfers are quick.

Last night I figured out the text input and used CHDK to connect to a network.  Just after I got a success message the camera shut down.  This happened twice.

Today with your new build I entered the same password, but it gave a wrong password message.

When I disabled a network (that I had setup using the eyefi center code on my laptop) the Canon menu no longer saw it, but the card still sees it and transfers to it.

Good Work!  This makes the card functional for many Powershots.
Jon

Re: Question about adding Eyefi-config code to CHDK build.
« Reply #67 on: 27 / September / 2013, 14:45:24 »
Maybe I'm somehow interfering with the camera dialogue to the eyefi, so the camera rebooted because of an unexpected situation; If you want to play safe you'd better turn off wlan with the camera's menus, then force it on and do whatever you want.
Keep trying and reporting strange behaviors, please


Re: Question about adding Eyefi-config code to CHDK build.
« Reply #68 on: 27 / September / 2013, 15:42:30 »
Hi,
I tried turning it off in Canon menu.  CHDK was able to see the available networks, but I still got a wrong password message when I tried to connect.  I think I am entering the right password because I tried the old code again and it connected.  It did not shut down this time so the shutdown might be a random thing.  Of course in the old code I needed to use the Canon menu to turn the wlan on.  The Canon menu does not see the new connection, but the eye-fi card uses it to transfer images.

If you want to play safe you'd better turn off wlan with the camera's menus, then force it on and do whatever you want.

Re: Question about adding Eyefi-config code to CHDK build.
« Reply #69 on: 28 / September / 2013, 18:05:58 »
I corrected a couple of mistakes. Now the wlan enable should work.
Updated binaries for the SX150is attached.
EDIT - I uploaded a better version (I just refactored the code for internationalization)
Are you "up" to doing a patch file now or would you prefer to post the code and have me do it again?
Ported :   A1200    SD940   G10    Powershot N    G16

 

Related Topics