Bug - Synch Delay time options do nothing

  • 30 Replies
  • 2842 Views
*

Offline reyalp

  • ******
  • 9957
  • Publish
    Re: Bug - Synch Delay time options do nothing
    « Reply #10 on: 11 / September / 2011, 23:00:14 »
    Advertisements
    Took me a bit, but I got the source downloaded and my environment setup. Now I just have to find the code I need to change.

    I have no idea how to submit a patch, if I end up getting the bug fixed. That's for later, though. Now, to code!
    FWIW, if you want some realtime advice, you can sometimes find us in #chdk on irc.freenode.net

    A630 actually users the generic version of platform/...kbd.c so changes there would affect a lot of cameras. But if it's a generic fix, that's a good thing I guess.
    Don't forget what the H stands for.

  • Publish
    Re: Bug - Synch Delay time options do nothing
    « Reply #11 on: 12 / September / 2011, 07:37:29 »
    A630 actually users the generic version of platform/...kbd.c so changes there would affect a lot of cameras. But if it's a generic fix, that's a good thing I guess.

    Of course, it would be easy to expand the A630 camera specific kbd.c file to look more like the A650 and delete the reference to the generic\kbd.c

    *

    Offline vnd

    • *
    • 36
  • Publish
    Re: Bug - Synch Delay time options do nothing
    « Reply #12 on: 04 / December / 2011, 05:37:44 »
    The main problem is that the delay loop speed is compiler dependent. New gcc even optimizes it out completely.

    The attached patch fixes it for s95. A similar fix should be applied for other cameras too, but I can't test it.



  • Publish
    Re: Bug - Synch Delay time options do nothing
    « Reply #13 on: 04 / December / 2011, 10:12:14 »
    The main problem is that the delay loop speed is compiler dependent. New gcc even optimizes it out completely.

    The attached patch fixes it for s95. A similar fix should be applied for other cameras too, but I can't test it.

    Did you see this thread ?

    http://chdk.setepontos.com/index.php?topic=7127.msg76626#msg76626

    Lots of other broken things to think about in that code right now.



    *

    Offline vnd

    • *
    • 36
  • Publish
    Re: Bug - Synch Delay time options do nothing
    « Reply #14 on: 04 / December / 2011, 11:46:37 »

  • Publish
    Re: Bug - Synch Delay time options do nothing
    « Reply #15 on: 22 / June / 2012, 06:04:44 »
    hi VND,

    the patch you released is exactly what I would need,
    how do i apply it?

    thx

  • Publish
    Re: Bug - Synch Delay time options do nothing
    « Reply #16 on: 22 / June / 2012, 06:15:45 »
    You have to compile your own CHDK for applying patches. You'd need to have CHDK source.

    If you have Windows machine you can simply use CHDK-Shell to compile CHDK. Check:

    http://chdk.wikia.com/wiki/Compiling_CHDK_under_Windows
    if (2*b || !2*b) {
        cout<<question
    }

    Compile error: poor Yorick

  • Publish
    Re: Bug - Synch Delay time options do nothing
    « Reply #17 on: 22 / June / 2012, 07:38:34 »
    the patch you released is exactly what I would need,
    how do i apply it ?
    You probably want to look at the main development trunk of CHDK ( http://mighty-hoernsche.de/trunk/ )  rather than the stable version.  The USB code there was completely rewritten to be workable and understandable.   It also  incorporates the code from vnd's patch.

    Documentation available here : USB_Remote_V2
    « Last Edit: 22 / June / 2012, 08:08:48 by waterwingz »


  • Publish
    Re: Bug - Synch Delay time options do nothing
    « Reply #18 on: 22 / June / 2012, 08:49:47 »
    thanks i tried it (build 1928)
    but for strange reasons it seems that the ENABLE SYNCH feature does not work,
    camera shoots at trigger pressure and not at trigger-release...

    I tried all the combinations of tha available options but nothing...
    Am I missing something?

  • Publish
    Re: Bug - Synch Delay time options do nothing
    « Reply #19 on: 22 / June / 2012, 08:54:52 »
    thanks i tried it (build 1928)
    but for strange reasons it seems that the ENABLE SYNCH feature does not work,
    camera shoots at trigger pressure and not at trigger-release...

    I tried all the combinations of tha available options but nothing...
    Am I missing something?
    Which version did you try ?

    http://chdk.wikia.com/wiki/Downloads

    Stable or Unstable ?  ( The same build # applies to both versions.)

    What are you using for a USB switch device ?

    Are you trying to use a script or the built-in functionality ?

    And how exactly did you setup the option in the Remote Parameters menu ?
    « Last Edit: 22 / June / 2012, 09:24:43 by waterwingz »

     

    Related Topics