Bug: A550 "mode dial" mismatch - General Discussion and Assistance - CHDK Forum
supplierdeeply

Bug: A550 "mode dial" mismatch

  • 5 Replies
  • 1835 Views
Bug: A550 "mode dial" mismatch
« on: 04 / October / 2011, 09:48:38 »
Advertisements
Whenever I activate CHDK, I'm not able to use video mode since it switches to night scene mode.
I also found other mismatches between normal modes and CHDK modes:

Manual               -> Manual

Auto                  -> Auto

Portrait               -> Auto

Landscape           -> Auto

NightSnapShot    -> Manual

Kids&Pets           -> Kids&Pets

Indoor                -> Indoor

Night Scene        -> Night Scene

Video                  -> Night Scene

I remember that old CHDK builds had no these kind of issues but I couldn't find them in my program archive.

*

Offline reyalp

  • ******
  • 12690
Re: Bug: A550 "mode dial" mismatch
« Reply #1 on: 09 / October / 2011, 00:41:57 »
Whenever I activate CHDK, I'm not able to use video mode since it switches to night scene mode.
I also found other mismatches between normal modes and CHDK modes:
I don't understand what you mean by "CHDK" modes.

CHDK shouldn't affect your what happens when you select a mode on the mode dial.
Don't forget what the H stands for.

Re: Bug: A550 "mode dial" mismatch
« Reply #2 on: 09 / October / 2011, 09:10:42 »
Sorry for my english.

I'm trying to explain step by step:

I enable the Video mode by the dial before pressing alt button (video-camera icon appears on screen)

Then, I press alt button but this time, night scene icon appears on screen.

To go back video mode, I have to press alt button again.


Also I found another problem:

I normally use zoom feature of my camera before pressing alt button but after pressing alt button, zoom functions of shutter button don't work. Therefore I use scripts to assign zoom functions to other buttons.

I don't know why these problems happen, maybe my camera has some problems but mode dial problem also has been reported by forum member ynaig.

http://chdk.setepontos.com/index.php?topic=230.msg5427#msg5427

One bug is that when I enable the Video mode by the dial, and I push the  ALT button, it doesn't switch to ALT mode, just it keeps switching to Night scene, and then pressing again ALT button, it goes back to Movie mode (obviously also the ALT mode will be enabled, but the mode will be Night Scene, not the Video Mode which is what I want).




*

Offline reyalp

  • ******
  • 12690
Re: Bug: A550 "mode dial" mismatch
« Reply #3 on: 10 / October / 2011, 01:35:40 »
Quote
I enable the Video mode by the dial before pressing alt button (video-camera icon appears on screen)

Then, I press alt button but this time, night scene icon appears on screen.

To go back video mode, I have to press alt button again.
So as soon as you enter alt mode, the camera changes to night scene ?

It sounds like physw_status bits are  getting messed up,  but I'm not sure how.  I don't see any related code that has changed in a long time.
Quote
I normally use zoom feature of my camera before pressing alt button but after pressing alt button, zoom functions of shutter button don't work.
Just to be clear, you mean after entering and leaving alt mode once, the zoom buttons do not work ? In alt mode, buttons should not be expected to have normal canon functions.
Don't forget what the H stands for.


Re: Bug: A550 "mode dial" mismatch
« Reply #4 on: 10 / October / 2011, 03:42:27 »
Quote
So as soon as you enter alt mode, the camera changes to night scene ?

Yes, for this reason I never use video mode in alt mode.

Quote
Just to be clear, you mean after entering and leaving alt mode once, the zoom buttons do not work ? In alt mode, buttons should not be expected to have normal canon functions.

Zoom buttons work after exiting from alt mode.

In alt mode, zoom buttons don't work but I can use "up" button for "zoom in" and "down" button for "zoom out" by using a script.
 

*

Offline reyalp

  • ******
  • 12690
Re: Bug: A550 "mode dial" mismatch
« Reply #5 on: 13 / October / 2011, 00:46:23 »
Quote
So as soon as you enter alt mode, the camera changes to night scene ?
Yes, for this reason I never use video mode in alt mode.
That definitely sounds like a bug.
Quote
Quote
Just to be clear, you mean after entering and leaving alt mode once, the zoom buttons do not work ? In alt mode, buttons should not be expected to have normal canon functions.
Zoom buttons work after exiting from alt mode.

In alt mode, zoom buttons don't work but I can use "up" button for "zoom in" and "down" button for "zoom out" by using a script.
This sounds like expected behavior, not a bug. In general, keys do not have their normal function in alt mode, the whole point of alt mode is to access other functions. On some cameras, zoom keys in alt mode are used to provide MF.

You should be able to detect zoom in and zoom out in a script the same way you catch up and down.
Don't forget what the H stands for.

 

Related Topics