supplierdeeply

Powershot SX150 IS Porting Thread

  • 279 Replies
  • 50395 Views
Re: Powershot SX150 IS Porting Thread
« Reply #120 on: 20 / January / 2012, 10:27:39 »
Advertisements
I tested it this morning: Behavior is same, no raw saved.
Jon


Try the attached test version.

Phil.

Update: replaced the attachment. Previous version was missing the changes added earlier by reyalp.


*

Online philmoz

  • *****
  • 3070
    • Photos
Re: Powershot SX150 IS Porting Thread
« Reply #121 on: 20 / January / 2012, 15:21:46 »
I tested it this morning: Behavior is same, no raw saved.
Jon


Try the attached test version.

Phil.

Update: replaced the attachment. Previous version was missing the changes added earlier by reyalp.


Can you post all the settings from the RAW Parameters menu, and which mode the camera is in (Auto, P, etc).
Also try running the 'Create badpixel.bin' command from the same menu and let me know what happens (will help determine where it's getting in the code).

Phil.
CHDK ports:
  sx30is (1.00c, 1.00h, 1.00l, 1.00n & 1.00p)
  g12 (1.00c, 1.00e, 1.00f & 1.00g)
  sx130is (1.01d & 1.01f)
  ixus310hs (1.00a & 1.01a)
  sx40hs (1.00d, 1.00g & 1.00i)
  g1x (1.00e, 1.00f & 1.00g)

Re: Powershot SX150 IS Porting Thread
« Reply #122 on: 21 / January / 2012, 01:39:50 »
I delete cchdk.cfg before starting so all is the default except I turn save raw on.
exceptions: non checked, warn on, crw,.cr2,... dng not checked.

When I execute create badpixel.bin it takes one picture that is all.  the file is not created.

Jon


Can you post all the settings from the RAW Parameters menu, and which mode the camera is in (Auto, P, etc).
Also try running the 'Create badpixel.bin' command from the same menu and let me know what happens (will help determine where it's getting in the code).

Phil.


*

Online philmoz

  • *****
  • 3070
    • Photos
Re: Powershot SX150 IS Porting Thread
« Reply #123 on: 21 / January / 2012, 01:53:31 »
I delete cchdk.cfg before starting so all is the default except I turn save raw on.
exceptions: non checked, warn on, crw,.cr2,... dng not checked.

When I execute create badpixel.bin it takes one picture that is all.  the file is not created.

Jon


Can you post all the settings from the RAW Parameters menu, and which mode the camera is in (Auto, P, etc).
Also try running the 'Create badpixel.bin' command from the same menu and let me know what happens (will help determine where it's getting in the code).

Phil.


When you start CHDK does the splash logo show straight away or only after about 4 seconds?
In AV or TV mode, if you enter CHDK <ALT> mode then turn the rear dial does the Canon AV or TV value still change?

I know these are unrelated; but will help me track the source of the problem. The boot code does not look correct to me so I'm trying to see if the CHDK tasks are running.

Phil.
CHDK ports:
  sx30is (1.00c, 1.00h, 1.00l, 1.00n & 1.00p)
  g12 (1.00c, 1.00e, 1.00f & 1.00g)
  sx130is (1.01d & 1.01f)
  ixus310hs (1.00a & 1.01a)
  sx40hs (1.00d, 1.00g & 1.00i)
  g1x (1.00e, 1.00f & 1.00g)


Re: Powershot SX150 IS Porting Thread
« Reply #124 on: 21 / January / 2012, 11:10:06 »
I'm following this thread now, having the same problem. Perhaps I can also help in some way.
After switching on, it takes some seconds and then the orange CHD.. appears.
IN AV and TV mode, going to CHDK <alt>, AV and TV are still changing.
Can I do additional tests for you?

hc

Re: Powershot SX150 IS Porting Thread
« Reply #125 on: 21 / January / 2012, 12:00:41 »
It does take 4 secs for the logo to appear. I had noticed the delay.  When in <alt> mode and Av or Tv the aperture or shutter speed still change when you move the back dial.
Jon

When you start CHDK does the splash logo show straight away or only after about 4 seconds?
In AV or TV mode, if you enter CHDK <ALT> mode then turn the rear dial does the Canon AV or TV value still change?

I know these are unrelated; but will help me track the source of the problem. The boot code does not look correct to me so I'm trying to see if the CHDK tasks are running.

Phil.


Re: Powershot SX150 IS Porting Thread
« Reply #126 on: 21 / January / 2012, 12:11:56 »
Yes, still changing, even in <alt> mode.

hc

*

Online philmoz

  • *****
  • 3070
    • Photos
Re: Powershot SX150 IS Porting Thread
« Reply #127 on: 21 / January / 2012, 15:42:46 »
It does take 4 secs for the logo to appear. I had noticed the delay.  When in <alt> mode and Av or Tv the aperture or shutter speed still change when you move the back dial.
Jon

That's what I thought. This means that none of the task overrides are being activated so most of the advanced CHDK functions won't work.

I'll need to review all the code before activating the tasks, since they may crash the camera if they have not been done correctly. I don't have this camera so I can't test any changes directly.

Keep watching this space for updates :)

Phil.

Update: The task code looks ok, attached is another test version (fingers crossed).

« Last Edit: 21 / January / 2012, 16:50:56 by philmoz »
CHDK ports:
  sx30is (1.00c, 1.00h, 1.00l, 1.00n & 1.00p)
  g12 (1.00c, 1.00e, 1.00f & 1.00g)
  sx130is (1.01d & 1.01f)
  ixus310hs (1.00a & 1.01a)
  sx40hs (1.00d, 1.00g & 1.00i)
  g1x (1.00e, 1.00f & 1.00g)


Re: Powershot SX150 IS Porting Thread
« Reply #128 on: 21 / January / 2012, 17:23:55 »
The logo appears right away now and the aperture and shuutter speed settings do not change in <alt> mode, but raw is still broken, behaves the same.


Update: The task code looks ok, attached is another test version (fingers crossed).


*

Online philmoz

  • *****
  • 3070
    • Photos
Re: Powershot SX150 IS Porting Thread
« Reply #129 on: 21 / January / 2012, 17:38:14 »
The logo appears right away now and the aperture and shuutter speed settings do not change in <alt> mode, but raw is still broken, behaves the same.


Update: The task code looks ok, attached is another test version (fingers crossed).


Does the 'create badpixel.bin' option work now?
Also try setting the option to save the RAW in the same directory as the JPEG.

Phil.
CHDK ports:
  sx30is (1.00c, 1.00h, 1.00l, 1.00n & 1.00p)
  g12 (1.00c, 1.00e, 1.00f & 1.00g)
  sx130is (1.01d & 1.01f)
  ixus310hs (1.00a & 1.01a)
  sx40hs (1.00d, 1.00g & 1.00i)
  g1x (1.00e, 1.00f & 1.00g)

 

Related Topics