Powershot SX150 IS Porting Thread

  • 279 Replies
  • 44425 Views
*

Offline reyalp

  • ******
  • 10949
Re: Powershot SX150 IS Porting Thread
« Reply #270 on: 30 / September / 2015, 22:45:21 »
Advertisements
Hears a test build with rear curtain define enabled. Please check if it actually has the expected effect on when the flash fires.
Don't forget what the H stands for.

Re: Powershot SX150 IS Porting Thread
« Reply #271 on: 04 / October / 2015, 22:09:29 »
Tested it - so far it from what I've tried it works perfectly - thanks!

Re: Powershot SX150 IS Porting Thread
« Reply #272 on: 04 / October / 2015, 22:15:32 »
Tested it - so far it from what I've tried it works perfectly - thanks!
I know nothing about flash sync.  How does one test this?  What do you expect to see that your don't get normally?

TIA.
Ported : A1200  SD940  G10  Powershot N  G16*

Re: Powershot SX150 IS Porting Thread
« Reply #273 on: 04 / October / 2015, 22:56:13 »
When rear curtain is enabled, the flash should fire at the end of the exposure rather than the beginning - so for example I've used it a lot for the northern lights or fireworks with people in the shot also - to get both the long exposure and then when the flash fires at the end of the exposure it freezes/draws out the people in the foreground clearly - also cool for moving subjects because the longer exposure will blur the motion but the flash at the back end of the exposure freezes the subject at the end ;)



Re: Powershot SX150 IS Porting Thread
« Reply #274 on: 04 / October / 2015, 23:02:41 »
When rear curtain is enabled, the flash should fire at the end of the exposure rather than the beginning
Okay - thanks.  I think I get it - you are using this with long exposures (more than a 2 seconds) to also freeze/illuminate things nearby at the end of the shot.

Ported : A1200  SD940  G10  Powershot N  G16*

*

Offline reyalp

  • ******
  • 10949
Re: Powershot SX150 IS Porting Thread
« Reply #275 on: 04 / October / 2015, 23:33:02 »
Tested it - so far it from what I've tried it works perfectly - thanks!
Thanks for confirming. I've checked this in so it will appear in the next autobuilds (trunk 4271, stable 4272)
Don't forget what the H stands for.

Re: Powershot SX150 IS Porting Thread
« Reply #276 on: 16 / November / 2015, 06:55:58 »
issue (trunk4175):
get_prop(props.DISPLAY_MODE) does not seem to work

discovered:
Canon Reset All re-enables the auto LCD off. In attempting this workround of that http://chdk.setepontos.com/index.php?topic=11038.msg108087#msg108087 - rather than just wait 10 secs, I included this check so a subsequent key press would re-enable the earlier call to LockMainPower

Code: [Select]
repeat
sleep(1000)
until get_prop(props.DISPLAY_MODE) == 2 --i.e. off
however, result was that the loop continued when lcd turned off.

A propcase compare dump, from 0 to 300, between lcd off & on reports only the not very useful:

                 prop off     on
1st run diff 273   921   912
2nd run diff 273   915   920

Is there another possible way to identify this or does it likely not exist?



Info:
Tested in record, M

In trunk4175 platform_camera.h, #define CAM_PROPSET -> 4
In propset4.h, #define PROPCASE_DISPLAY_MODE -> 105

Reset All & propcase discovery script used attached
« Last Edit: 16 / November / 2015, 08:21:04 by andrew.stephens.754365 »

Re: Powershot SX150 IS Porting Thread
« Reply #277 on: 30 / December / 2016, 06:35:41 »
I need to operate chdk while the battery/SD compartment door remains open.

If a kind dev were to provide the SX150IS:
  • battery cover index
  • battery cover flag
It would provide me a nice start to do something useful in the New Year  :)
« Last Edit: 30 / December / 2016, 07:09:13 by andrew.stephens.754365 »


*

Offline srsa_4c

  • ******
  • 3474
Re: Powershot SX150 IS Porting Thread
« Reply #278 on: 30 / December / 2016, 08:07:12 »
If a kind dev were to provide the SX150IS:
  • battery cover index
  • battery cover flag
It's in the official source (as comment).

Re: Powershot SX150 IS Porting Thread
« Reply #279 on: 30 / December / 2016, 10:59:33 »
It's in the official source (as comment).

Thanks!



Edit Update (for the record):

Since SX150IS chdk battery door operation is not currently supported I had automatically assumed it would not work. However, on testing, I found the camera still operational (in both record and play mode) around 5 minutes after starting the camera with the door open!

A related thread is this:
https://chdk.setepontos.com/index.php?topic=5744.0
« Last Edit: 31 / December / 2016, 05:00:03 by andrew.stephens.754365 »

 

Related Topics