Powershot SX150 IS Porting Thread

  • 279 Replies
  • 38300 Views
Re: Powershot SX150 IS Porting Thread
« Reply #50 on: 04 / December / 2011, 23:02:17 »
Advertisements
DISP+FUNC/SET puts it in alt mode. I have the sx 150. The only problem is nothing really works on it. You can use the simple shoot script that's about it besides the grids. It wont save RAWS or anything else "yet".

Make sure you hit DISP first. If you hit FUNC/SET first your left side menu will pop up and be stuck there. Then you will have to do it all over again. Not a big deal but annoying.
« Last Edit: 04 / December / 2011, 23:06:49 by Fathem »

Re: Powershot SX150 IS Porting Thread
« Reply #51 on: 04 / December / 2011, 23:31:31 »
Thanks Fathem,
I was always hitting func/set first.  Now it works for me.  I will start checking it out.

Jon
DISP+FUNC/SET puts it in alt mode. I have the sx 150. The only problem is nothing really works on it. You can use the simple shoot script that's about it besides the grids. It wont save RAWS or anything else "yet".

Make sure you hit DISP first. If you hit FUNC/SET first your left side menu will pop up and be stuck there. Then you will have to do it all over again. Not a big deal but annoying.

Re: Powershot SX150 IS Porting Thread
« Reply #52 on: 05 / December / 2011, 22:16:53 »
Suggestion for ALT key:
I find it a pain to need two hands to get into alt mode on this camera.  Has anyone already suggested SET+RIGHT instead of SET+DISP?  It works for me with just one thumb.
Just make this change to kbd.c:
Code: [Select]
{ 2, KEY_PRINT     , 0x00001400 }, // SET + RIGHT  was SET+DISP

Try it, you might like it.

Jon

Re: Powershot SX150 IS Porting Thread
« Reply #53 on: 05 / December / 2011, 22:25:42 »
Suggestion for ALT key:
I find it a pain to need two hands to get into alt mode on this camera.  Has anyone already suggested SET+RIGHT instead of SET+DISP?  It works for me with just one thumb.
Just make this change to kbd.c:
Code: [Select]
{ 2, KEY_PRINT     , 0x00001400 }, // SET + RIGHT  was SET+DISP

Try it, you might like it.

Jon

Does the SX150 support user changing of the ALT key ?  Its available in the CHDK core code but a developers has to enable it for the camera.

Also, why does the SX150 require a two button sequence in the first place ?   The camera has a DISP button - which many cameras use as the way to enter <ALT> mode on its own (a quick press gets <ALT> mode and you hold the DISP key down longer to get the Canon functions of brightness change and review display modes).   Recently there has been a push to use the Play button ( the one with the green triangle ) to enter <ALT> mode.    Either way, you get rid of the whole "two key sequence" nonsense.

http://chdk.setepontos.com/index.php?topic=6787.0
« Last Edit: 05 / December / 2011, 22:51:54 by waterwingz »


Re: Powershot SX150 IS Porting Thread
« Reply #54 on: 06 / December / 2011, 04:14:20 »
hi y'all. long time checker-outer, first time poster. i hope i'm posting in the right thread, and not pissin' anyone off by asking such newbie questions, but i've been lusting after the SX130is for a few months now, and i finally have the money to buy it, but now i see that there's the SX150is, and now i think i want that. however, i don't know how far along the CHDK for it is, since it's so much newer, or if maybe i could just use the one for the SX130is, or whatever. and would it be best to just get the SX130is, since the hack is farther along, or what? in case you haven't guessed, i've never hacked a camera before, and really have not much clue what i'm doing in this respect, but i really want the extra functions that i've been reading about, and especially the RAW, and exposure/aperture limits increased. also, where can i even get the hack for it anyway? i can't seem to find anywhere to download anything. there's nothing in the "downloads" section. is there a CHDK for dummies tutorial for this camera, or something? if anyone would see their way fit to give me a hand with that stuff, i sure would appreciate it. thanks a bunch.
« Last Edit: 06 / December / 2011, 04:15:59 by Arajmahad »

Re: Powershot SX150 IS Porting Thread
« Reply #55 on: 06 / December / 2011, 06:52:20 »
You are correct in your assumption that the sx130 is much better supported today.  The sx150 is a really early release but will likely get better.  That said,  make sure you've read & understand the following :

link> CHDK FAQ : My camera isn't ported yet

You can find links for the current sx150 in this porting thread. The source code  is available from the CHDK SVN site but as it is an early release, an executable is not available as  from the autobuild server.

Here's some other reading for you :

link> CHDK for Dummies
link> CHDK UserGuide April 2009
link> CHDK Installation Guide


Re: Powershot SX150 IS Porting Thread
« Reply #56 on: 06 / December / 2011, 11:44:38 »
Thanks waterwingz for the link to the alt mode topic.  It seems to settle on using the play button if it exists.  I would do that but can't find a definition for KEY_PLAY for this camera.
How do I find out what the bit mask should be?  I assume there is a debugging tool for that, but I don't know what it is.

Edit: I see now that it is defined as KEY_PLAYBACK,but I still don't know the bit mask.  For this camera CAM_ADJUSTABLE_ALT_BUTTON is not defined.
I will define it and see what happens.

Also, why does the SX150 require a two button sequence in the first place ?   The camera has a DISP button - which many cameras use as the way to enter <ALT> mode on its own (a quick press gets <ALT> mode and you hold the DISP key down longer to get the Canon functions of brightness change and review display modes).   Recently there has been a push to use the Play button ( the one with the green triangle ) to enter <ALT> mode.    Either way, you get rid of the whole "two key sequence" nonsense.

http://chdk.setepontos.com/index.php?topic=6787.0

« Last Edit: 06 / December / 2011, 12:35:41 by hiker_jon »

Re: Powershot SX150 IS Porting Thread
« Reply #57 on: 06 / December / 2011, 13:07:17 »
How do I find out what the bit mask should be?  I assume there is a debugging tool for that, but I don't know what it is.
Bitmaps are reported in the stubs_entry.S file by the new sigfinder.

Quote
Edit: I see now that it is defined as KEY_PLAYBACK,but I still don't know the bit mask.  For this camera CAM_ADJUSTABLE_ALT_BUTTON is not defined.
I will define it and see what happens.
There are a couple of other files you will need to touch to add the keys available to the menu.


*

Offline philmoz

  • *****
  • 2936
    • Photos
Re: Powershot SX150 IS Porting Thread
« Reply #58 on: 06 / December / 2011, 14:12:25 »
How do I find out what the bit mask should be?  I assume there is a debugging tool for that, but I don't know what it is.
Bitmaps are reported in the stubs_entry.S file by the new sigfinder.


Only for a limited set of buttons. For most cameras you need to enable the physw_status display code in gui_draw_debug_vals_osd() and take note of which bits change when you press the buttons. Note that the bits are normally 1 and go to 0 in physw_status when the buttons are pressed.

Phil.
CHDK ports:
  sx30is (1.00c, 1.00h, 1.00l, 1.00n & 1.00p)
  g12 (1.00c, 1.00e, 1.00f & 1.00g)
  sx130is (1.01d & 1.01f)
  ixus310hs (1.00a & 1.01a)
  sx40hs (1.00d, 1.00g & 1.00i)
  g1x (1.00e, 1.00f & 1.00g)

Re: Powershot SX150 IS Porting Thread
« Reply #59 on: 06 / December / 2011, 15:18:02 »
Just enabling CAM_ADJUSTABLE_ALT_BUTTON didn't work.  It did add a gui menu item, but when I changed that to play it did not alter the original play functionality.  So I had no way to get into alt mode to try setting it to something else. 


There are a couple of other files you will need to touch to add the keys available to the menu.


 

Related Topics