SX40HS porting thread - page 12 - DryOS Development - CHDK Forum

SX40HS porting thread

  • 258 Replies
  • 91421 Views
Re: SX40HS porting thread
« Reply #110 on: 26 / March / 2012, 16:16:18 »
Advertisements
For everybody who still has problems using CHDK on the SX40:
  • Find out the firmware version of your camera: Start your camera, go to review mode and then press FUNC. + DISP. Your firmware version will be displayed like this: Ver GM1.00I. Important is the last letter, in my case the capitalized i. Don't press FUNC too long as the display will then show the time.
  • Download the according CHDK version from here: http://mighty-hoernsche.de/. Unpack it.
  • Take an SD (the size doesn't matter, can be larger than 4 GB) and format it. I've been told that it's best to format in the camera rather than in the pc but cannot confirm that.
  • Copy CHDK onto the card.
  • Set the small slider on the side of the SD card to "lock". Don't worry, you will still be able to safe pics.
  • Insert the card into the SX40. Switch it on by pressing the review button, not the normal ON/OFF switch. Go to MENU and to the last entry called "FIRM UPDATE". Select it. CHDK is now loaded and can be used.
  • If you wish CHDK to load automatically on every startup (which most ppl will), press the print/shortcut button and then MENU to access the CHDK menu. Go to the last menu (misc) and look for "make card  bootable".
That's it, you can now enjoy CHDK on the SX40. Don't forget to adjust the positions of the displayed OSD items to make it more appealing and efficient to use...

I've also got a question: does anyone already have settings for lightroom to process the DNGs to get rid of the distortion?
« Last Edit: 26 / March / 2012, 16:20:45 by one2three »

Re: SX40HS porting thread
« Reply #111 on: 26 / March / 2012, 17:46:30 »
Ported :   A1200    SD940   G10    Powershot N    G16

Re: SX40HS porting thread
« Reply #112 on: 27 / March / 2012, 03:40:10 »

Is it possible that we can use zoom lever for manual focusing while shooting..... ::)
it would be great.
flickr

"Saying a Camera takes Nice Pictures is like Saying a Guitar Plays Nice Melodies"

Re: SX40HS porting thread
« Reply #113 on: 27 / March / 2012, 13:02:26 »
Hey folks,

Just got my SX40IS today and first thing I want to do is install CHDK.  I am not entirely new to CHDK (used it with my S3IS a while ago), but am having a problem with my SX40HS.  It has the 1.00I firmware on it.

I've downloaded and installed everything onto a 16GB SDHC card.  No problems there, as far as I can tell.  What is happening is that when I have CHDK autoboot (which works from either the Play button or On/Off button), it won't come out of <ALT> mode.  No matter which way I turn on the camera, it starts in Play and will not go into Rec at all.  I know it is in <ALT> mode even though it doesn't display it at the bottom of the display, because if I press Menu, I get the CHDK menus and not the Canon menus.

Any help would be greatly appreciated.

Al


Re: SX40HS porting thread
« Reply #114 on: 27 / March / 2012, 15:31:59 »
Found a solution to my problem above.  I had been trying to use the Play button to switch back to Record mode.  I ended up pressing the video Record button and it put me back into a state where I could now take pictures.  Yeah!

Not sure what I have done in the setup, but all my pictures are coming out almost white with no detail at all.  Will try resetting everything back to its default and try again.

Also, I like to shoot HDR and was wondering if there is a setting that will allow me to shoot more than the standard 3 images, like 5, 7 or 9?  I think this was available on the S3IS CHDK, but am just going by my memory on this.

And as most everyone else has said, thank you for taking the time and effort in putting this great program together!

Al

Re: SX40HS porting thread
« Reply #115 on: 27 / March / 2012, 22:48:31 »
Hmmm...  seem to be answering my own questions today... LOL

Found how to shoot multiple images using AEB for HDR pictures.  From the main menu, I go to Extra Photo Operations.  Then I scroll down and select Bracketing in Continuous Mode.  From there, I set TV Bracketing Value to something like 1/3 EV for a large number of pictures or something like 2 if taking only 3 pictures.  Next, I go to the auto-timer settings and select custom.  Set the number of shots you want (e.g. 3 or 5 or 7 or 9).  I had the length of time before the pictures would start to be taken to 5 seconds.  A tripod would be best, but I was just doing this off the side of my desk.  Press the shutter halfway to focus and then press the shutter fully.  The camera will then start taking pictures after the specified number of seconds, each one differing by the bracketing amount.  Make sure your camera is on AV mode and you set the aperture to whatever desired F stop you want.  By using AV mode, the depth of field will remain constant.  Load the images into your favorite HDR program and go nuts.

Hope this all makes sense, I am tired and heading off to bed.

Nite nite...
Al

Re: SX40HS porting thread
« Reply #116 on: 28 / March / 2012, 10:54:22 »
Found how to shoot multiple images using AEB for HDR pictures.  From the main menu,...
FYI ..  this and other things are covered (but not as precisely) here : http://chdk.wikia.com/wiki/CHDK_for_Dummies#Bracketing

and here :  http://images3.wikia.nocookie.net/__cb20120105020429/chdk/images/6/62/CHDK_User_Quick_Start_Guide.pdf on page 49

along with a bunch of other handy stuff.
Ported :   A1200    SD940   G10    Powershot N    G16

Re: SX40HS porting thread
« Reply #117 on: 28 / March / 2012, 12:36:15 »
This is all brand new to me, but Computers (Macs) and Cameras are not. I just updated my old Canon SX1 and got a CanonSX40HS, and only did that because someone told me about this software I could use that would allow me to shoot in Raw. However, I've been all over the place in the CHDK info, tried various manual methods to load and install my version (1.00i), but CANNOT get a menu item called Firm Update to come up. I've searched all menus. And yes, I'm starting camera in Review/Playback mode. I hope someone can help, otherwise anyone want a SX40HS cheap? Thanks, Dave


Re: SX40HS porting thread
« Reply #118 on: 28 / March / 2012, 12:43:05 »
This is all brand new to me, but Computers (Macs) and Cameras are not. I just updated my old Canon SX1 and got a CanonSX40HS, and only did that because someone told me about this software I could use that would allow me to shoot in Raw. However, I've been all over the place in the CHDK info, tried various manual methods to load and install my version (1.00i), but CANNOT get a menu item called Firm Update to come up. I've searched all menus. And yes, I'm starting camera in Review/Playback mode. I hope someone can help, otherwise anyone want a SX40HS cheap?
There are reported to be a couple of cameras that don't support firmware update.  But people in this forum thread seem to be able to make it work so that should not be the problem.

Normally, if you have a ps.fi2 file in the root of your SD card and you start the camera with the Playback button then you will get it to work.  There are apparently a few gotchas if you do this from a Mac - info about that in the link below.

http://chdk.wikia.com/wiki/FAQ/Mac#Still_Having_Trouble.3F

Otherwise, you could just use the bootable SD card method ?  It's actually a lot more convenient.

http://chdk.wikia.com/wiki/Prepare_your_SD_card


« Last Edit: 28 / March / 2012, 12:50:15 by waterwingz »
Ported :   A1200    SD940   G10    Powershot N    G16

Re: SX40HS porting thread
« Reply #119 on: 28 / March / 2012, 18:07:23 »
Hi drdoad,

I have the same firmware as you and this is how I find the Firm Update.

With the SD card unlocked, press the Play button to turn on your camera.
Press the Menu button.
The menu showing should start out with Movie Digest Playback...
Scroll down to the bottom of the menu and that is where Firm Update should be.

Hope this helps...
Al

 

Related Topics