SX40HS porting thread - page 15 - DryOS Development - CHDK Forum supplierdeeply

SX40HS porting thread

  • 258 Replies
  • 77239 Views
Re: SX40HS porting thread
« Reply #140 on: 11 / April / 2012, 01:40:38 »
Advertisements
Its working SWEET ...  :D  :D

Thanks  8)

Re: SX40HS porting thread
« Reply #141 on: 11 / April / 2012, 09:17:26 »
philmoz
Can you add a function mapping the accurate distance for manual focus?
Like it was done for the approximation.
PowerShoot SX40 HS (1.00i)

Re: SX40HS porting thread
« Reply #142 on: 11 / April / 2012, 19:57:55 »
Hopefully this is the appropriate way to report this:

It seems that the override values (or at least one) is not followed when something is mounted in the hot shoe.  Simply removing the item (a red dot sight in my case) from the hot shoe will allow the overrides to work.  Even with the hot shoe filled the display still shows the override values (both via CHDK overlays and the Canon originals).  I believe I saw reference to this having been an issue on the G9.  Note that the red dot sight does not make any contact with the terminals but would trigger the microswitch under the right hand hot shoe spring.

I have observed this on both 100i-1688 full and 100i-1798 full.

*

Offline philmoz

  • *****
  • 3156
    • Photos
Re: SX40HS porting thread
« Reply #143 on: 11 / April / 2012, 20:03:37 »
philmoz
Can you add a function mapping the accurate distance for manual focus?
Like it was done for the approximation.

Sorry, I don't understand what you are asking for.

Phil.
CHDK ports:
  sx30is (1.00c, 1.00h, 1.00l, 1.00n & 1.00p)
  g12 (1.00c, 1.00e, 1.00f & 1.00g)
  sx130is (1.01d & 1.01f)
  ixus310hs (1.00a & 1.01a)
  sx40hs (1.00d, 1.00g & 1.00i)
  g1x (1.00e, 1.00f & 1.00g)
  g5x (1.00c, 1.01a, 1.01b)


*

Offline philmoz

  • *****
  • 3156
    • Photos
Re: SX40HS porting thread
« Reply #144 on: 12 / April / 2012, 01:58:56 »
Hopefully this is the appropriate way to report this:

It seems that the override values (or at least one) is not followed when something is mounted in the hot shoe.  Simply removing the item (a red dot sight in my case) from the hot shoe will allow the overrides to work.  Even with the hot shoe filled the display still shows the override values (both via CHDK overlays and the Canon originals).  I believe I saw reference to this having been an issue on the G9.  Note that the red dot sight does not make any contact with the terminals but would trigger the microswitch under the right hand hot shoe spring.

I have observed this on both 100i-1688 full and 100i-1798 full.

Common problem with many cameras - I'm not aware that anyone has found a solution yet.

Phil.
CHDK ports:
  sx30is (1.00c, 1.00h, 1.00l, 1.00n & 1.00p)
  g12 (1.00c, 1.00e, 1.00f & 1.00g)
  sx130is (1.01d & 1.01f)
  ixus310hs (1.00a & 1.01a)
  sx40hs (1.00d, 1.00g & 1.00i)
  g1x (1.00e, 1.00f & 1.00g)
  g5x (1.00c, 1.01a, 1.01b)

Re: SX40HS porting thread
« Reply #145 on: 19 / April / 2012, 16:22:06 »
Hi There,

 Saw this posting and wanted to ask, what if i used another flash with the hot shoe instead of the default camera flash?  I just bought the speedlite YN560 and it has high speed flash, but i cant get it to work with my SX40HS, even when i try it with the "force manual flash" option on CHDK.

Thanks
Summer

would be great to use the flash continuously while using the high speed burst, it is possible?
thanks, i'm new in this, so i'd like to learn.
I have not seen anything specific to CHDK that would support this.  Probably because you can't change the basic laws of physics - the camera's flash circuitry needs time to charge between each flash operation.  Large flash units for DSLR cameras that control the length of each flash burst might be capable of taking many shots but the ones on my most P&S cameras pretty much discharge completely on each shot and need a recharge interval.
Ports: SX40HS 100i

Re: SX40HS porting thread
« Reply #146 on: 04 / May / 2012, 19:04:33 »
Hi.

I've got my SX40 camera and I've started my own analysis of the firmware.
My firmware version is 1.00i.
I found that one of eventproc tables for some unknown reason resides at 0x86A4 address  :o.
That table gives us that FF1A2E64 is File.ClearExifInfo and FF1A2FA4 is File.Delete_AllImg.
I do not know whether this information is new or not. This just appeared to me to be odd and I wanted to share this info.

Re: SX40HS porting thread
« Reply #147 on: 06 / May / 2012, 21:07:51 »
hi guys, i just noticed that when you set the aperture value(av) in the CHDK extra photo operations menu, the av. value does not appear in the miscellaneous values, instead of this you see the value that you have set in the camera option for av.. but the picture it's affected by the value you put in the chdk menu, so its just a problem of get the real av value and show it in the miscellaneous values..


Re: SX40HS porting thread
« Reply #148 on: 18 / May / 2012, 08:21:50 »
It seems, that Digic5 is actually some of Texas Insturements processor, probably OMAP one.

In firmware version "i" there is a _srRegDump at 0xFF15459C
Code: [Select]
ROM:FF15459C _srRegDump                              ; DATA XREF: sub_FF154A78o
ROM:FF15459C                                         ; ROM:off_FF154A84o
ROM:FF15459C                 STMFD   SP!, {R4-R6,LR}
ROM:FF1545A0                 ADR     R0, aSvtReg     ; "\nSVT reg\n"
ROM:FF1545A4                 BL      sub_FF00179C
ROM:FF1545A8                 LDR     R5, =0xD02C3000
ROM:FF1545AC                 MOV     R4, #0
ROM:FF1545B0
ROM:FF1545B0 loc_FF1545B0                            ; CODE XREF: _srRegDump+2Cj
ROM:FF1545B0                 ADD     R1, R5, R4,LSL#2
ROM:FF1545B4                 LDR     R2, [R1]
ROM:FF1545B8                 ADR     R0, a0x08x0x08x ; "[0x%08X] 0x%08X\n"
ROM:FF1545BC                 BL      sub_FF00179C
ROM:FF1545C0                 ADD     R4, R4, #1
ROM:FF1545C4                 CMP     R4, #0x10
ROM:FF1545C8                 BCC     loc_FF1545B0
ROM:FF1545CC                 ADR     R0, aHvtReg     ; "\nHVT reg\n"
...
Note that HVT and SVT are read linearly starting from 0xD02C3000 offset.
HVT and SVT registers are reference to Ti's SmartReflex technology. I'm not sure, but I think those registers are kinda interrupt vectors, which help in powersaving.
Also there is a string:
Code: [Select]
ROM:FF1548E0 aSmartreflex_c  DCB "SmartReflex.c",0 which confirms, that it is SmartReflex.
« Last Edit: 18 / May / 2012, 08:31:13 by Deamon »

Re: SX40HS porting thread
« Reply #149 on: 28 / May / 2012, 21:58:12 »
This is all brand new to me, but Computers (Macs) and Cameras are not. I just updated my old Canon SX1 and got a CanonSX40HS, and only did that because someone told me about this software I could use that would allow me to shoot in Raw. However, I've been all over the place in the CHDK info, tried various manual methods to load and install my version (1.00i), but CANNOT get a menu item called Firm Update to come up. I've searched all menus. And yes, I'm starting camera in Review/Playback mode. I hope someone can help, otherwise anyone want a SX40HS cheap? Thanks, Dave

Download Stuffit Expander and use that to expand/open the CHDK zip file.  It will now work.  Took me forever to stumble onto this!

 

Related Topics