SX20 IS does not start - General Help and Assistance on using CHDK stable releases - CHDK Forum

SX20 IS does not start

  • 3 Replies
  • 2605 Views
SX20 IS does not start
« on: 20 / October / 2011, 17:57:07 »
Advertisements
Hello, I just installed on my 1GB SD card "SX20-102d-1372-0.9.9-full.zip" with the procedure of Bootable SD card CHDK / Installing with cardtricks.

I am stepping procedure, but when I put the card (after locked) in my SX20 IS, it will not start. Nothing happens when I turn On. I must to open the trap door for the battery that operates again with another card (wihout CHDK).

I tried to install CHDK older and small version , even on another SD card 500MB with the same result device blocked.

Thank's for your help.

*

Offline philmoz

  • *****
  • 3332
    • Photos
Re: SX20 IS does not start
« Reply #1 on: 20 / October / 2011, 18:01:23 »
Hello, I just installed on my 1GB SD card "SX20-102d-1372-0.9.9-full.zip" with the procedure of Bootable SD card CHDK / Installing with cardtricks.

I am stepping procedure, but when I put the card (after locked) in my SX20 IS, it will not start. Nothing happens when I turn On. I must to open the trap door for the battery that operates again with another card (wihout CHDK).

I tried to install CHDK older and small version , even on another SD card 500MB with the same result device blocked.

Thank's for your help.

That's usually a sign you have the wrong version of CHDK.
The version number in the file name has to match the firmware version on your camera - 1.02d in this case.

Are you sure your camera has firmware version 1.02d?
There are instructions on the Wiki for determining your firmware version, or you can just try the other CHDK versions for the SX20 and see if one of them works.

Phil.
CHDK ports:
  sx30is (1.00c, 1.00h, 1.00l, 1.00n & 1.00p)
  g12 (1.00c, 1.00e, 1.00f & 1.00g)
  sx130is (1.01d & 1.01f)
  ixus310hs (1.00a & 1.01a)
  sx40hs (1.00d, 1.00g & 1.00i)
  g1x (1.00e, 1.00f & 1.00g)
  g5x (1.00c, 1.01a, 1.01b)
  g7x2 (1.01a, 1.01b, 1.10b)

Re: SX20 IS does not start
« Reply #2 on: 20 / October / 2011, 18:17:08 »
My actual firmware version is 100f.
Oops, I skipped a step.

How then upgrade to 1.02d ?

*

Offline philmoz

  • *****
  • 3332
    • Photos
Re: SX20 IS does not start
« Reply #3 on: 20 / October / 2011, 19:08:39 »
My actual firmware version is 100f.
Oops, I skipped a step.

How then upgrade to 1.02d ?

You can't update the firmware in your camera unless Canon supplies a firmware update program, which they very rarely do.

The SX20 1.00f version has not been included in the autobuild yet - you can download the latest test version from http://chdk.setepontos.com/index.php?topic=4348.msg65447#msg65447

Phil.
CHDK ports:
  sx30is (1.00c, 1.00h, 1.00l, 1.00n & 1.00p)
  g12 (1.00c, 1.00e, 1.00f & 1.00g)
  sx130is (1.01d & 1.01f)
  ixus310hs (1.00a & 1.01a)
  sx40hs (1.00d, 1.00g & 1.00i)
  g1x (1.00e, 1.00f & 1.00g)
  g5x (1.00c, 1.01a, 1.01b)
  g7x2 (1.01a, 1.01b, 1.10b)


 

Related Topics