Problem with boot on startup - camera tries to boot but CHDK is not loaded. - General Help and Assistance on using CHDK stable releases - CHDK Forum

Problem with boot on startup - camera tries to boot but CHDK is not loaded.

  • 2 Replies
  • 1737 Views
Advertisements
Hello everyone!

Since I rapaired my lock switch in SD card I liked to boot CHDK on startup. I have as follows:

-SX130is 1.01c firmware
-8 GB SD with 2 partitions (16 MB FAT16 bootable; rest - FAT32)
-Ubuntu GNU/Linux

What I did:
-partitions (as above) using gparted
-both partitions contains CHDK binaries (ps2 and bin as well)
-generally as written on wiki (http://chdk.wikia.com/wiki/Bootable_SD_card)
-in CHDK menu I used 'make card bootable' option

What I have (and why it's not what I need):
-when I have unlocked card I have to run CHDK through Firm Update (that's OK)
-when I lock SD and try to turn the camera ON it is doing something for 1-2 seconds and then turns ON but without CHDK.

I'm pretty sure, that correct partition is first and bootable, since the camera is doing something  - I guess it tries to boot .bin file. But it fails and then boots without CHDK. And I can't find the reason.

I tried to use three builds, one was compiled by my own and no one have run. ps2 files through Firm Update works good.

If you can give me more informations about possible reasons or solutions I'll try to change something or read apropriate manuals. At the moment I have no idea why camera fails.

I can't use CardTrics since it runs only on Windows which I don't have...
if (2*b || !2*b) {
    cout<<question
}

Compile error: poor Yorick

I can't use CardTrics since it runs only on Windows which I don't have...
As you are using Linux,  why not use fdisk to determine which partition is first and whether its bootable ?
Ported :   A1200    SD940   G10    Powershot N    G16

Than you for the answer!

I'm sure that fat16 is first and bootable, as it was made in gparted. Also - when I replace partitions using CHDK the 1-2 seconds delay between pressing Power On button and camera boot doesn't occur. It looks like camera is doing something before run.

Here's what gave me fdisk:
-before replacing partitions by CHDK (camera is doing something before startup):
Code: [Select]
Disk /dev/mmcblk0: 7948 MB, 7948206080 bytes
4 heads, 16 sectors/track, 242560 cylinders
Units = cylinders of 64 * 512 = 32768 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000d8a6b

        Device Boot      Start         End      Blocks   Id  System
/dev/mmcblk0p1             545      242560     7744512    b  W95 FAT32
Partition 1 does not end on cylinder boundary.
/dev/mmcblk0p2   *          33         544       16384    6  FAT16
Partition 2 does not end on cylinder boundary.

Partition table entries are not in disk order

-after replacing partitions using CHDK menu entry (camera runs immediately after Power On):
Code: [Select]
Disk /dev/mmcblk0: 7948 MB, 7948206080 bytes
4 heads, 16 sectors/track, 242560 cylinders
Units = cylinders of 64 * 512 = 32768 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000d8a6b

        Device Boot      Start         End      Blocks   Id  System
/dev/mmcblk0p1   *          33         544       16384    6  FAT16
Partition 1 does not end on cylinder boundary.
/dev/mmcblk0p2             545      242560     7744512    b  W95 FAT32
Partition 2 does not end on cylinder boundary.

In both cases CHDK is not run.
if (2*b || !2*b) {
    cout<<question
}

Compile error: poor Yorick

 

Related Topics