Canon Powershot A495 Wont power on using the ON/OFF button - General Discussion and Assistance - CHDK Forum

Canon Powershot A495 Wont power on using the ON/OFF button

  • 14 Replies
  • 6891 Views
Canon Powershot A495 Wont power on using the ON/OFF button
« on: 10 / November / 2011, 14:19:55 »
Advertisements
Hi,
After taking some pictures, my canon PowerShot A495 was down to its last battery bar, I wanted to see the pictures I took, so I pressed the play button (the lens was out), suddenly the lens went in and the camera switched off by itself. I recharged the batteries, and when I started the camera again, it redirects me directly to the photo view mod (when i was before the camera shut down) without the lens going out, and in order to take a photo again, I have to press the shutter button once and the lens goes out normally. BTW the camera doesn't stat using the ON/OFF button, it just turns on when i close the batteries door.
Thanks in advance.

*

Offline reyalp

  • ******
  • 12072
Re: Canon Powershot A495 Wont power on using the ON/OFF button
« Reply #1 on: 10 / November / 2011, 23:27:10 »
Are you using CHDK ?  If so, try without.

It sounds like there could be a physical problem with the on/off button on your camera.
Don't forget what the H stands for.

Re: Canon Powershot A495 Wont power on using the ON/OFF button
« Reply #2 on: 10 / November / 2011, 23:34:30 »
... and when I started the camera again, it redirects me directly to the photo view mod (when i was before the camera shut down) without the lens going out, and in order to take a photo again, I have to press the shutter button once and the lens goes out normally.
This is the normal CHDK startup behaviour.   The rest of your post could be explained by a defective On/Off switch - as suggested by reyalp.

Ported :   A1200    SD940   G10    Powershot N    G16

Re: Canon Powershot A495 Wont power on using the ON/OFF button
« Reply #3 on: 11 / November / 2011, 07:57:19 »
Are you using CHDK ?  If so, try without.

It sounds like there could be a physical problem with the on/off button on your camera.

No, I'm not using CHDK.

I don't think it can be a physical problem, because I didn't drop the camera or something, the only thing that happened is that the batteries went down, and also the on/off button can turn the camera off.

By the way, when I press the shutter button halfway, the lens goes out and i can take pictures, but when I press the playback button to see the taken photos it doesn't work.   


Re: Canon Powershot A495 Wont power on using the ON/OFF button
« Reply #4 on: 11 / November / 2011, 08:12:34 »
... and when I started the camera again, it redirects me directly to the photo view mod (when i was before the camera shut down) without the lens going out, and in order to take a photo again, I have to press the shutter button once and the lens goes out normally.
This is the normal CHDK startup behaviour.   The rest of your post could be explained by a defective On/Off switch - as suggested by reyalp.

I don't know if the ON/OFF button is damaged, since it can turn the camera off.

Do you think the problem can be related to the firmware? Is there anyway to find out? 

Re: Canon Powershot A495 Wont power on using the ON/OFF button
« Reply #5 on: 21 / November / 2011, 09:37:41 »
Still unsolved guys.  :(

Anyone can help please?

Re: Canon Powershot A495 Wont power on using the ON/OFF button
« Reply #6 on: 21 / November / 2011, 09:44:17 »
No, I'm not using CHDK.
As you are not using CHDK,  you must have a broken camera.  The reason nobody has posted is that nobody knows what's wrong with your camera.   CHDK does not modify Canon firmware so that's not the issue. People here are pretty helpful, if they had suggestions I'm sure they would  have posted them.

Does CHDK work with your camera ?  It scans the camera buttons on its own - replacing the Canon firmware function.  If the buttons all work with CHDK then maybe there is a firmware problem with the camera itself.
« Last Edit: 21 / November / 2011, 09:46:36 by waterwingz »
Ported :   A1200    SD940   G10    Powershot N    G16

Re: Canon Powershot A495 Wont power on using the ON/OFF button
« Reply #7 on: 22 / November / 2011, 15:40:53 »
Hi,
I tried running the camera with the CHDK but I couldn't, because i had to press the playback button to do that.  :(


Re: Canon Powershot A495 Wont power on using the ON/OFF button
« Reply #8 on: 22 / November / 2011, 15:50:10 »
Hi,
I tried running the camera with the CHDK but I couldn't, because i had to press the playback button to do that.  :(
Only if you are loading via the "firmware update" method.  Use the "SD Card Lock" method instead.

CHDK Installation Guide
Ported :   A1200    SD940   G10    Powershot N    G16

Re: Canon Powershot A495 Wont power on using the ON/OFF button
« Reply #9 on: 24 / November / 2011, 12:28:03 »
Hi,
I tried running the camera with the CHDK but I couldn't, because i had to press the playback button to do that.  :(
Only if you are loading via the "firmware update" method.  Use the "SD Card Lock" method instead.

CHDK Installation Guide

Hi,
Thank you for the guide.
I followed the steps as suggested: I found out the firmware version which is 100f, I downloaded the CHDK compressed file, I made the memory card bootable and installed the CHDK on it, but when i start the camera (after locking the card), the splash screen appears for 2 seconds and then the camera turns off.
I also tried to load the CHDK manually by selecting the Firm update menu option and got the same result (btw, i didn't have to press the playback button, because the camera starts automatically in playback mode when i close the batteries door).

 

Related Topics