IXUS 230 HS - Porting Thread - page 3 - General Discussion and Assistance - CHDK Forum

IXUS 230 HS - Porting Thread

  • 168 Replies
  • 48123 Views
Re: IXUS 230 HS - Porting Thread
« Reply #20 on: 05 / December / 2011, 09:56:50 »
Advertisements
...  since my camera has version 1.00 and the posts so far relate to 1.00b and 1.00c.

That's probably not your firmware version if you just took it from the Canon menus. Take a look at this :


link> Determining the firmware version in your camera.
Ported :   A1200    SD940   G10    Powershot N    G16

Re: IXUS 230 HS - Porting Thread
« Reply #21 on: 05 / December / 2011, 10:11:24 »
I got 1.00 from a hex dump of a photo taken by the camera.  It was a null-terminated ASCII string.
I have tried ver.req and vers.req and nothing happens.
On one of the tries I had the basic dump script on the card, and got "Start not found" when I pressed the Menu button.

What script do I need to use to get a dump?  The ones I've tried yield nothing.

Re: IXUS 230 HS - Porting Thread
« Reply #22 on: 05 / December / 2011, 12:06:22 »
I have tried ver.req and vers.req and nothing happens.

Did you try this : http://www.zenoshrdlu.com/acid/acid.html ?
Ported :   A1200    SD940   G10    Powershot N    G16

Re: IXUS 230 HS - Porting Thread
« Reply #23 on: 05 / December / 2011, 21:14:51 »
Thanks for that.  I use Gentoo, but I got a good result.  1.00b.


Re: IXUS 230 HS - Porting Thread
« Reply #24 on: 05 / December / 2011, 22:16:33 »
I've worked more on the boot.c file, updating the values to match what is in the firmware. Still not booting. Will look more into it tomorrow. I've attached what I've done sofar. The code seems to stop just prior to the taskcreate_startup_my section

Learning quite a bit about the flow of the code...and differences between cameras :)

(comparing against ixus220/elph300, ixus310/elph500 and sx150is)

*

Offline tommi2water

  • ***
  • 157
  • IXUS 220 HS Firmware: 1.00c
Re: IXUS 230 HS - Porting Thread
« Reply #25 on: 06 / December / 2011, 10:49:52 »
Please try also what I wrote in http://chdk.setepontos.com/index.php?topic=7149.msg77330#msg77330

You're still using this:
*(int*)(0x2610) = (*(int*)0xC0220130)&1 ? 0x200000 : 0x100000; //0x2610 found at address 0xff05788c

First only try to get the REVIEW-Mode working:
*(int*)(0x2610) = (*(int*)0xC0220130)&1 ? 0x100000 : 0x200000; //0x2610 found at address 0xff05788c

This will let camera only start in REVIEW-Mode, not in more complicated RECORD-Mode.

:)

Re: IXUS 230 HS - Porting Thread
« Reply #26 on: 06 / December / 2011, 15:32:51 »
Ah, missed that part. Just tried it and still nothing. Going to spend some time on this tonight to see narrow down where it's getting hung up on.

Re: IXUS 230 HS - Porting Thread
« Reply #27 on: 06 / December / 2011, 22:13:01 »
Success!!! Started from scratch on the boot.c file. Able to boot the camera and get the CHDK splash screen. The code isn't 100% settled yet, still missing most functionality, but it boots  8)

Attached the boot.c file. Will continue working tomorrow on adding functionality.


Re: IXUS 230 HS - Porting Thread
« Reply #28 on: 06 / December / 2011, 22:40:56 »
Attached the boot.c file. Will continue working tomorrow on adding functionality.
A quick look at your source suggests you might be using CHDK-PT ?  (tabs & spacing to EOL is a clue). 

However,  you appear to have indented each line quite a bit.  If you did that on purpose and like the effect (I think that I do) then I could add it as an formatting option.

Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline tommi2water

  • ***
  • 157
  • IXUS 220 HS Firmware: 1.00c
Re: IXUS 230 HS - Porting Thread
« Reply #29 on: 07 / December / 2011, 10:08:48 »
Success!!! Started from scratch on the boot.c file. Able to boot the camera and get the CHDK splash screen.

Congratulations, velvethammer! 8)

From your source file it looks like your mykbd task is also already started.

Then you could try to adapt the kbd.c file next and try entering <ALT> mode.

If you uncomment these lines (line 286-296) in kbd.c you will be able to see the kbd values on screen:
Code: [Select]
// useful for further debugging: print keypress values on display
// char osd_buf[64];
        // extern long physw_status[3];
        // sprintf(osd_buf, "1:%8x  ", physw_status[0]);
        // draw_txt_string(8, 10, osd_buf, conf.osd_color);

        // sprintf(osd_buf, "2:%8x  ", physw_status[1]);
        // draw_txt_string(8, 11, osd_buf, conf.osd_color);

        // sprintf(osd_buf, "3:%8x  ", physw_status[2]);
        // draw_txt_string(8, 12, osd_buf, conf.osd_color);

Here is a short explaination how you can get to the key mapping values:
http://chdk.setepontos.com/index.php?topic=6341.msg76530#msg76530

Good luck!


 

Related Topics