supplierdeeply

IXUS 230 HS - Porting Thread

  • 167 Replies
  • 23110 Views
  • Publish
    Re: IXUS 230 HS - Porting Thread
    « Reply #30 on: 07 / December / 2011, 19:26:44 »
    Advertisements
    Attached the boot.c file. Will continue working tomorrow on adding functionality.
    A quick look at your source suggests you might be using CHDK-PT ?  (tabs & spacing to EOL is a clue). 

    However,  you appear to have indented each line quite a bit.  If you did that on purpose and like the effect (I think that I do) then I could add it as an formatting option.



    I did use CHDK-PT...forgot to mention that, thanks for the work on that tool, was very helpful in getting the values. I did indent on purpose and find it makes the code more readable, adding that formatting option would be a pretty good option. I intend to remove the trailing spaces from the code once I finalize it.

    Success!!! Started from scratch on the boot.c file. Able to boot the camera and get the CHDK splash screen.

    Congratulations, velvethammer! 8)

    From your source file it looks like your mykbd task is also already started.

    Then you could try to adapt the kbd.c file next and try entering <ALT> mode.

    If you uncomment these lines (line 286-296) in kbd.c you will be able to see the kbd values on screen:
    Code: [Select]
    // useful for further debugging: print keypress values on display
    // char osd_buf[64];
            // extern long physw_status[3];
            // sprintf(osd_buf, "1:%8x  ", physw_status[0]);
            // draw_txt_string(8, 10, osd_buf, conf.osd_color);

            // sprintf(osd_buf, "2:%8x  ", physw_status[1]);
            // draw_txt_string(8, 11, osd_buf, conf.osd_color);

            // sprintf(osd_buf, "3:%8x  ", physw_status[2]);
            // draw_txt_string(8, 12, osd_buf, conf.osd_color);

    Here is a short explaination how you can get to the key mapping values:
    http://chdk.setepontos.com/index.php?topic=6341.msg76530#msg76530

    Good luck!



    I'll get to work on this most likely tomorrow...spent way to long at work and just need a mental break lol.

  • Publish
    Re: IXUS 230 HS - Porting Thread
    « Reply #31 on: 07 / December / 2011, 19:40:31 »
    I did use CHDK-PT...forgot to mention that, thanks for the work on that tool, was very helpful in getting the values. I did indent on purpose and find it makes the code more readable, adding that formatting option would be a pretty good option. I intend to remove the trailing spaces from the code once I finalize it.
    Thanks - I'll put that on the list for the next (infrequent) update.    I think the trailing spaces were put there to make the Setup -> Show Address Info line up properly.  Although now that I see how ugly they are I'll change it so they are not inserted unless the Address Info is actually selected.

  • Publish
    Re: IXUS 230 HS - Porting Thread
    « Reply #32 on: 08 / December / 2011, 15:12:48 »
    I was able to get ALT mode without modifying anything in kbd.c. ALT mode is entered using the video button much like the ixus220/elph300hs. <ALT> is displayed at the bottom of the screen. Pressing the menu button brings up the Main Menu and I can move around the various options. Haven't tried selecting anything yet. All this testing was done in review mode.

    Moved code to trunk 1459. Source code attached with changes described below. Only functionality is that it boots and <ALT> mode can be selected...no easy task. Next up is to add functionality to it.

    Code: [Select]
    core/gui.c // add support for ixus230_elph310hs
    core/kbd.c // add support for ixus230_elph310hs
    camera_list.csv // add ALPHA Status entry for ixus230_elph310hs
    loader/ // add new folder "ixus230_elph310hs" with loader files for ixus230_elph310hs
    platform/ // add new folder "ixus230_elph310hs" with platform files for ixus230_elph310hs Firmware 1.00b
    « Last Edit: 08 / December / 2011, 16:59:51 by velvethammer42 »

  • Publish
    Re: IXUS 230 HS - Porting Thread
    « Reply #33 on: 09 / December / 2011, 22:56:17 »
    I did use CHDK-PT...forgot to mention that, thanks for the work on that tool, was very helpful in getting the values. I did indent on purpose and find it makes the code more readable, adding that formatting option would be a pretty good option. I intend to remove the trailing spaces from the code once I finalize it.
    Thanks - I'll put that on the list for the next (infrequent) update.    I think the trailing spaces were put there to make the Setup -> Show Address Info line up properly.  Although now that I see how ugly they are I'll change it so they are not inserted unless the Address Info is actually selected.

    Done - released as v1.06


  • Publish
    Re: IXUS 230 HS - Porting Thread
    « Reply #34 on: 10 / December / 2011, 14:00:57 »
    This is awesome guys!
    Thanks for the hard work!

    Minos  :xmas

  • Publish
    Re: IXUS 230 HS - Porting Thread
    « Reply #35 on: 14 / December / 2011, 20:23:54 »
    Just checking in, reasurring people that I'm still working on getting this camera ported. Currently having issues with gettting the camera to shoot RAW and create the badpixel.bin file. I've attached the progress I've made with the capt_seq.c and lib.c files.

    *

    Offline tommi2water

    • ***
    • 157
    • IXUS 220 HS Firmware: 1.00c
  • Publish
    Re: IXUS 230 HS - Porting Thread
    « Reply #36 on: 16 / December / 2011, 11:48:31 »
    ... Currently having issues with gettting the camera to shoot RAW and create the badpixel.bin file...

    Good progress, Velvethammer! :)

    I can't believe that you're still the only one who is working on this port!?

    Regarding RAW image shooting issues, please follow this discussion from this point for three posts:
    http://chdk.setepontos.com/index.php?topic=6341.msg76720#msg76720

    Then you will know how philmoz was able to find out which values I had to use for shooting RAW images.


  • Publish
    Re: IXUS 230 HS - Porting Thread
    « Reply #37 on: 18 / December / 2011, 14:09:14 »
    We now have RAW support!!

    Multiple issues caused the camera to crash and not save the RAW files:

    boot.c had incorrect taskhook setting. I had changed these to debug but never changed them back.
    PARAM_FILE_COUNTER was incorrect for this camera, should have been 0x3A instead of 0x3B that is in the ixus220 port.

    I've also updated the modemap list with the correct values. I'll upload my progress so far when I finish checking out the other tables.


  • Publish
    Re: IXUS 230 HS - Porting Thread
    « Reply #38 on: 27 / December / 2011, 12:50:55 »
    Thanks for your work VelvetHammer.
    Do you know if we will be able to get past the 15 second limited aperture time in Manual mode with your work? I plan to do aurora photo in February... :-)

    Sorry I can't help at all. I am in the middle of a South American trip and I am in the Galapagos right now.

    Just to warn any prospective customer of teh ELPH310 HS that on Day 1 of my Galapagos trip, I got the dreaded LENS ERROR message from the camera requiring me to send it back to Canon. Great. As you can imagine, I am pissed off!

    Now, I have no camera for the cruise besides a very old IXUS70.
    Awesome..

  • Publish
    Re: IXUS 230 HS - Porting Thread
    « Reply #39 on: 27 / December / 2011, 13:11:41 »
    Just to warn any prospective customer of teh ELPH310 HS that on Day 1 of my Galapagos trip, I got the dreaded LENS ERROR message from the camera requiring me to send it back to Canon. Great. As you can imagine, I am pissed off! Now, I have no camera for the cruise besides a very old IXUS70.
    Awesome..
    The dirty little secret is that this happens with almost all P&S cameras - you ELPH310 is probably no different.

    Depending on how desperate you are,  here's a pretty good list of things you can try :

    http://camerarepair.blogspot.com/2007/12/fixing-lens-error-on-digital-camera.html

    I got to #6a before I "solved" my problem - YMMV.

     

    Related Topics