IXUS 230 HS - Porting Thread - page 17 - General Discussion and Assistance - CHDK Forum

IXUS 230 HS - Porting Thread

  • 167 Replies
  • 37757 Views
*

Offline nafraf

  • *****
  • 1308
Re: IXUS 230 HS - Porting Thread
« Reply #160 on: 05 / October / 2012, 07:16:02 »
Advertisements
Anyway, the video limit removal works well, I went up to 16 min before the 4GB size limit was reached. I've only seen one issue so far: the "Video without Timelimit" parameter defaults to false and doesn't save, so I have to set it to true every time I turn the camera on.
It is not a bug, read this:  http://chdk.setepontos.com/index.php?topic=7889.msg90251#msg90251

*

Offline mdk

  • *
  • 3
Re: IXUS 230 HS - Porting Thread
« Reply #161 on: 05 / October / 2012, 16:05:39 »
Ah, I see. Good to know.

Re: IXUS 230 HS - Porting Thread
« Reply #162 on: 05 / October / 2012, 16:30:10 »
Anyway, the video limit removal works well, I went up to 16 min before the 4GB size limit was reached. I've only seen one issue so far: the "Video without Timelimit" parameter defaults to false and doesn't save, so I have to set it to true every time I turn the camera on.
It is not a bug, read this:  http://chdk.setepontos.com/index.php?topic=7889.msg90251#msg90251

It would be interesting to see data on that - has anyone tracked sensor temperature against time ?  I'd be surprise to find out that the sensor temperature rises much after the first few minute of shooting ...
Ported :   A1200    SD940   G10    Powershot N    G16

Re: IXUS 230 HS - Porting Thread
« Reply #163 on: 18 / October / 2012, 09:10:35 »
Hi.. I am new here.. I downloaded the Firmware for Ixus 230 HS and copied them on the SD card..
But how do I boot it? I want to try the Firmware update http://chdk.wikia.com/wiki/%22firmware_update_method%22 method first. I dont want it to always start in CHDK. But there is no Firmware update option in the menu!
Please help.


Re: IXUS 230 HS - Porting Thread
« Reply #164 on: 18 / October / 2012, 09:49:43 »
Hi.. I am new here.. I downloaded the Firmware for Ixus 230 HS and copied them on the SD card..
When you say "copied" do you mean that you "unzipped" the distribution file to the SD card or you just copied the whole thing over ?   Is there a file named ps.fi2 in the top directory on your SD card ?   How did you determine which firmware version to use ?

This page can be useful : http://chdk.wikia.com/wiki/Prepare_your_SD_card
Ported :   A1200    SD940   G10    Powershot N    G16

Re: IXUS 230 HS - Porting Thread
« Reply #165 on: 18 / October / 2012, 15:05:48 »
I used ACID to check the firmware. Had made a mistake. By mistake had downloaded 100e instead of 100b which is my camera's firmware version :P
Everything is working fine now. Thank you.  :)

*

Offline ramja

  • *
  • 10
Re: IXUS 230 HS - Porting Thread
« Reply #166 on: 19 / October / 2012, 22:42:42 »
I want to give a special "public" shout-out to nafraf for his great work and persistence in getting the 1.00a port out and doing some significant clean-up on 1.00b and e. As you can see from my post way up at the top of this thread I have been waiting 10 months to get CHDK on my 1.00a Elph 310 and had pretty much given up hope weeks ago. Then between Sept. 22 and Oct. 1 nafraf worked up at least 15 alpha ports for me and others to test. When we were cleaning up zebra and edge overlay he was making 2 or 3 adjustments a day for testing. It was hard for me to keep up!

Then I find out he's doing the same thing for several other Powershot models! :o

nafraf - THANKS!! You are an amazing asset to the CHDK community.

(and, of course, many thanks to reyalp, waterwingz, fe50 and the other gurus who share their in-depth knowledge and are keeping this whole thing rolling along so smoothly.)


*

Offline reyalp

  • ******
  • 12303
Re: IXUS 230 HS - Porting Thread
« Reply #167 on: 22 / January / 2014, 00:54:06 »
From this thread: http://chdk.setepontos.com/index.php?topic=11129.10 it appears this camera has very little free memory.

I see commented out
#override OPT_EXMEM_MALLOC=1
#override OPT_CHDK_IN_EXMEM=1

in the makefile.inc but skimming back of over the thread I'm not sure if the values are correct, or anyone tried it.
Don't forget what the H stands for.


 

Related Topics