supplierdeeply

Canon PowerShot ELPH 300 8 GB SD card partition problem

  • 11 Replies
  • 3104 Views
Canon PowerShot ELPH 300 8 GB SD card partition problem
« on: 01 / December / 2011, 07:48:42 »
Advertisements
Hi, I just joined the forum.
I have Canon PowerShot ELPH 300 camera. I wanted to use the alpa release of CHDK for my camera. Somewhere in this forum I read that, for some newer cameras it is possible to use a single Fat32 partition. I tried this but, CHDK did not boot. Then, I partitioned the SD card as described. Now, CHDK can boot and works but my camera only uses the first small partition for image storage. Is this normal or am I missing something? Is it because of the alpha release? Can anyone give me some advice about the correct usage of a 8GB sd card with CHDK?

Thanks


*

Offline msl

  • *****
  • 1186
  • A720 IS, SX220 HS 1.01a
    • CHDK inside
Re: Canon PowerShot ELPH 300 8 GB SD card partition problem
« Reply #2 on: 01 / December / 2011, 09:18:03 »
I think the ixus220/elph300 has not yet a multipartition support for cards > 4 GB. See also notes in source code.

FAT32 autoboot like for the SX220/230/ixus310_elph500 is also not possible.

Cards > 4 GB are possible but only with the manual start method ('Firm Update').

msl
German CHDK pages:  CHDK forum | CHDK inside | CHDK Twitter News by msl | Download CHDK-DE (Autobuild)
Note: SDM violates the GPL rules!

Re: Canon PowerShot ELPH 300 8 GB SD card partition problem
« Reply #3 on: 01 / December / 2011, 09:52:58 »
Thanks. But there is no "firmware update" menu item for this camera. Can I switch active partitions in CHDK. I can use 2 4GB partitions and switch between them if possible.


*

Offline whim

  • ******
  • 2013
  • A495/590/620/630 ixus70/115/220/230/300/870 S95
Re: Canon PowerShot ELPH 300 8 GB SD card partition problem
« Reply #4 on: 01 / December / 2011, 10:22:08 »
@msl
@gookank
Quote
FAT32 autoboot like for the SX220/230/ixus310_elph500 is also not possible.
Sorry msl, but it does work: this camera also has DRYOS 2.3 R47 ...
I just tried using your instructions here and it worked like a charm - as long as
you replace:
Quote
When CHDK is starting go into ALT mode by pressing [DISP.]+[FUNC.SET] button
by:
Quote
When CHDK is starting go into ALT mode by (short) pressing [VIDEO] button

Tested with latest Autobuild full version (ixus220_elph300hs-100c-0.9.9-1442-full_ALPHA.zip), and an 8 GB card.

@gookank
1. Do not forget to LOW LEVEL format the card in the camera if you have partitioned it before.
2. Don't forget that you will only get the Canon 'Firm update' menu item if you start the camera with
    the Playback (triangle) button (not the On/Off button). Switching back from REC to Playback
    mode will not work.

hope that helps,

wim
« Last Edit: 01 / December / 2011, 10:29:11 by whim »

*

Offline msl

  • *****
  • 1186
  • A720 IS, SX220 HS 1.01a
    • CHDK inside
Re: Canon PowerShot ELPH 300 8 GB SD card partition problem
« Reply #5 on: 01 / December / 2011, 11:08:38 »
Sorry msl, but it does work: this camera also has DRYOS 2.3 R47 ...

Oh yes, you're right. I missed the entry in platform_camera.h - my fault.  :-[

Thanks for the clarification.

msl
German CHDK pages:  CHDK forum | CHDK inside | CHDK Twitter News by msl | Download CHDK-DE (Autobuild)
Note: SDM violates the GPL rules!

*

Offline whim

  • ******
  • 2013
  • A495/590/620/630 ixus70/115/220/230/300/870 S95
Re: Canon PowerShot ELPH 300 8 GB SD card partition problem
« Reply #6 on: 01 / December / 2011, 11:18:06 »
Quote
Thanks for the clarification
Thank you for bringing this to my attention ... because I only have
one card > 4 GB, this means I will no longer need to swap partitions   :)

wim



Re: Canon PowerShot ELPH 300 8 GB SD card partition problem
« Reply #7 on: 02 / December / 2011, 04:47:08 »
I started my camera using the playbak button but still cannot find the menu item "Firm update".  :(


*

Offline fe50

  • ******
  • 3038
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: Canon PowerShot ELPH 300 8 GB SD card partition problem
« Reply #8 on: 02 / December / 2011, 05:50:18 »
I started my camera using the playbak button but still cannot find the menu item "Firm update".  :( 

Expand all files from the CHDK full package to the root of your SD card, start your camera in playback mode with the [>] button, then enter the Canon menu...

The "Firm update" menu entry is only visible when the camera is in playback mode (with lens retracted) and there's a file PS.FI2 on the root of your SD card.

On a Mac make sure you've removed the quarantine flags, read more here:
* http://chdk.wikia.com/wiki/FAQ/Mac
* http://chdk.wikia.com/wiki/FAQ/Mac#Still_Having_Trouble.3F

Re: Canon PowerShot ELPH 300 8 GB SD card partition problem
« Reply #9 on: 03 / December / 2011, 12:08:07 »
Thank you all. "Firm Update" menu item is only visible if there is acctually a firmware binary in the SD card. I, extracted the CHDK release and it is done.  CHDK successfully loads. :)

 

Related Topics