Remote USB Shutter Does not work on ELPH 300 - General Help and Assistance on using CHDK stable releases - CHDK Forum

Remote USB Shutter Does not work on ELPH 300

  • 4 Replies
  • 2397 Views
Remote USB Shutter Does not work on ELPH 300
« on: 29 / December / 2011, 20:17:18 »
Advertisements
I have the latest build of CHDK for the ELPH 300, and I am trying to get the remote USB shutter to work. I am running following the directions at http://chdk.wikia.com/wiki/USB_Remote_Cable.

After everything is set up (parameters set and script running), I connect the USB cable. Then, the shutter closes and the screen goes black. If I leave the cable connected for too long the camera shuts down with error code E41 If I disconnect power promptly, the camera reverts to its previous mode without having taken a picture.

In fact it appears that the camera always shuts down with this error whenever power is supplied (for too long) via the USB cable, even when the remote parameters are not set and scripts are not running.

Any help would be much appreciated.

Re: Remote USB Shutter Does not work on ELPH 300
« Reply #1 on: 29 / December / 2011, 20:28:25 »
After everything is set up (parameters set and script running), I connect the USB cable.
Please post which script you are running.

Quote
Then, the shutter closes and the screen goes black.
Small detail - did you mean to say that the shutter "opens" or that the camera takes a picture ?

Quote
If I leave the cable connected for too long the camera shuts down with error code E41 If I disconnect power promptly, the camera reverts to its previous mode without having taken a picture.

In fact it appears that the camera always shuts down with this error whenever power is supplied (for too long) via the USB cable, even when the remote parameters are not set and scripts are not running.
So what happens if you do not load CHDK and plug the camera into your USB cable (which I assume is connected to your PC for power)?   And what happens when you do not have USB remote enabled in the CHDK menus ?
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline fvdk

  • ***
  • 144
  • Ixus 70 1.01b / 1.02a & Powershot A590is 1.01b
    • My Flickr photo page
Re: Remote USB Shutter Does not work on ELPH 300
« Reply #2 on: 30 / December / 2011, 08:14:31 »
Deleted
« Last Edit: 30 / December / 2011, 08:16:58 by fvdk »

Re: Remote USB Shutter Does not work on ELPH 300
« Reply #3 on: 04 / January / 2012, 01:06:35 »
Please post which script you are running.
/CHDK/SCRIPTS/EXAM/remote.bas

Quote
Small detail - did you mean to say that the shutter "opens" or that the camera takes a picture ?
Neither, the physical shutter closes, but no picture is taken.

Quote
So what happens if you do not load CHDK and plug the camera into your USB cable (which I assume is connected to your PC for power)? 
Without CHDK running the camera fuctions correctly going into mass storage mode.
Quote
And what happens when you do not have USB remote enabled in the CHDK menus ?

The same thing happens as when the USB remote is enabled (shutter closes and eventually the camera shuts off).


Re: Remote USB Shutter Does not work on ELPH 300
« Reply #4 on: 04 / January / 2012, 04:12:49 »
I think I found a fix for this and posted it here : http://chdk.setepontos.com/index.php?topic=6341.msg79244.msg#79249

Solves the USB remote problem although there maybe another problem exposed as well.
« Last Edit: 04 / January / 2012, 04:24:26 by waterwingz »
Ported :   A1200    SD940   G10    Powershot N    G16

 

Related Topics