Need Help: SD940/Ixus120is and RAW

  • 6 Replies
  • 724 Views
  • Publish
    Need Help: SD940/Ixus120is and RAW
    « on: 01 / January / 2012, 21:01:46 »
    Advertisements
    Hello everyone!
    im kinda new and i gotta say i just joined because im stuck with a problem on my ixus 120is (sd 940 it is i think).
    chdk loads up fine, everything works, histograms and all. but i cant get raws to work.
    creating this badpixel.bin doesnt really work, it takes a pictures and than thats it. no new file,no temp file. nothing.
    trying to shot in crw doesnt do anything either sadly. just jpgs. sadface :(
    any ideas anyone?
    running on the 1.00E firmware.

    thanks in advance!! <3

    d

  • Publish
    Re: Need Help: SD940/Ixus120is and RAW
    « Reply #1 on: 01 / January / 2012, 21:08:07 »
    but i cant get raws to work. creating this badpixel.bin doesnt really work, it takes a pictures and than thats it. no new file,no temp file. nothing. trying to shot in crw doesnt do anything either sadly. just jpgs.
    When CHDK stores a RAW picture,  there is a several second delay after the shot is taken while it processes the data. Do you notice a difference with RAW enabled or disabled ?

    And how are you looking for the raw files ?   You will not be able to see them if you connect your camera via a USB cable to your computer.  Only JPEG's will be visible that way.

    You need to put the SD card in a reader on your computer.  Also be aware that depending on your setup,  CHDK may put the RAW files in a different directory on the card from where the jpegs are stored.  Look around for them.

  • Publish
    Re: Need Help: SD940/Ixus120is and RAW
    « Reply #2 on: 01 / January / 2012, 21:42:47 »
    thanks for the quick answer!
    nope, doesnt seem like theres any delay, no raws are created.
    looked for them with the "raw processing" feature and the file exporer.
    « Last Edit: 01 / January / 2012, 21:47:30 by thebeep »

  • Publish
    Re: Need Help: SD940/Ixus120is and RAW
    « Reply #3 on: 01 / January / 2012, 22:02:39 »
    thanks for the quick answer!
    nope, doesnt seem like theres any delay, no raws are created.
    looked for them with the "raw processing" feature and the file exporer.
    Well,  the 1.00e port has had a few quirks not suffered by the other 4 SD940 cameras.  If you enable the Show Raw state option in the OSD do you get onscreen display of remaining raw space ?


  • Publish
    Re: Need Help: SD940/Ixus120is and RAW
    « Reply #4 on: 01 / January / 2012, 22:05:35 »
    yes, seeing i got like 91 left...small card :)
    save raw is def. on... hm, weird.

  • Publish
    Re: Need Help: SD940/Ixus120is and RAW
    « Reply #5 on: 01 / January / 2012, 22:36:58 »
    Found it - the address used in boot.c to hook the capture sequence task has been wrong for a long time.  Obviously this model was not used by a lot of people.  Try this for me ?  The fix was easy.
    « Last Edit: 02 / January / 2012, 09:02:40 by waterwingz »

  • Publish
    Re: Need Help: SD940/Ixus120is and RAW
    « Reply #6 on: 02 / January / 2012, 04:33:03 »
    Sir, you can officially can call you awesome.
    spot on. it works!! even badpixels.bin creation!
    shooting in raw now...

    THANK YOU!

     

    Related Topics