A800 Porting Thread - page 13 - DryOS Development - CHDK Forum supplierdeeply

A800 Porting Thread

  • 277 Replies
  • 75484 Views
Re: A800 Porting Thread
« Reply #120 on: 18 / March / 2012, 19:34:33 »
Advertisements
Can you upload a CR2 raw somewhere ?
Took a RAW (with no other settings changed, just a fresh copy onto the card, enable RAW capture, take a picture.)  That's the first picture of a black pen and my SD card reader (and its cap.)  Then had it create badpixel.bin, set Bad pixel removal to Averag., ticked DNG format and 'DNG' file extension to on, took another picture, that's the one of a yellow mini-postitnote pad with the blank pen and SD card reader.  I also included the .jpg files for comparison.

It seems that putting it in .DNG mode fixes it?

http://www.box.com/s/59306f42daaaa999737a


P.S. Apparently the forums like me again so I can finally attach things to posts so I attached my full .zip on the build I am testing with - 1748 with the color tweak and 'Main Menu' modified to 'xMain Menu' with EXMEM ticked in the compile options.
« Last Edit: 18 / March / 2012, 19:44:23 by Qanthelas »

*

Offline srsa_4c

  • ******
  • 4426
Re: A800 Porting Thread
« Reply #121 on: 18 / March / 2012, 20:09:54 »
It seems that putting it in .DNG mode fixes it?
Just checked, the RAW has the same dimensions and size as the RAW of the SX110IS (which is advertised as a 9MP camera btw...), and is recognized as such by dcraw (it detects these headerless files by size). The SX110IS has an RGGB CFA pattern. That means: A800 users will need to use DNG.


I'm a bit suspicious since the autobuild setmode.lua works and the builds I've gotten from you, waterwingz, error out in the same way - did something get tweaked on your trunk?
Could be.  I've been building those on my Linux box using the most current svn source - I'm 100% sure that part is correct.  However,  its possible I have one of the build options different.  Its also possible that I'm using a different compiler version than what's the autobuild uses.   When I get a minute, I'll reboot into Windows and try a CHDK-Shell build.
Could you guys test this? I'm really interested whether there's again some gcc miscompilation issue somewhere.
« Last Edit: 18 / March / 2012, 20:15:13 by srsa_4c »

Re: A800 Porting Thread
« Reply #122 on: 18 / March / 2012, 20:31:56 »
Just to confirm that the tweaks I was trying were red herrings, I grabbed the latest /trunk autobuild from http://mighty-hoernsche.de/trunk/ which is a800-100c-1.1.0-1749-full_BETA and ran the same tests again - fresh copy onto the card, enable RAW, take a picture, take badpixel.bin, turn on DNG mode and DNG file extension, take another picture.  (Added a green piece of paper to the DNG shot to make it nice and easy to tell which is which, just in case.)  Here are the files:

http://www.box.com/s/345793793dd2f4e102bc

As for the gcc miscompliation issues, waterwingz, when you get a chance try a build and post it here and I can test it.

*

Offline reyalp

  • ******
  • 13434
Re: A800 Porting Thread
« Reply #123 on: 18 / March / 2012, 20:47:42 »
So just to confirm, the build used to take the DNG CRW_0056.DNG in reply #120 uses
Code: [Select]
#define cam_CFAPattern                  0x01000201 // Green Blue Red Green, at philmoz's suggestion to make RAW photos not look purple
This looks correct to me.

As mentioned earlier, this will have no effect non-DNG "CHDK raw"
Don't forget what the H stands for.


Re: A800 Porting Thread
« Reply #124 on: 18 / March / 2012, 20:51:19 »
http://www.box.com/s/345793793dd2f4e102bc
The DNG does not seem to work well with any of my photo software.  I get a small purple image that I assume is the thumbnail ?

Quote
As for the gcc miscompliation issues, waterwingz, when you get a chance try a build and post it here and I can test it.
Okay.  Won't be tonight though.

Ported :   A1200    SD940   G10    Powershot N    G16

Re: A800 Porting Thread
« Reply #125 on: 18 / March / 2012, 20:53:56 »
So just to confirm, the build used to take the DNG CRW_0056.DNG in reply #120 uses
Code: [Select]
#define cam_CFAPattern                  0x01000201 // Green Blue Red Green, at philmoz's suggestion to make RAW photos not look purpleThis looks correct to me.

As mentioned earlier, this will have no effect non-DNG "CHDK raw"

Yes, that is indeed the change made on that build of mine.  Check the post before yours, though, and see if the .DNG there looks right - I'd check myself but this computer doesn't have the stuff to open DNG files.  If that one, 0064.DNG, also looks good (and not purple) then changing the cam_CFAPattern value was a red herring.  If 0064.DNG is purple, though (as waterwingz's post suggests?) then yes, we need to make that change to the cam_CFAPattern value so that it matches the code string quoted.

If what srsa_4c says is true then it's all good that it doesn't do anything to non-DNG "CHDK raw" because apparently that isn't usable on this camera model anyways (although I'm a little fuzzy on just why that's the case.)

Oh, and waterwingz, no worries, I'll keep an eye on this thread, post your build when you can :)
« Last Edit: 18 / March / 2012, 20:55:39 by Qanthelas »

Re: A800 Porting Thread
« Reply #126 on: 18 / March / 2012, 21:03:28 »
If what srsa_4c says is true then it's all good that it doesn't do anything to non-DNG "CHDK raw" because apparently that isn't usable on this camera model anyways (although I'm a little fuzzy on just why that's the case.)
Your DNG files look bad.  I switched to windows to try them on RawTherapee and got the same purple thumbnail only.   So its not all good.  Sorry.
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline srsa_4c

  • ******
  • 4426
Re: A800 Porting Thread
« Reply #127 on: 18 / March / 2012, 21:06:20 »
If what srsa_4c says is true then it's all good that it doesn't do anything to non-DNG "CHDK raw" because apparently that isn't usable on this camera model anyways (although I'm a little fuzzy on just why that's the case.)
The above mentioned dcraw code is used by many software to open RAW files. Since it misdetects the RAW of A800, it will always give miscolored results on these. Your 0056 dng looks fine to me, 0064 is purple.

edit: Used IrfanView to check (I think it uses dcraw too).
« Last Edit: 18 / March / 2012, 21:09:02 by srsa_4c »


Re: A800 Porting Thread
« Reply #128 on: 18 / March / 2012, 21:09:46 »
Thanks for checking my uploads, guys :)  Waterwingz, are both the 0056 dng and the 0064 dng purple thumbnails for you?  If that's the case then I don't know what the heck is going on, but if 0056 dng is fine but 0064 dng is a purple thumbnail, then apparently the switch to GBRG did the trick.  That would seem to match with what srsa_4c is seeing.  As for the .CR2 files, they could very well be all kinds of messed up - I was able to open them just fine, they were just purple.  As a sidenote, when I tried using the computer I'm on now to open my .DNG files in GIMPPortable I also ended up with purple-ish little bitty thumbnail-sized pictures, so what the heck is that all about?  I don't think that's the camera's problem, though, as I was able to open those same files on another computer just fine (as in not tiny).  Maybe something about the whole 'not having headers' thing?  (I'm out of my league here, I really don't know much about all this :P )

I am also curious if/how this is related to that thread that waterwingz linked earlier, http://chdk.setepontos.com/index.php?topic=7674.msg82190#msg82190
« Last Edit: 18 / March / 2012, 21:14:03 by Qanthelas »

Re: A800 Porting Thread
« Reply #129 on: 18 / March / 2012, 21:15:12 »
Waterwingz, are both the 0056 dng and the 0064 dng purple thumbnails for you? 
The "0056" opens as a full size image with RawTherappe. Color looks good too - no purple.
Ported :   A1200    SD940   G10    Powershot N    G16

 

Related Topics