A800 Porting Thread - page 18 - DryOS Development - CHDK Forum supplierdeeply

A800 Porting Thread

  • 277 Replies
  • 83454 Views
*

Offline srsa_4c

  • ******
  • 4450
Re: A800 Porting Thread
« Reply #170 on: 03 / April / 2012, 16:33:04 »
Advertisements
I got two log files and both show "ASSERT!! MotionVector.c Line 133" a search indicates that MotionVector is from the original firmware
In case of a crash, the camera tries to record debugging information (function of the original firmware). When you request a romlog, you always get the information about the latest recorded crash event (watch the timestamp to see whether a new crash has happened).
In some cases the camera's operating system fails to catch the event and the crash doesn't leave a trace.
Quote
and the times stamps don't match the times when the camera actually stopped.
Are you sure? Your current log shows a fresh timestamp with about 78 minutes uptime (the 8 digit numbers in the second half of the log show the elapsed milliseconds).

If your camera crashes again, try to get another romlog.

Re: A800 Porting Thread
« Reply #171 on: 03 / April / 2012, 17:10:46 »
Hello, everyone. I have the following problem. I've just bought A800 but it turned out that it have 1.00b firmware. So I'm wondering usually how long does it takes to port CHDK from one firmware version to another? I other words should I just pay some extra cash and grab A495 or should I wait a week or two for the 1.00b version? Thanks.

Re: A800 Porting Thread
« Reply #172 on: 03 / April / 2012, 17:58:26 »
Hello, everyone. I have the following problem. I've just bought A800 but it turned out that it have 1.00b firmware. So I'm wondering usually how long does it takes to port CHDK from one firmware version to another? I other words should I just pay some extra cash and grab A495 or should I wait a week or two for the 1.00b version? Thanks.
CHDK does not have a schedule.  Unless somebody with an A800 decides to do the port, there may never be a port for that version.  You could try the 1.00A version and see if it works in your 1.00B camera.
Ported :   A1200    SD940   G10    Powershot N    G16

Re: A800 Porting Thread
« Reply #173 on: 03 / April / 2012, 19:21:16 »
I too have the 1.00b and a800-100c-1.1.0-1787-full_BETA is not working. But what is 1.00A ? I could not locate it.


Re: A800 Porting Thread
« Reply #174 on: 03 / April / 2012, 20:36:07 »
I too have the 1.00b and a800-100c-1.1.0-1787-full_BETA is not working. But what is 1.00A ? I could not locate it.
my bad - answered on a mobile phone where it was hard to check older info - I should have said 1.00C.   So maybe my penalty is to help port the A800 to 1.00B if I have some volunteer testers. 

« Last Edit: 03 / April / 2012, 23:54:59 by waterwingz »
Ported :   A1200    SD940   G10    Powershot N    G16

Re: A800 Porting Thread
« Reply #175 on: 04 / April / 2012, 03:26:57 »
I also have 1.00b. make port-will be tested

Re: A800 Porting Thread
« Reply #176 on: 04 / April / 2012, 21:09:07 »
CHDK-PT address.txt file for the A800 1.00c version :
Code: [Select]
;
; address.txt :  A800 1.00C
;
boot 0xFFC0000C 86
sub_FFC0035C_my 0xFFC0035C 27
sub_FFC011B4_my 0xFFC011B4 42
sub_FFC05EE4_my 0xFFC05EE4 30
taskcreate_Startup_my 0xFFC10730 44
task_Startup_my 0xFFC106D4 23
taskcreatePhySw_my 0xFFC2382C 9
init_file_modules_task  0xFFC7387C 8
movie_record_task 0xFFD18384 66
sub_FFD17E98_my 0xFFD17E98 128
sub_FFE10140_my 0xFFE10140 57
capt_seq_task  0xFFC5B06C 148
exp_drv_task  0xFFC98190 437
sub_FFC95088_my 0xFFC95088 51
sub_FFC86234_my 0xFFC86234 17
Ported :   A1200    SD940   G10    Powershot N    G16

Re: A800 Porting Thread
« Reply #177 on: 04 / April / 2012, 21:53:31 »
I also have 1.00b. make port-will be tested
Here you go :

A800 1.00B Beta 1

SD card lock boot method only - will not work with firmware update method prior to inclusion in autobuild server.

Let me know what works and what doesn't ?



Ported :   A1200    SD940   G10    Powershot N    G16


Re: A800 Porting Thread
« Reply #178 on: 05 / April / 2012, 04:06:35 »
waterwingz, thanks for the port.sometimes does not save in RAW, even though there is a copy in JPEG

*

Offline fe50

  • ******
  • 3139
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: A800 Porting Thread
« Reply #179 on: 05 / April / 2012, 04:52:21 »
waterwingz, thanks for the port.sometimes does not save in RAW, even though there is a copy in JPEG
Does this only happen when you rapidly press the shutter without pre-focusing ?

* http://chdk.setepontos.com/index.php/topic,3952.msg37161.html#msg37161 Intermittent/sporadic RAW issue
* http://trac.assembla.com/chdk/changeset/923

 

Related Topics