On A490, firmware E, ubasic scripts named of 8.3 chars don't load, 7.3 chars ok - Script Writing - CHDK Forum supplierdeeply

On A490, firmware E, ubasic scripts named of 8.3 chars don't load, 7.3 chars ok

  • 4 Replies
  • 2666 Views
Advertisements
When I selected a script to load, my cam only showed the parameter setting for the default script.

After I spent a lot of time figuring out what was wrong in my script, I found out that if i renamed from 8.3 to 7.3 characters, it worked.

Could this have something to do with the saving of parameters in a file whose name becomes larger than 8.3 chars?

Does this happen also on other cams?

I used build 1532. A490 firmware E

Did you try to put your script to other directory? Some cameras have limit of length of the path to the file (but not the filename itself AFAIK).

Try to move this script to other directory and give a feedback wheter it helps or changes anyghing.
if (2*b || !2*b) {
    cout<<question
}

Compile error: poor Yorick

After I spent a lot of time figuring out what was wrong in my script, I found out that if i renamed from 8.3 to 7.3 characters, it worked.
As outslider said,  there is a length limit for some cameras.  Its 31 characters including the path, filename & the \ characters.
Ported :   A1200    SD940   G10    Powershot N    G16

The path is not so long, less than 20 chars, directly under the CHDK/SCRIPTS folder.

I thought it might be the files created in CHDK/DATA which consist of the script name with a suffix like _1 or _2.

However, if that was the case, i guess the problem would also occur with 7.3 char filenames then, but they seemed to work fine.

I'll check if I can reproduce it on another camera...


ok, I should learn to count... Including the filename dot I am at 31 chars.. If the path starts with a \ before chdk, then I am at 32...

So it is probably due to the 31 char limit.

Thanks guys.

Maybe an idea to put a warning in the readme file in the scripts folder.

 


 

Related Topics