time lapse script - Script Writing - CHDK Forum

time lapse script

  • 10 Replies
  • 3970 Views
time lapse script
« on: 29 / January / 2012, 15:27:09 »
Advertisements
I am trying to get the "Selective Intevalometer" onto my SD750
Total newbe and idiot.
it says:
"Save the script as a *.BAS file and place in the CHDK/SCRIPTS folder to use."

How do I do that ?
How do I save as a .bas file?
help please.

Re: time lapse script
« Reply #1 on: 29 / January / 2012, 15:37:36 »
I am trying to get the "Selective Intevalometer" onto my SD750
Total newbe and idiot.
it says:
"Save the script as a *.BAS file and place in the CHDK/SCRIPTS folder to use."

How do I do that ?
How do I save as a .bas file?
it just means to save the script text in a file with the extension (last part of file name) set to .bas

Then copy that file over to the specified directory on your SD card
« Last Edit: 29 / January / 2012, 15:39:21 by waterwingz »
Ported :   A1200    SD940   G10    Powershot N    G16

Re: time lapse script
« Reply #2 on: 29 / January / 2012, 15:41:11 »
In fact Basic script might have any extension, so you don't have to care about that. It can be .txt.

How to place on CHDK/SCRIPTS folder? Just put SD card in card reader and copy script from your PC to card;)

PS. In other case - if you'd like to use script written in Lua it must have .lua extension. To change extension of file in Windows you have to uncheck option called something like "hide extension of known file types" in "folder options" or something simmilar. Then just rename file.
« Last Edit: 29 / January / 2012, 15:45:31 by outslider »
if (2*b || !2*b) {
    cout<<question
}

Compile error: poor Yorick

Re: time lapse script
« Reply #3 on: 29 / January / 2012, 15:59:11 »
Ok. I have created a file in Notepad and copied the script into it. It only gives the option to save as .text file but will not save - says disc is write protected. Am I going in the right direction. ?


Re: time lapse script
« Reply #4 on: 29 / January / 2012, 16:02:02 »
Ok. I have created a file in Notepad and copied the script into it. It only gives the option to save as .text file but will not save - says disc is write protected. Am I going in the right direction. ?
I assume you are trying to save directly to your SD card ?  If so,  you need to turn off the SD card lock on the SD card prior to attempting to save anything there.
Ported :   A1200    SD940   G10    Powershot N    G16

Re: time lapse script
« Reply #5 on: 29 / January / 2012, 18:42:35 »
thank you mr waterwingz - what a simple thing !

Re: time lapse script
« Reply #6 on: 29 / January / 2012, 18:44:55 »
thank you mr waterwingz - what a simple thing !
Don't forget to turn the SD card lock back on when you are done so that CHDK will boot again.
Ported :   A1200    SD940   G10    Powershot N    G16

Re: time lapse script
« Reply #7 on: 30 / January / 2012, 16:17:45 »
I am a total beginner at this so please forgive me seeming a little dim.
I have now got the Intervalometer onto the card/ camera.
Have gone to Scripts
Loaded script from file .
What I am trying to do is get series of  1min shots for 8 hours.
On selective Intervals I have put :
Number of shots 500
Inteval  1min.
Starting Time/end time I have put a zero.

But I cant seem to get it to run. Camera turns off after a minute or two.
Any suggestions welcome


Re: time lapse script
« Reply #8 on: 30 / January / 2012, 17:02:48 »
This might be a bug in the script or maybe even in your camera port. Could you give a link to the exact script you are using? If there's no link you can attach the script here.

I'm not sure that I can help you, but this might be usefull for forum members with higher level of CHDK knowledge who might help you;)
if (2*b || !2*b) {
    cout<<question
}

Compile error: poor Yorick

Re: time lapse script
« Reply #9 on: 30 / January / 2012, 19:05:25 »
I am a total beginner at this so please forgive me seeming a little dim.
I have now got the Intervalometer onto the card/ camera.
Have gone to Scripts
Loaded script from file .
What I am trying to do is get series of  1min shots for 8 hours.
On selective Intervals I have put :
Number of shots 500
Inteval  1min.
Starting Time/end time I have put a zero.

But I cant seem to get it to run. Camera turns off after a minute or two.
Any suggestions welcome
Its not clear from your description if you completed the last necessary step in the process - pressing the shutter button while in <ALT> mode to activate the script ?
Ported :   A1200    SD940   G10    Powershot N    G16

 

Related Topics