supplierdeeply

TX-1 Firmware has been dumped...!!!

  • 11 Replies
  • 4965 Views
  • Publish
    TX-1 Firmware has been dumped...!!!
    « on: 12 / March / 2008, 10:10:14 »
    Advertisements
    To All & especially to ewavr:

    Looks like I took a dump!!!

    Empty.dum says:

    (Starting around 0000BFF0)

    Copyright 1999-2001 ARM Limited Copyright 1999-2001 Wind River Systems, Inc.

    ...

    Juno - ARM946ES  (ARM)

    ....

    VxWorks 5.5 VxWorks 5.5 Dec 13 2005, 16:53:49   Startup

    ...

    Mar 23 2007.....11:29:53.....Firmware Version 1.01....Firmware ver GM1.01B

    ...

    around area of 0038d924:

    jp56_firmware build#0094 2005/11/12 Saku Hi

    (0038D9B8) watashi, Satoshi Naito, Yukio Chiba...
    ...diagnosis() rev0.03 2004/11/08 Satoshi Naito followed by L launcher, L bypass etc.


    ...


    in line 003BFFA0 there is reference to microsoft.com/WPDNA 1.0 & WPDWCN: 1.0
    then Canon IXY Digital 500

    ...

    last code is between 003C73D4 and 003C7468.




    Now that I have the file, What's the best way to post it for everyone to use???

    And may I just add thanks again to all who helped me with this!
    « Last Edit: 12 / March / 2008, 10:25:53 by cybercom »
    ~~~~~~~~~~~~~~~~~~~~~

    <")%%%><<

    *

    Offline GrAnd

    • ****
    • 916
    • [A610, S3IS]
      • CHDK
  • Publish
    Re: TX-1 Firmware has been dumped...!!!
    « Reply #1 on: 12 / March / 2008, 10:16:22 »
    Please, upload the file (e.g. to zshare.net) and post the link in this topic: [DOWNLOAD LINKS] Firmware dumps available
    CHDK Developer.

  • Publish
    Re: TX-1 Firmware has been dumped...!!!
    « Reply #2 on: 12 / March / 2008, 10:27:28 »

    Looks like I took a dump!!!

    Wow !!!

    I bet GrAnd or EWAVR can work this out  :)

  • Publish
    Re: TX-1 Firmware has been dumped...!!!
    « Reply #3 on: 12 / March / 2008, 10:46:31 »
    Just uploaded to:

    zSHARE - tx-1_dump_080312

    And then downloaded file to confirm accuracy. It's fine.

    Please note, I did not try to remove any leading or trailing zeros from the file. It is just the raw dump of empty.bin renamed to TX-1_dump_080312.

    I'll really look forward to what you 4-star generals come up with from this!

    TIA,

    ~~~~~~~~~~~~~~~~~~~~~

    <")%%%><<


  • Publish
    Re: TX-1 Firmware has been dumped...!!!
    « Reply #4 on: 12 / March / 2008, 10:48:22 »
    OK, I have the dump.

    Are there any updated signatures or scripts that I should be aware of for IDA Pro ?


  • Publish
    Re: TX-1 Firmware has been dumped...!!!
    « Reply #5 on: 12 / March / 2008, 10:55:01 »
    Yayeee! I'm SO excited! I didn't wanna interrupt, but I just HAD to thank everyone for their efforts!
    This is the coolest EVER!
    You smite like a girl!

    *

    Offline ewavr

    • ****
    • 1057
    • A710IS
  • Publish
    Re: TX-1 Firmware has been dumped...!!!
    « Reply #6 on: 12 / March / 2008, 11:11:12 »
    To Microfunguy:

    After loading dump in IDA I see why you could not turn on any LED: all of them controlled only with PWM (UniqueLedOn()/UniqueLedOff() functions, no 0x46/0x44 access).

  • Publish
    Re: TX-1 Firmware has been dumped...!!!
    « Reply #7 on: 12 / March / 2008, 11:28:42 »
    To Microfunguy:

    After loading dump in IDA


    I must be doing something wrong, I only see zeros !

    I renamed file TX1.BIN and loaded into IDA.

    Gave ROM start address and loading address as 0xFFC00000    .. it did not like that.

    Tried leaving the addresses at 0x00000000 and I do not see any code.


    David


    *

    Offline ewavr

    • ****
    • 1057
    • A710IS
  • Publish
    Re: TX-1 Firmware has been dumped...!!!
    « Reply #8 on: 12 / March / 2008, 11:34:11 »
    Just uploaded to:

    zSHARE - tx-1_dump_080312

    And then downloaded file to confirm accuracy. It's fine.

    Please note, I did not try to remove any leading or trailing zeros from the file. It is just the raw dump of empty.bin renamed to TX-1_dump_080312.

    This dump after cropping/zipping http://www.zshare.net/download/8830648da10fa6/
    Load address is 0xFF810000.

  • Publish
    Re: TX-1 Firmware has been dumped...!!!
    « Reply #9 on: 12 / March / 2008, 11:47:57 »

    Load address is 0xFF810000.



    Hmmm .. so that is like the 'S', 'SD'  and 'G' series rather than the 'A' series

    The 'S' series caused problems with USB-remote but the others were OK.

     

    Related Topics