Starting CHDK on an A495 - button sequence??? - General Help and Assistance on using CHDK stable releases - CHDK Forum  

Starting CHDK on an A495 - button sequence???

  • 5 Replies
  • 2643 Views
Starting CHDK on an A495 - button sequence???
« on: 13 / February / 2012, 15:42:17 »
Advertisements
I have not been able to get CHDK to run on my A495. I CAN get the camera to recognize CHDK though as when I press the MENU button I CAN update the firmware. But when the update finishes the camera turns off and when turned back on - nothing.

Is there a sequence of button presses for the A495 to get to the CHDK menu that I am unaware of? There is no "display" button or "program" button - just the "FUNC SET" button and the "MENU" button seem to work.

Any help here is very much appreciated!

Hillbille

Re: Starting CHDK on an A495 - button sequence???
« Reply #1 on: 13 / February / 2012, 15:45:29 »
Sounds like you might be loading the wrong firmware version.  Did you see the CHDK logo after the "firmware update" ?   If the cameras turns off right away then its crashing.  After a restart, CHDK is gone so finding a button sequence won't help you.

Ported :   A1200    SD940   G10    Powershot N    G16

Re: Starting CHDK on an A495 - button sequence???
« Reply #2 on: 13 / February / 2012, 17:49:29 »
Sounds like you might be loading the wrong firmware version.  Did you see the CHDK logo after the "firmware update" ?   If the cameras turns off right away then its crashing.  After a restart, CHDK is gone so finding a button sequence won't help you.



Yes I see the CHDK logo - but cannot get to the menu. The FIRST time through it all works fine. I turn on in PLAYBACK mode, go to the menu, run the firmware update and CHDK loads, the logo stays up and the camera stays on. I press the playback button and the <ALT> appears allowing access to the CHDK menu. I can go into the menu and set up a script (inteval) and set the card to be bootable. Exit the CHDK menu. Camera off.  Set the card to "locked" and reinsert. Turn on the camera - NOTHING. The camera reports the card is "LOCKED" and then does nothing.

Do I need to partition the card (it is a 4GB sandisk) for this to work? After I lock the card and insert it back into the camera I can no longer get the CHDK to load and I can not get the firmware to update again properly. The only way anything works again is if I format the card (in camera) and then reload (extract) CHDK onto the card fresh. THEN it will allow me to update the firmware - and back to the same story -

So what am I doing wrong?

Hillbille

*

Offline zeno

  • *****
  • 889
Re: Starting CHDK on an A495 - button sequence???
« Reply #3 on: 13 / February / 2012, 18:14:42 »
If you want to be able to have CHDK automatically load when the camera is switched on then you will have to format the cards as FAT16, not FAT32. There are several ways to do this - perhaps the easiest is to use the SDMInst.exe program that's part of SDM. You'll find it in the common_files.zip file here http://stereo.jpn.org/eng/sdm/file/common_files.zip.
CardTricks is another program that will do the job - see http://chdk.setepontos.com/index.php/topic,964.0.html

If you're using a Mac my SDMInst.app will do the job - see http://www.zenoshrdlu.com/clickpansdm/sdminst.html
A570, S100, Ixus 127
Author of ASSIST, STICK, WASP, ACID, SDMInst, LICKS, WICKS, MacBoot, UBDB, CFGEdit


Re: Starting CHDK on an A495 - button sequence???
« Reply #4 on: 13 / February / 2012, 18:57:19 »
Okay I'll try that. I thought formatting the card in the camera solved the problem - but I am still learning!! LOL!! It's amazing what little things are so important!!

I am trying to get a intervalometer to run and - yes - I would like for it to run automatically at start-up. I already have an A530 set to do this same thing but it has been through a lot - (LOL!!) - and I would like to have a little better camera to do this with so that is why I am trying this. You guys have no idea how appreciated your help and work in finding the "cures" for all of us "others" is! Thank you very much!!

Hillbille

Re: Starting CHDK on an A495 - button sequence???
« Reply #5 on: 13 / February / 2012, 23:54:21 »
That was all that was wrong was the formatting of the card. Works fine now!

Thanks again!

Hillbille

 

Related Topics