Ixus 800 IS damaged due to CHDK ? - Hello, I'm a NEWBIE - HELP!! (Newbies assistance, User Guides and thank you notes) - CHDK Forum
supplierdeeply

Ixus 800 IS damaged due to CHDK ?

  • 9 Replies
  • 3204 Views
Ixus 800 IS damaged due to CHDK ?
« on: 19 / February / 2012, 09:58:31 »
Advertisements
Hi everyone

I have an IXUS 800 IS

P-ID:3119 PAL
Firmware: Ver GM1.01A
E18
June 6 2006  20:54:08

I have loaded CHDK:
ixus800_sd700-101a-0.9.9-874-full

Normally when I half press the photo button I can hear the autofocus acting and the camera adjusts.
This feature is now gone, what could be the choices in the menu.

BUT: when I upload CHDK, go in <alt> mode to run a script (e.g. the default script), then go out of <alt> mode this feature is back.
When I switch off the camera if I switch it on a short time later this feature is generally (but not always) still present, if I switch it on after several tens of minutes it is always off

Any idea of what I can do to recover this feature? I use it a lot.

Thank you

Re: Ixus 800 IS damaged due to CHDK ?
« Reply #1 on: 19 / February / 2012, 10:16:52 »
Delete CHDK from your SD card and restart camera with SD card lock in the unlock position.  Does the feature work properly again?  If so, the answer to your questions  "Ixus 800 IS damaged due to CHDK ?"  is No.
Ported :   A1200    SD940   G10    Powershot N    G16

Re: Ixus 800 IS damaged due to CHDK ?
« Reply #2 on: 19 / February / 2012, 12:41:44 »
Delete CHDK from your SD card and restart camera with SD card lock in the unlock position.  Does the feature work properly again?  If so, the answer to your questions  "Ixus 800 IS damaged due to CHDK ?"  is No.

already done, I have tried with another card, never used with CHDK, and this feature don't work.

It seems that running a script activates this function but later the firmware "forget" to activate it.

Re: Ixus 800 IS damaged due to CHDK ?
« Reply #3 on: 19 / February / 2012, 14:51:22 »
It seems that running a script activates this function but later the firmware "forget" to activate it.
Sorry, but its pretty hard to imagine that this has anything to do with CHDK.  There is just nothing in the code that would cause what you describe.  And nobody else has reported this even though the code that handles scripts is common to all cameras.

Your camera does have an AF-Lock function and AiAF mode (pg 49 - 51 in then IXUS800IS user's manual).  Are you sure you are not activiting / changing these settings in some way ?
Ported :   A1200    SD940   G10    Powershot N    G16


Re: Ixus 800 IS damaged due to CHDK ?
« Reply #4 on: 19 / February / 2012, 16:44:55 »
Just done a new test
I start the camera, press halfway the shutter, no AF action
I place the card with CHDK,
go in <ALT> mode,
load a script
go out of <alt> mode
press halfway the shutter, the AF act and the speed and aperture are displayed on bottom of the screen.

I switch off the camera, switch it five minutes after: no AF action when I press halfway the shutter

I redo the same thing, load the script
and when when I press halfway the shutter the AF works and display the parametres

I can reproduce it as I want: the halfway shutter act only if I have loaded a script.

I don't have the AiAF mode, it is not in the camera menu

I have this issue in automatic mode, so the AF lock function ( thanks for the information, is is quite hidden and as I never use the manual mode...) should not interfere.

Agree it is pretty hard to imagine a direct action of CHDK, but it is pretty hard also to imagine a failure of the firmware and moreover a failure corrected when loading a script

Strange behaviour....

Thanks

Re: Ixus 800 IS damaged due to CHDK ?
« Reply #5 on: 19 / February / 2012, 16:53:50 »
I don't have the AiAF mode, it is not in the camera menu
Hmmm .... from the ixus800is manual :
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline fe50

  • ******
  • 3132
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: Ixus 800 IS damaged due to CHDK ?
« Reply #6 on: 20 / February / 2012, 01:15:36 »
@PounetBF
Did you already reset your camera's settings, from the Canon menu ?

Re: Ixus 800 IS damaged due to CHDK ?
« Reply #7 on: 20 / February / 2012, 13:27:39 »
@ waterwingz
Yes, I have seen this in the user guide; Sorry I was checking in auto mode, (99% of the usage) where this choice doesn't exist.

@fe50
yes, I have tried, without effect

This halfway shutter function is erratic, when I have switched on the camera today it was working,  then after several off-on it has stopped to work. Sometimes it start to work 15 or 20 second after the camera has been switched on.

The interesting point is that to run a script always activate this function.


*

Offline reyalp

  • ******
  • 13393
Re: Ixus 800 IS damaged due to CHDK ?
« Reply #8 on: 20 / February / 2012, 16:26:33 »
@ waterwingz
Yes, I have seen this in the user guide; Sorry I was checking in auto mode, (99% of the usage) where this choice doesn't exist.

@fe50
yes, I have tried, without effect

This halfway shutter function is erratic, when I have switched on the camera today it was working,  then after several off-on it has stopped to work. Sometimes it start to work 15 or 20 second after the camera has been switched on.

The interesting point is that to run a script always activate this function.
Is it only AF that fails to happen, or all the half-shoot related functions ?

Assuming it's all half-shoot related functions, I would suspect the physical button hardware is failing in such at way that it makes contact intermittently. It wouldn't be out of the question for CHDK to have some impact on how the camera responds to this when CHDK is loaded (CHDK sits in between the hardware values and the variable that the rest of the firmware looks at for that state, so for example if the hardware state was rapidly changing due to an intermittent contact, CHDK might smooth that out in some cases)

IMO it's *extremely* unlikely that this was caused by CHDK. There's really no conceivable mechanism for it to have this kind of effect when CHDK isn't loaded.
Don't forget what the H stands for.

Re: Ixus 800 IS damaged due to CHDK ?
« Reply #9 on: 21 / February / 2012, 00:49:10 »

Is it only AF that fails to happen, or all the half-shoot related functions ?

Assuming it's all half-shoot related functions, I would suspect the physical button hardware is failing in such at way that it makes contact intermittently. It wouldn't be out of the question for CHDK to have some impact on how the camera responds to this when CHDK is loaded (CHDK sits in between the hardware values and the variable that the rest of the firmware looks at for that state, so for example if the hardware state was rapidly changing due to an intermittent contact, CHDK might smooth that out in some cases)

IMO it's *extremely* unlikely that this was caused by CHDK. There's really no conceivable mechanism for it to have this kind of effect when CHDK isn't loaded.

It is the halfway function.
I have also suspected the button hardware but when I switch on the camera I always have a stable case:  the halfway function  works always or works never. And this will stay this way until the camera is switched off. This is not the behaviour of a defective electrical contact.

 

Related Topics