help with firmware version for SX230 - General Help and Assistance on using CHDK stable releases - CHDK Forum

help with firmware version for SX230

  • 4 Replies
  • 2114 Views
help with firmware version for SX230
« on: 22 / February / 2012, 22:53:21 »
Advertisements
I installed the chdk a few years ago on my SD1100, so I have a general idea what I'm doing. But, I feel silly right now, because I can't find my camera's firmware number. I put a ver.req and a vers.req file on the root directory of my card, and I have been holding down func, hitting display, hitting down, etc, and it isn't doing anything except showing me the date and time in crazy colors. I have a mac, so I used TextEdit to make the files, and I was careful to pick plain text, unicode 16 encoding, and uncheck using .txt as a default. I read in the FAQ that for the SX220 specifically you should hold down func and then press down while still holding down func, so I tried that, but it didn't work. Is there some other trick for the SX230?

Thanks!
My Flickr Page
I use the chdk on my SX230 and SD1100 cameras, and I installed them using a Macbook, currently running 10.6.8.

*

Online reyalp

  • ******
  • 13392
Re: help with firmware version for SX230
« Reply #1 on: 22 / February / 2012, 23:12:04 »
unicode 16 encoding, and uncheck using .txt as a default.
You want ASCII encoding, not unicode. Also watch out for chdk.wikia.com/wiki/FAQ/Mac#Still_Having_Trouble.3F

You can also try http://www.zenoshrdlu.com/acid/acid.html
Don't forget what the H stands for.

Re: help with firmware version for SX230
« Reply #2 on: 22 / February / 2012, 23:27:00 »
I put a ver.req and a vers.req file on the root directory of my card, and I have been holding down func, hitting display, hitting down, etc, and it isn't doing anything except showing me the date and time in crazy colors.

With the write protect swich turned off, it displays the crazy tumbling date and time whenever you press the FUNC SET button slightly too long before also pressing the DISP button. The trick is... within a short fraction of a second after you press the FUNC SET button, also press the DISP button. It should then display the firmware information.

Re: help with firmware version for SX230
« Reply #3 on: 22 / February / 2012, 23:29:48 »
I just tried "Western (ASCII)" and that didn't work either. But ACID worked - tells me my firmware is 101c, and is working on downloaded the right CHDK files. Thanks!
My Flickr Page
I use the chdk on my SX230 and SD1100 cameras, and I installed them using a Macbook, currently running 10.6.8.


Re: help with firmware version for SX230
« Reply #4 on: 22 / February / 2012, 23:54:04 »
With the write protect swich turned off, it displays the crazy tumbling date and time whenever you press the FUNC SET button slightly too long before also pressing the DISP button. The trick is... within a short fraction of a second after you press the FUNC SET button, also press the DISP button. It should then display the firmware information.

For the record, I just tried that several times, and I couldn't get it to work, but its possible I was just doing it wrong. However, I think I found the right firmware version using ACID so this particular problem is solved.

I'm now moving on to other problems ... so I will leave this here for the next person who has this firmware question, and start another thread for the rest of it.
« Last Edit: 23 / February / 2012, 00:30:48 by CanonBlue »
My Flickr Page
I use the chdk on my SX230 and SD1100 cameras, and I installed them using a Macbook, currently running 10.6.8.

 

Related Topics