TX-1 - loading to IDA and porting...

  • 88 Replies
  • 12299 Views
  • Publish
    Re: TX-1 - loading to IDA and porting...
    « Reply #10 on: 12 / March / 2008, 16:58:26 »
    Advertisements
    (UniqueLedOn()/UniqueLedOff() functions


    I tried searching for those functions and IDA does not find them.

    *

    Offline GrAnd

    • ****
    • 916
    • [A610, S3IS]
      • CHDK
  • Publish
    Re: TX-1 - loading to IDA and porting...
    « Reply #11 on: 12 / March / 2008, 17:15:01 »
    The link in this page Loading dump to IDA - CHDK Wiki seems work for me.

    It does not work for me, I just see adverts.

    Where abouts on the page would the link be ?


    Does it expect you to have Javascript enabled ?

    Ok. As that hosting service is free there are ads everywhere. :)
    When I click to the link from the wiki I get the page with the another link and the red button. If I click any of them, the download begins.

    « Last Edit: 12 / March / 2008, 17:20:13 by GrAnd »
    CHDK Developer.

  • Publish
    Re: TX-1 - loading to IDA and porting...
    « Reply #12 on: 12 / March / 2008, 17:26:27 »
    I get the page with the another link and the red button.


    Thanks.

    I did not think the red button was for download because the cursor did not change when I hovered over it.


    I guess I will have to study the WIKI about porting next  .. unless EVAWR has already finished it   :)

  • Publish
    Re: TX-1 - loading to IDA and porting...
    « Reply #13 on: 12 / March / 2008, 18:30:56 »
    To All:

    I don't know if this is the proper place for "Features Request" but for me, the priorities would be:

    Dual synchronized Remote trigger by USB port (esp. since I'm already building my twin TX-1 release. I'll upload pix when done);

    Synchronized flash control using twinned cameras;

    Extended shutter speeds - 1/10,00th sec to 60 sec.

    I've spoken with three other TX-1 owners who agree that these would be first priorities for them as well. One also wanted to be able to access the RAW files if possible.

    TIA,

    ~~~~~~~~~~~~~~~~~~~~~

    <")%%%><<


  • Publish
    Re: TX-1 - loading to IDA and porting...
    « Reply #14 on: 12 / March / 2008, 18:36:34 »

    I don't know if this is the proper place for "Features Request" but for me, the priorities would be:

    Dual synchronized Remote trigger by USB port

    You are getting way ahead of the game  :)

    First, it has to be ported to CHDK by modifying some platform and loader files.

    (I have never done that so will read the WIKI).

    Once that is done, it is relatively easy to add to SDM.


    That is some way down the road  ..........



    David

    *

    Offline ewavr

    • ****
    • 1057
    • A710IS
  • Publish
    Re: TX-1 - loading to IDA and porting...
    « Reply #15 on: 12 / March / 2008, 19:19:05 »
    If strings are not aligned properly (by DWORD), they can be recognized incorrectly. But IDA in this case is not able to recognize that strings at all.

    But string is uncorrupted. After findstrings() strings looks like:
    Code: [Select]
    ROM:FFF666C7                 DCB 0x49 ; I
    ROM:FFF666C8 aMage           DCB "mage",0
    ROM:FFF666CD                 DCB 0x53 ; S
    ROM:FFF666CE                 DCB 0x74 ; t
    ROM:FFF666CF                 DCB 0x61 ; a
    ROM:FFF666D0 aNdard_4        DCB "ndard",0
    also without XREFs... The most bad, that in "strings" window strings also are corrupted, I cannot find anything...

    You can just comment out the call of  'findStrings()' procedure in 'CHDK.idc' to skip strings recognition.

    Thanks.
    « Last Edit: 12 / March / 2008, 19:30:07 by ewavr »

  • Publish
    Re: TX-1 - loading to IDA and porting...
    « Reply #16 on: 12 / March / 2008, 19:41:40 »
    The dump that I have ends at 0xffc0fff.

    *

    Offline whim

    • ******
    • 2013
    • A495/590/620/630 ixus70/115/220/230/300/870 S95
  • Publish
    Re: TX-1 - loading to IDA and porting...
    « Reply #17 on: 12 / March / 2008, 22:41:59 »
    @ewavr

    I know you want/need IDA to recognize the strings, but until that works, maybe this is helpful
    does ascii & unicode  (util + txtfile attached)

    wim


    *

    Offline GrAnd

    • ****
    • 916
    • [A610, S3IS]
      • CHDK
  • Publish
    Re: TX-1 - loading to IDA and porting...
    « Reply #18 on: 13 / March / 2008, 02:51:03 »
    If strings are not aligned properly (by DWORD), they can be recognized incorrectly. But IDA in this case is not able to recognize that strings at all.

    But string is uncorrupted. After findstrings() strings looks like:
    Code: [Select]
    ROM:FFF666C7                 DCB 0x49 ; I
    ROM:FFF666C8 aMage           DCB "mage",0
    ROM:FFF666CD                 DCB 0x53 ; S
    ROM:FFF666CE                 DCB 0x74 ; t
    ROM:FFF666CF                 DCB 0x61 ; a
    ROM:FFF666D0 aNdard_4        DCB "ndard",0
    also without XREFs... The most bad, that in "strings" window strings also are corrupted, I cannot find anything...

    The IDC-scripts assumes that all in a program (code and data) is properly aligned (by 4 bytes). In general, thats correct approach for ARM code. But in firmware there are some parts of data with 1 byte alignment. So, findstrings() searches for strings starting from ..0, ..4, ..8, ..C addresses, and in this case misses the correct start point of string. This behavior can be changed in 'scan-strings.idc', just look for '4' constant.
    CHDK Developer.

    *

    Offline GrAnd

    • ****
    • 916
    • [A610, S3IS]
      • CHDK
  • Publish
    Re: TX-1 - loading to IDA and porting...
    « Reply #19 on: 13 / March / 2008, 03:03:52 »
    The dump that I have ends at 0xffc0fff.

    That's correct. Or you expected the dump till 0xffffffff?
    The firmware itself is not larger than 4MB. You can see a lot of 0xFF bytes at the end of the dump - that means there is nothing there.
    CHDK Developer.

     

    Related Topics