sx40HS power up ? - General Help and Assistance on using CHDK stable releases - CHDK Forum

sx40HS power up ?

  • 3 Replies
  • 1406 Views
sx40HS power up ?
« on: 21 / March / 2012, 01:23:06 »
Advertisements
why when i use chdk in the sx40 it powers up like its in play mode?

when i power it up i have to hit the record button EVERY time............. = GRRRRRRRRRRRRRR

without chdk it powers up perfectly in the PROPER mode live view.

is this going to be some sort of "normal" thing ?

Re: sx40HS power up ?
« Reply #1 on: 21 / March / 2012, 01:27:27 »
well i think i found my "isue" ..............
i cant just Hit the power button quick....
I have to HOLD the Power button untill powered on.

I dont think i like this at all  :(

*

Offline reyalp

  • ******
  • 12314
Re: sx40HS power up ?
« Reply #2 on: 21 / March / 2012, 01:32:21 »
is this going to be some sort of "normal" thing ?
If you hold the power button a bit longer, it should start in record mode.

Unfortunately, this is an unavoidable byproduct of how CHDK starts. What happens is the camera boots, then reboots using CHDK. When it does this, the information about which button was used to start the camera (play or power) is lost.

While you can make the code so that it always starts in record mode, we don't do that for CHDK because someone pressing play might not expect the lens to extend. This could damage the camera if it was somewhere without room to open. We can't make starting in record or play a user option, because the information is needed before the OS is loaded enough to read the config file.
Don't forget what the H stands for.

Re: sx40HS power up ?
« Reply #3 on: 21 / March / 2012, 14:09:45 »
ok ....
Im getting use to it this is the FIRST day with this camera...
 ::)


 

Related Topics