S100 porting thread - page 5 - DryOS Development - CHDK Forum  

S100 porting thread

  • 286 Replies
  • 97182 Views
*

Offline asm1989

  • *****
  • 527
  • SX720, SX260, SX210 & SX200
Re: S100 porting thread
« Reply #40 on: 29 / April / 2012, 08:09:07 »
Advertisements
thanks whim, It worked fine

we have to resolve why new cams fail to load the FI2,

 I mean manualy loading you can allways use canon firmaware with outoload you need another sd card.

*

Offline c10ud

  • ***
  • 245
Re: S100 porting thread
« Reply #41 on: 29 / April / 2012, 10:50:37 »
@c10ud

Where you able to load chdk usign the FI2 file, via fimware update menu?

I think s100 & sx260 have the same issue with this,  and blocks the use of sd cards greater than 32Gb.
No, but i never tested it.

But i saw other people testing this and reported it failing. I'm not really into this FI2 thing (i find diskboot much better) so i don't know what to say..

Re: S100 porting thread
« Reply #42 on: 30 / April / 2012, 11:19:00 »
Hi c10ud,
Following this thread closely as I can't wait to use CHDK on my S100! :)

When can we expect an official release?
And can I participate in the beta?

*

Offline c10ud

  • ***
  • 245
Re: S100 porting thread
« Reply #43 on: 30 / April / 2012, 11:45:13 »
Hello, you can find the s100 beta build in the autobuild website already:
http://www.mighty-hoernsche.de/trunk/

beware this is not a stable release


Re: S100 porting thread
« Reply #44 on: 01 / May / 2012, 22:17:39 »
I wish I could code so that I could help more. Except for the battery levels being wrong issue, this build is pretty solid so far.  I personally used EOScard 1.2 to make my SD card bootable, loaded my CHDK files on the card, then locked my card. I can now just turn on my camera by pressing and holding the play or on/off button.  (no FI2 file needed)  :D

I searched the internet for specific information about this build and could not find any.  So I will write the specific information for anybody who is looking for it.

Features I have tested and work (so far):
* ISO override from 50 to 7500
* shutter speed override from 1/5000 to 2048 (34 minutes  :o
(I actually set a timer and returned just in time to here here the shutter close.  1 Picture took about an hour total an completely drained the battery)

* Aperture seem to stay within specs 2 to 8 (override higher than 8 seems to nothing)

* USB remote features all work well using a simple remote (could not test Ricoh CA-1)

I don't have a lot of time because of work.  In my spare time I have been testing out this build of CHDK.  I will write more as I get a chance.

EDIT:
hey c10ud.....when you try and choose a script from shooting mode it brings up the file browser but nothing gets highlighted so you can't really see what your are choosing.  I mean it is minor since in play mode the browser is a bit different and it does highlight things.  Kind of weird but just noticed it.
« Last Edit: 02 / May / 2012, 00:04:14 by colon247 »

Re: S100 porting thread
« Reply #45 on: 02 / May / 2012, 00:24:44 »
hey c10ud.....when you try and choose a script from shooting mode it brings up the file browser but nothing gets highlighted so you can't really see what your are choosing.  I mean it is minor since in play mode the browser is a bit different and it does highlight things.  Kind of weird but just noticed it.
Welcome to the world of Canon color palettes.  Canon changes the palette it uses as it enter different modes ( playback, shooting, setup, video etc).  CHDK currently has no good way to track this so the menu and OSD colors change as the Canon mode changes.   Careful selection of colors can help but a good fix has not been worked out for this ( although philmoz has implemented a specialized fix for a few cameras).
Ported :   A1200    SD940   G10    Powershot N    G16

Re: S100 porting thread
« Reply #46 on: 03 / May / 2012, 18:45:58 »
I finally figured out I don't need to know coding that much using one of the gui's .  So my question is what would I have to do to make things better. 

For example how do I find battery max and min?
how do I help with circle of confusion?
....ect?

I dont have all the time in the world but with a little guidance maybe I can really help.

Re: S100 porting thread
« Reply #47 on: 03 / May / 2012, 21:55:45 »
I finally figured out I don't need to know coding that much using one of the gui's .  So my question is what would I have to do to make things better. 
Probably the biggest thing you could do to help is test each version that you see released here.  Especially the changes.   Feedback from users is really really valued by the CHDK developers !

Quote
For example how do I find battery max and min? how do I help with circle of confusion?
....etc? I dont have all the time in the world but with a little guidance maybe I can really help.
I really hate to "rain on your parade" here,  but by the time someone walks you through what it takes to make these sort of changes,  they can make the changes themselves and post patches.   However,  just testing what works and does not work AND POSTING YOUR RESULTS  is a really important thing - the devs do fixes and mostly hope nothing else breaks.  Feedback helps a lot.

Update :  okay, if you really want to try out making a change,  compiling it and seeing it take effect,  then to change the values for battery min and max at the bottom of the main.c file in trunk/platform/s100/main.c. 

Code: [Select]
long get_vbatt_min()
{
    return 3000;     // 3 volts
}

long get_vbatt_max()
{
    return 4100;    // 4.1 volts
}
Play with the values until they work well for the S100.
« Last Edit: 04 / May / 2012, 00:13:33 by waterwingz »
Ported :   A1200    SD940   G10    Powershot N    G16


*

Offline asm1989

  • *****
  • 527
  • SX720, SX260, SX210 & SX200
Re: S100 porting thread
« Reply #48 on: 04 / May / 2012, 08:53:31 »
colon247 ,

for Circle Of Confusion
using exiftool-8.90 on a JPG taken by your cam will get something like this:
......
"Circle Of Confusion             : 0.005 mm"
....


Re: S100 porting thread
« Reply #49 on: 04 / May / 2012, 19:26:49 »
waterwingz......thanks, I know it is a bit hard but I learn quick.  I will soon try changing those numbers and see where I get.  No promises but if I get somewhere with these numbers I will post.

asm1989.....thanks a lot......the circle of confusion right now in "shooting.c" is
Code: [Select]
int circle_of_confusion = 5; //TODO:
I am assuming this is wrong.  So far after checking all my pictures and every picture on flickr taken with a s100 is seem that the number is .006 instead of .005   

This might be a dumb question but what happens when this number is wrong?





 

Related Topics