S100 porting thread - page 7 - DryOS Development - CHDK Forum supplierdeeply

S100 porting thread

  • 286 Replies
  • 107016 Views
Re: S100 porting thread
« Reply #60 on: 07 / May / 2012, 11:19:22 »
Advertisements
I have already placed the new Fi2enc.c in "tools\packfi2".   I just need the "Fi2key" and "Fi2IV" values for the "fi2.inc" and I can test it.

I also already removed:
Code: [Select]
#suppress FI2 since it doesn't work
override OPT_FI2=

I get an error right now because I don't have the Fi2 values


if anyone can find these please share with me  :)
« Last Edit: 07 / May / 2012, 11:34:02 by colon247 »

*

Offline funnel

  • ****
  • 349
Re: S100 porting thread
« Reply #61 on: 07 / May / 2012, 15:02:09 »
for ver 101a you can find them

FI2KEY is at offset 0xFF3B28
FI2IV offset 0x63AF20

they look like this

FI2KEY=F7ABABABABABABABABABABABABA70
FI2IV   =F7ABABABABABABABABABABABABA98

first and last byte are correct for orientation. You can use a simple hex editor.

http://chdk.wikia.com/wiki/For_Developers/fi2offsets
EDIT: typos
« Last Edit: 08 / May / 2012, 02:47:18 by funnel »

*

Online philmoz

  • *****
  • 3427
    • Photos
Re: S100 porting thread
« Reply #62 on: 07 / May / 2012, 16:07:13 »
since i don't have the camera anymore i'm not working on this, but i am confident that the fix for sx260 will apply to s100 too, just wait until it gets upstreamed or apply the patch by yourself ;)

Unlikely, the S100 has DryOS version R49. I checked and it has the same block record size as other cameras up to that version.

Do you get an 'Update file error' when you try and manual boot or does the camera simply lock up?

The 'Update fle error' will occur if the file size or checksum are wrong, the platform id is wrong or there is no boot block record in the file. The new entry in the block record for R50 threw off the file size calculation which is why the SX260 gives this error.

Phil.
CHDK ports:
  sx30is (1.00c, 1.00h, 1.00l, 1.00n & 1.00p)
  g12 (1.00c, 1.00e, 1.00f & 1.00g)
  sx130is (1.01d & 1.01f)
  ixus310hs (1.00a & 1.01a)
  sx40hs (1.00d, 1.00g & 1.00i)
  g1x (1.00e, 1.00f & 1.00g)
  g5x (1.00c, 1.01a, 1.01b)
  g7x2 (1.01a, 1.01b, 1.10b)

Re: S100 porting thread
« Reply #63 on: 07 / May / 2012, 17:12:26 »
I have been working on this all day and failed. 
philmoz....I think originally it just locked up.  people stated it went to black screen and that was that.

I just wish I knew the right offsets for 101a  so that I could help with this.


I might have found one but not the other. 

Funnel was talking about 101b.  I did not think there was a 101b.

  :blink:  maybe someone will figure this out.    someone smarter than me....hahahaha


*

Offline funnel

  • ****
  • 349
Re: S100 porting thread
« Reply #64 on: 07 / May / 2012, 17:50:56 »
Quote
I did not think there was a 101b.

Sorry, I meant 1.01a.

Re: S100 porting thread
« Reply #65 on: 07 / May / 2012, 21:52:55 »
Okay I after setting the keys and builing a PS.FI2 these were the results:

old fi2enc.c - when I choose the firmware update....the camera just turned off

SX260's fi2enc.c - when I go to try and choose update I get an update error

*

Online philmoz

  • *****
  • 3427
    • Photos
Re: S100 porting thread
« Reply #66 on: 07 / May / 2012, 22:21:00 »
SX260's fi2enc.c - when I go to try and choose update I get an update error

This will create a PS.FI2 file with the wrong block record size so the file will fail the validation checks (the file size calculation will fail). Hence the 'update file error' message.

There are a number of cameras that just don't work with manual booting at the moment.

It should be possible since Canon has released a real firmware update for the camera; but it will require more detailed investigation into the boot process and perhaps detailed analysis of the Canon firmware update file.

Phil.
CHDK ports:
  sx30is (1.00c, 1.00h, 1.00l, 1.00n & 1.00p)
  g12 (1.00c, 1.00e, 1.00f & 1.00g)
  sx130is (1.01d & 1.01f)
  ixus310hs (1.00a & 1.01a)
  sx40hs (1.00d, 1.00g & 1.00i)
  g1x (1.00e, 1.00f & 1.00g)
  g5x (1.00c, 1.01a, 1.01b)
  g7x2 (1.01a, 1.01b, 1.10b)

Re: S100 porting thread
« Reply #67 on: 08 / May / 2012, 13:31:43 »
I used for a long time a S95 camera with CHDK, and now I have a S100 on my hands but I'm not figuring out how to boot the CHDK on this camera, I saw that the firmware version is 1.01a so I formated the card and make it bootable with cardTricks then copied the right files, but when I locked the card and put it on the camera, it doesn't boot (the same thing happens in S95 if put the wrong firmware version on the card).

Am I doing something wrong ? I really need the CHDK, because I use the camera in UAVs and I need the remote trigger function and to run a script that I developed to set some configs like Focus.

Thanks in advance.


Re: S100 porting thread
« Reply #68 on: 08 / May / 2012, 16:47:16 »
fvztdk ---

Dont know if it makes a difference but I made my card bootable with EOScard 1.2

Just format your card, use EOScard 1.2, then place the right files from 101a you just unzipped.

press and hold play to turn on your camera you will see CHDK logo.  then have fun.  :D



if it still does not work---- :(
Are you sure you have 101a.   take a picture (of something like your wall for simplicity) with your camera, upload it to Flickr, then post a link I will double check the firmware version for you.


Re: S100 porting thread
« Reply #69 on: 09 / May / 2012, 12:14:01 »
fvztdk ---

Dont know if it makes a difference but I made my card bootable with EOScard 1.2

Just format your card, use EOScard 1.2, then place the right files from 101a you just unzipped.

press and hold play to turn on your camera you will see CHDK logo.  then have fun.  :D



if it still does not work---- :(
Are you sure you have 101a.   take a picture (of something like your wall for simplicity) with your camera, upload it to Flickr, then post a link I will double check the firmware version for you.



I tested the firmware version with CameraVersion13 that I get on CHDK website.

I will try the EOScard software.

 

Related Topics