SX240 HS Porting Thread - page 12 - DryOS Development - CHDK Forum supplierdeeply

SX240 HS Porting Thread

  • 174 Replies
  • 67134 Views
Re: SX240 HS Porting Thread
« Reply #110 on: 15 / November / 2012, 14:44:55 »
Advertisements
I put all the files on the sd card. test not successful. firmware-update menu button not available.
I noticed that the file ps.fi2, which was contained in the other ports I tried (100a and 100c)  is missing in the zip you sent me. Could thi be the issue?

Re: SX240 HS Porting Thread
« Reply #111 on: 15 / November / 2012, 15:19:20 »
@nafnaf
I also got a sx240 101a and I'm interested to test the prealpha version as well.
Can you provide me a link?

Regards

*

Offline nafraf

  • *****
  • 1308
Re: SX240 HS Porting Thread
« Reply #112 on: 15 / November / 2012, 15:27:38 »
I also got a sx240 101a and I'm interested to test the prealpha version as well.
Can you provide me a link?
I sent the link by PM.  Please use the Bootable SD-Card Method to load CHDK.

Re: SX240 HS Porting Thread
« Reply #113 on: 16 / November / 2012, 13:48:14 »
It loads! I did the recommended script tests:
llibtst: os fail 2
setmode: everything ok
ubtest: everything ok
do some practical testing and report.
looks very promising!!  8)


*

Offline nafraf

  • *****
  • 1308
Re: SX240 HS Porting Thread
« Reply #114 on: 16 / November / 2012, 14:19:11 »
It loads! I did the recommended script tests:
llibtst: os fail 2
Could you post the log file? Thanks

Re: SX240 HS Porting Thread
« Reply #115 on: 17 / November / 2012, 04:26:52 »
Could you post the log file? Thanks

here you go

Re: SX240 HS Porting Thread
« Reply #116 on: 17 / November / 2012, 07:12:35 »
zebra mode seems not to work  :(
it works (sorry, I'm new to chdk... )  :-[
« Last Edit: 17 / November / 2012, 07:23:15 by JamesBMI6 »

Re: SX240 HS Porting Thread
« Reply #117 on: 17 / November / 2012, 17:38:14 »
Hello,
i bougt a SX240HS today, but with FW 1.01A.
I dumped the Firmware using EOScard and universal Dumper script. You can find all the Files here:   https://www.box.com/s/pmqax9j8dtl9l3gkgtyr

When i compared my dumpfile with the 1.01A file on the Wiki, there are some differences (yellow):

I don't know if the difference is OK or if i failed at dumping.
Anyway i would be happy if i could test the prealpha, too.

Regards
Ur@n


*

Offline reyalp

  • ******
  • 14080
Re: SX240 HS Porting Thread
« Reply #118 on: 17 / November / 2012, 17:52:16 »
When i compared my dumpfile with the 1.01A file on the Wiki, there are some differences (yellow):
I don't know if the difference is OK or if i failed at dumping.
Anyway i would be happy if i could test the prealpha, too.
Assuming the low address is at the top, this is probably as expected. The camera keeps calibration data, settings, crash logs etc in the same flash memory that serves as "ROM"
Don't forget what the H stands for.

Re: SX240 HS Porting Thread
« Reply #119 on: 17 / November / 2012, 17:55:53 »
I dumped the Firmware using EOScard and universal Dumper script. You can find all the Files here:   https://www.box.com/s/pmqax9j8dtl9l3gkgtyr
Once there is already a dump for the firmware version of your camera,  we don't need another one.

Quote
When i compared my dumpfile with the 1.01A file on the Wiki, there are some differences (yellow):
I don't know if the difference is OK or if i failed at dumping.
What you are seeing is normal.  At the end of the Canon code there is typically an area that changes somewhat - camera configuration variable and things like that are store there.    Beyond that is typically unused memory.

Ported :   A1200    SD940   G10    Powershot N    G16

 

Related Topics