sx40 straight to shooting? - General Discussion and Assistance - CHDK Forum

sx40 straight to shooting?

  • 9 Replies
  • 1863 Views
sx40 straight to shooting?
« on: 01 / April / 2012, 05:00:38 »
Advertisements
i have the chdk auto load on my sx40. But tomshoot each time means pressing the spare function button and then the shutter button. is there anyway to have it go straight to ready to shoot?

*

Offline whim

  • ******
  • 2022
  • A495/590/620/630 ixus70/115/220/230/300/870 S95
Re: sx40 straight to shooting?
« Reply #1 on: 01 / April / 2012, 05:22:26 »
Hi meanducando, welcome to the forum !

Press and hold the on/off button until you see the CHDK logo ( ~ 1 sec) when starting your camera.

hope that helps,

wim

Re: sx40 straight to shooting?
« Reply #2 on: 01 / April / 2012, 05:41:07 »
thanks but i dont get the logo. Just the splashscreen. Holding the on/off button for as long as i care too doesnt make any difference. So giess i need to know why im not seeing a logo. I get the normal camera logo then it boots to the alt playback screen.

Re: sx40 straight to shooting?
« Reply #3 on: 01 / April / 2012, 07:46:25 »
You mean you start in ALT mode? The "ALT" string is displayed on the bottom of the screen?

It's a guess but maybe you have set some script to run at start...? Camera shouldn't start in ALT mode in any way, the script autostart is the only exception that comes to my mind.
if (2*b || !2*b) {
    cout<<question
}

Compile error: poor Yorick


Re: sx40 straight to shooting?
« Reply #4 on: 01 / April / 2012, 08:59:31 »
So giess i need to know why im not seeing a logo. I get the normal camera logo then it boots to the alt playback screen.
That usually means you have not put all the CHDK files onto your SD card - just the diskboot.bin.  You need to download and unzip the full package to your SD card.
Ported :   A1200    SD940   G10    Powershot N    G16

Re: sx40 straight to shooting?
« Reply #5 on: 01 / April / 2012, 10:25:39 »
nope. I am using build 1781 full, all files and folders. 

Re: sx40 straight to shooting?
« Reply #6 on: 01 / April / 2012, 12:33:23 »
Maybe some mess with config... Could you remove or rename your CHDK config file? This is this one with CFG extension in CHDK folder.
if (2*b || !2*b) {
    cout<<question
}

Compile error: poor Yorick

Re: sx40 straight to shooting?
« Reply #7 on: 01 / April / 2012, 12:35:16 »
which folder would the logo be in? Im not seeing a logo.


Re: sx40 straight to shooting?
« Reply #8 on: 01 / April / 2012, 12:55:27 »
which folder would the logo be in? Im not seeing a logo.
/CHDK/DATA - its called logo.dat
Ported :   A1200    SD940   G10    Powershot N    G16

Re: sx40 straight to shooting?
« Reply #9 on: 01 / April / 2012, 15:42:13 »
OUTSLIDER tx, renamed the config file and indeed it then worked as normal.

 

Related Topics