a4000 disassembling problem

  • 5 Replies
  • 1988 Views
*

Offline alvm

  • ***
  • 116
a4000 disassembling problem
« on: 06 / April / 2012, 03:50:28 »
Advertisements
Hi,

I have a problem with a4000 dump disassembling. IDA and  arm-elf-objdump give the same result.

So a4000 start address is 0xFF810000. The problem is:

ROM:FF8111E8                 BL      0x3FC448

ROM:FF8111E8: Can't find name (hint: use manual arg)

The real address for BL is 0xFFC10194 instead 0xFF8111E8 + 0x3FC448 -> 0xFFC0D630.

How can I fix the problem?

Thanks,
Alex.
« Last Edit: 06 / April / 2012, 05:12:33 by alvm »

*

Offline c10ud

  • ***
  • 244
Re: a4000 disassembling problem
« Reply #1 on: 06 / April / 2012, 05:12:17 »
You may want to follow this porting thread: http://chdk.setepontos.com/index.php?topic=7889
Looks like newer dryos versions like to copy some of the firmware from ROM to RAM during boot

*

Offline alvm

  • ***
  • 116
Re: a4000 disassembling problem
« Reply #2 on: 06 / April / 2012, 05:23:55 »
Thanks, c10ud!

The link explain the problem and way for its solving.

*

Offline reyalp

  • ******
  • 10069
Re: a4000 disassembling problem
« Reply #3 on: 06 / April / 2012, 21:46:04 »
Hi alvm,

Can you post a firmware dump for this camera ? We might be able to give you more help that way :)

You can use a file hosting site like box.com or zshare
Don't forget what the H stands for.


*

Offline alvm

  • ***
  • 116
Re: a4000 disassembling problem
« Reply #4 on: 09 / April / 2012, 06:43:28 »
Hi reyalp,

Thanks for your offer of help :)

Link is http://www.box.com/s/998b7fa6dbe2ab011ac2

Start address is 0xFF810000.

Thanks,
Alex.
« Last Edit: 09 / April / 2012, 16:48:10 by alvm »

*

Offline fe50

  • ******
  • 3038
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: a4000 disassembling problem
« Reply #5 on: 12 / April / 2012, 02:08:52 »
Added the
  • A4000 1.00C
full 8MB dump (dumped with cBasic udumper) by alvm from this forum post to the box.net/chdk repository.

 

Related Topics