Can't get 'Firm. Update' to appear on G10 1.02A - page 2 - General Help and Assistance on using CHDK stable releases - CHDK Forum
supplierdeeply

Can't get 'Firm. Update' to appear on G10 1.02A

  • 16 Replies
  • 3986 Views
Re: Can't get 'Firm. Update' to appear on G10 1.02A
« Reply #10 on: 13 / June / 2012, 18:27:10 »
Advertisements
Are you starting the camera with the playback (triangle) button or the on/off switch and then changing to playback mode.   You need to start with the playback switch - not the on/off switch !
Ported :   A1200    SD940   G10    Powershot N    G16

Re: Can't get 'Firm. Update' to appear on G10 1.02A
« Reply #11 on: 14 / June / 2012, 05:38:10 »
Zeno,

my SD main root directory looks as follow:

changelog.txt
CHDK (folder)
DISKBOOT.BIN
PS.FI2
readme.txt
vers.req

Re: Can't get 'Firm. Update' to appear on G10 1.02A
« Reply #12 on: 14 / June / 2012, 05:49:38 »

I have a Powershoot canon g10 camera
I have Canon original firmware 1.0.3b installed (I have checked it by using SEL and DISPL. bottoms)

Now I want to update it with the CHDK firmware. Right?
I got 1.0.3b full CHDK from http://mighty-hoernsche.de/  (g10-103b-1.0.0-1907-full.zip  (731KB)

I have a 4GB SD card and I use Mac OSX 10.6.8

When I just format with the Mac the card and add in the main SD directory the content, under playback mode, the canon menu will NOT give me at the bottom the firmware update option. Why is that?
I have than used the SDMinst app to create a bootable SD card. I did as fat32 and I locked it. When I add the SD card to the Canon, again in playback mode, I get for couple of seconds a screen with CHDK logo, in red, and than everything disappear and nothing happen....

Re: Can't get 'Firm. Update' to appear on G10 1.02A
« Reply #13 on: 14 / June / 2012, 06:53:34 »
I have a 4GB SD card and I use Mac OSX 10.6.8

When I just format with the Mac the card and add in the main SD directory the content, under playback mode, the canon menu will NOT give me at the bottom the firmware update option. Why is that?

I have than used the SDMinst app to create a bootable SD card. I did as fat32 and I locked it. When I add the SD card to the Canon, again in playback mode, I get for couple of seconds a screen with CHDK logo, in red, and than everything disappear and nothing happen....
I posted a link earlier explaining why you cannot load the card directly from your Mac. I also posted that you cannot boot a G10 from a FAT32 card - it need to be FAT16.

However, from you description, it appears you have succeeded in booting CHDK using SDMinst and the frimware updat menu.   After the logo dissappears (which it is supposed to do) press the Print button on the upper left of the back of your camera to launch <ALT> mode and then press the MENU button to open the CHDK menu.   
« Last Edit: 14 / June / 2012, 06:55:21 by waterwingz »
Ported :   A1200    SD940   G10    Powershot N    G16


Re: Can't get 'Firm. Update' to appear on G10 1.02A
« Reply #14 on: 14 / June / 2012, 09:27:28 »
SDMint utility will NOT allow me to make 1 single SD card as fat16. Any clue? I can only make 2 partitions or 1 partition but as fat32 only....

Re: Can't get 'Firm. Update' to appear on G10 1.02A
« Reply #15 on: 14 / June / 2012, 12:14:18 »
SDMint utility will NOT allow me to make 1 single SD card as fat16. Any clue? I can only make 2 partitions or 1 partition but as fat32 only....
I don't have a Mac but here's what it says on the SDMinst web page :

"version 1.17 - updated 29th July 2011 - ensure 4GB cards can be formatted as a single FAT16 partition."

What version are you using ?
Ported :   A1200    SD940   G10    Powershot N    G16

Re: Can't get 'Firm. Update' to appear on G10 1.02A
« Reply #16 on: 14 / June / 2012, 12:52:38 »
waterwingz, I have version 1.2.4 of SDMinst app for Mac OSX.

 

Related Topics