remote.bas (USB remote) does not work on video - bug or ... ? - General Help and Assistance on using CHDK stable releases - CHDK Forum  

remote.bas (USB remote) does not work on video - bug or ... ?

  • 7 Replies
  • 4035 Views
Advertisements
Hi, CHDK works great on my PowerShot S95
Using USB power and remote.bas I can take pictures (described on http://chdk.wikia.com/wiki/USB_Remote_Cable)
However, this does not work in video mode.

It will start recording once, then script needs to be stopped, then started for the remote to be able to stop the recording, then script needs to be started & stopped for the camera to react on next USB power command.

Is this a bug, or should the script contain some "if video_mode then"....   or other logic ?

Re: remote.bas (USB remote) does not work on video - bug or ... ?
« Reply #1 on: 23 / April / 2012, 08:55:21 »
Try this ;

Code: [Select]
@title Remote button
while 1
  wait_click 1
  if is_key "remote" then click "shoot_full"
wend
end
Ported :   A1200    SD940   G10    Powershot N    G16

Re: remote.bas (USB remote) does not work on video - bug or ... ?
« Reply #2 on: 23 / April / 2012, 14:06:01 »
Thank you.  it works great ! - and no adverse effect on photos in photo mode (as I can see ?)
(maybe wiki should be updated?)

Re: remote.bas (USB remote) does not work on video - bug or ... ?
« Reply #3 on: 23 / April / 2012, 16:14:47 »
Thank you.  it works great ! - and no adverse effect on photos in photo mode (as I can see ?)
(maybe wiki should be updated?)
In regular shooting mode,  it will tend to bypass the "focus and exposure set" step.  Pretty much what happens when you fully press the shutter button without waiting for the "beep" at half press.
Ported :   A1200    SD940   G10    Powershot N    G16


Re: remote.bas (USB remote) does not work on video - bug or ... ?
« Reply #4 on: 23 / April / 2012, 16:37:36 »
Exactly what I was afraid of :) - that means the quality may be lower,  is it possible for the script to detect video mode, and use shoot_full only for video ?

Re: remote.bas (USB remote) does not work on video - bug or ... ?
« Reply #5 on: 24 / April / 2012, 09:56:08 »
Exactly what I was afraid of :) - that means the quality may be lower,  is it possible for the script to detect video mode, and use shoot_full only for video ?
Code: [Select]
@title Remote Shutter Button
while 1
  do
    wait_click 1
  until is_key "remote"
  if get_mode=2 then click "shoot_full"  else shoot
wend
end
« Last Edit: 24 / April / 2012, 21:23:48 by waterwingz »
Ported :   A1200    SD940   G10    Powershot N    G16

Re: remote.bas (USB remote) does not work on video - bug or ... ?
« Reply #6 on: 14 / May / 2012, 13:34:12 »
Thank you - it works great well.   this code should replace the original remote.bas


Re: remote.bas (USB remote) does not work on video - bug or ... ?
« Reply #7 on: 14 / May / 2012, 19:10:21 »
Thank you - it works great well.   this code should replace the original remote.bas
That script was designed to be as simple as possible.  Its always easy to add to a script though - just as we did here.  Every user has different needs.
Ported :   A1200    SD940   G10    Powershot N    G16


 

Related Topics