SX40 and SD card > 4GB - General Help and Assistance on using CHDK stable releases - CHDK Forum supplierdeeply

SX40 and SD card > 4GB

  • 4 Replies
  • 3067 Views
SX40 and SD card > 4GB
« on: 06 / March / 2012, 17:34:17 »
Advertisements
So far I've been using CHDK on my sx40 (firmware 1.00G) with an SD card < 4GB and without any problems.
Used CardTricks144 for formatting, making bootable and copying in CHDK to the SD card.
Some days ago I bought an 32GB SD card, then my problems started...

My problem is making the SD card bootable.
CardTricks144 is formatting FAT32 and copying in CHDK, but cant make the card bootable.
Planed for using the the camera and CHDK for making the card bootable, by loading CHDK with "Firm Update".
But, I cant find the "Firm Update" choice in the menu...
I've tried:
 - Locked and unlocked SD card
 - starting the camera with the "view-button" and then menu, but no "Firm Update".
 - same solution, but hitting the" view-button" twice - and twice with a delay of 2 sec, still no "Firm Update".

Any proposals out there?

Re: Re: SX40 and SD card > 4GB
« Reply #1 on: 06 / March / 2012, 20:14:55 »
So far I've been using CHDK on my sx40 (firmware 1.00G) with an SD card < 4GB and without any problems.
Used CardTricks144 for formatting, making bootable and copying in CHDK to the SD card.
Some days ago I bought an 32GB SD card, then my problems started...

My problem is making the SD card bootable.
CardTricks144 is formatting FAT32 and copying in CHDK, but cant make the card bootable.
Planed for using the the camera and CHDK for making the card bootable, by loading CHDK with "Firm Update".
But, I cant find the "Firm Update" choice in the menu...
I've tried:
 - Locked and unlocked SD card
 - starting the camera with the "view-button" and then menu, but no "Firm Update".
 - same solution, but hitting the" view-button" twice - and twice with a delay of 2 sec, still no "Firm Update".

Any proposals out there?
You also need to have the CHDK file called ps.fi2 in the root directory of your SD card.  If this file is not available for the SX40 yet (typical during the early stages of a port) then there is nothing for the camera to load the "firmware update" from.
« Last Edit: 06 / March / 2012, 20:38:32 by waterwingz »
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline fe50

  • ******
  • 3134
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: SX40 and SD card > 4GB
« Reply #2 on: 07 / March / 2012, 01:47:13 »
EOScard 1.1 writes the "BOOTABLE" string to 0x5C for a FAT32 card.  Anyway to change this to 0x1E0?
Yes. Use EOScard 1.2
...Or using a hex editor (e.g. HxD from http://mh-nexus.de/en/hxd/ - free, usable without installation) to write the BOOTDISK tag to the card...
Where should the BOOTDISK label be for my 16GB card?
FAT32 formatted card (cameras with DryOS version >= R47 from year >=2011: offset 0x1E0
FAT12 / FAT16 formatted card (all cameras): at offset 0x40

* http://pel.hu/down/

Re: SX40 and SD card > 4GB
« Reply #3 on: 07 / March / 2012, 06:26:04 »
Ported :   A1200    SD940   G10    Powershot N    G16


Re: SX40 and SD card > 4GB
« Reply #4 on: 24 / April / 2012, 06:06:57 »
 Thanks a lot for help!

I've  tested the updated wiki  on "SD card preparation" and it's now working well without any problems.
Also using last version og CHDK for sx40 HS, firm. 1.00G (sx40hs-100g-1.0.0-1820-full_BETA).

Thanks to you both - "I'm back on the sunny side of life again"...  :D

 

Related Topics