Need help w/continuous video script for S95 - page 5 - Script Writing - CHDK Forum supplierdeeply

Need help w/continuous video script for S95

  • 69 Replies
  • 19341 Views
*

Offline J_ph3

  • *
  • 28
Re: Need help w/continuous video script for S95
« Reply #40 on: 15 / September / 2014, 16:25:43 »
Advertisements
I tested the vidExt5.lua with my S95 but unfortunately the focus and the zoom will not work while the script is active. I can pause the script and perform both actions. I then loaded the previous script version and the zoom feature was restored.


j

Re: Need help w/continuous video script for S95
« Reply #41 on: 15 / September / 2014, 17:02:20 »
I tested the vidExt5.lua with my S95 but unfortunately the focus and the zoom will not work while the script is active. I can pause the script and perform both actions. I then loaded the previous script version and the zoom feature was restored.
That is quite strange about zoom not working.  The code for that is identical to the code msl posted here. Can you confirm that version of the script works?
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline J_ph3

  • *
  • 28
Re: Need help w/continuous video script for S95
« Reply #42 on: 15 / September / 2014, 17:11:18 »
>can you confirm that version of the script works?

Yes that's correct, and I can pause <alt>  that script and focus.


*

Offline J_ph3

  • *
  • 28
Re: Need help w/continuous video script for S95
« Reply #43 on: 15 / September / 2014, 17:44:28 »
SORRY!  checked again zoom does work, but focus doesn't.


Re: Need help w/continuous video script for S95
« Reply #44 on: 15 / September / 2014, 18:39:23 »
SORRY!  checked again zoom does work, but focus doesn't.
Thanks - I was getting worried there. 

I took another look at the script and did some forum searching.  According to this old post by ewavr, the MakeAFScan() function needs a couple of parameter, which I did not give it.  Oooops.

But before I fix that, fabri22 came up with an interesting solution here using set_aflock().  I've added that to the attached script instead of MakeAFScan(). See if it works for you?   If so, it's a general solution that should work in most cameras.
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline J_ph3

  • *
  • 28
Re: Need help w/continuous video script for S95
« Reply #45 on: 15 / September / 2014, 20:10:42 »
We have a winner! thanks so much.


....an off-topic question - where is the menu setting for the video quality display?  Currently it shows up in the bottom middle of the LCD  "Qual:80" I'd like to move it or remove it. It looks like I can comment out the script short cuts to free up some screen space.

thanks

j

Re: Need help w/continuous video script for S95
« Reply #46 on: 15 / September / 2014, 20:30:58 »
We have a winner! thanks so much.
props to fabri22 for giving me the idea !

Quote
....an off-topic question - where is the menu setting for the video quality display?  Currently it shows up in the bottom middle of the LCD  "Qual:80" I'd like to move it or remove it. It looks like I can comment out the script short cuts to free up some screen space.
The OSD information for video is a little bit "brain dead". 

The "Qual:80" line is the fourth line in the "Remaining video time" OSD icon.  Even if there is no third or second line,  it still shows up in the same place but with a blank space between it and the first line.  The state displays handle that situation much better. Different authors I guess?

So you move that line by moving all four lines of the "Remaining video time" OSD icon in the OSD editor.  You can also get rid of it by setting the quality value to the default ( 84?).   

Unfortunately, there is no generic way to just turn off the video OSD information that I am aware of.
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline J_ph3

  • *
  • 28
Re: Need help w/continuous video script for S95
« Reply #47 on: 15 / September / 2014, 20:41:38 »
>You can also get rid of it by setting the quality value to the default ( 84?).   

that works - thanks again.


*

Offline J_ph3

  • *
  • 28
Re: Need help w/continuous video script for S95
« Reply #48 on: 02 / March / 2016, 22:07:37 »
hmmm.... I haven't used CHDK for quite awhile. I used Stick, installed the new CHDK and tried a couple of the continuous scripts LUA and BAS. But unfortunately when I press the shutter release the display shows "start" and then "finished".


I don't know if this thread is still active, just wondering if the scripts are not compatible with the newer CHDK of if I'm just doing something wrong.


thanks


j


s95

Re: Need help w/continuous video script for S95
« Reply #49 on: 02 / March / 2016, 22:21:11 »
hmmm.... I haven't used CHDK for quite awhile. I used Stick, installed the new CHDK and tried a couple of the continuous scripts LUA and BAS.
It would help a lot here if you would provide links to the exact scripts you tried.

Quote
But unfortunately when I press the shutter release the display shows "start" and then "finished".
If this happens for every script you tried,  it suggests you are not actually loading the scripts correctly.  Please tell us exactly what steps your followed to download the script,  transfer it to your SD card,  load it into CHDK, and run it.  For example,  when you load a script,  do you see the script name on the lower left hand edge of the screen when you are in <ALT> mode?

Quote
I don't know if this thread is still active, just wondering if the scripts are not compatible with the newer CHDK of if I'm just doing something wrong.
Seems most likely it is something you are doing wrong.
Ported :   A1200    SD940   G10    Powershot N    G16

 

Related Topics