"shoot" command not working - Script Writing - CHDK Forum supplierdeeply

"shoot" command not working

  • 1 Replies
"shoot" command not working
« on: 18 / March / 2008, 19:54:25 »
I have a PowerShot A640 running fingalo-allbest #42, dated Mar 8 2008.

When i call the "shoot" command from within a script, the camera autofocuses, but does not take the picture. Here is an example script:

Code: [Select]
sleep 1000

The script runs just fine, the camera autofocuses after approximately 1 second, but never takes the picture, and the script never ends. I have tried it in the following modes: AUTO, P, C. If I place the camera in manual-focus mode, then it takes the pictures just fine. It just doesn't work when autofocusing is used.

Code: [Select]
sleep 1000
click "shoot_half"
sleep 2000
click "shoot_full"

...works fine.

Also tried the CHDK allbest #37, Feb 27 2008, and it works about 50% of the time, but exhibits the same problem the other 50% of the time.

I have searched the forums, and also Google, but cannot seem to find something that addresses this problem. I'm sure I'm not the only one, and it's probably something obvious that I'm just missing. Could somebody please point me to where this solution is documented, or at least point me in a proper direction for resolution.

« Last Edit: 18 / March / 2008, 20:35:54 by airman99 »

Re: "shoot" command not working
« Reply #1 on: 18 / March / 2008, 22:01:25 »
« Last Edit: 22 / April / 2008, 14:30:09 by Barney Fife »
[acseven/admin commented out: please refrain from more direct offensive language to any user. FW complaints to me] I felt it imperative to withdraw my TOTAL participation. Nobody has my permission, nor the right, to reinstate MY posts. Make-do with my quoted text in others' replies only. Bye


Related Topics