ELPH 110 HS (IXUS 125 HS) Porting Thread - page 17 - DryOS Development - CHDK Forum

ELPH 110 HS (IXUS 125 HS) Porting Thread

  • 246 Replies
  • 101655 Views
Re: ELPH 110 HS (IXUS 125 HS) Porting Thread
« Reply #160 on: 02 / April / 2014, 18:16:10 »
Advertisements
Is there any way to control the F stop value? I have shutter speed and ISO locked while shooting on bright and sunny days, but every 6th picture or so the F goes from 2.7 to 8 and the picture is very, very dark.

I can't find any Av control, but is there maybe some trick to stop this from happening all together? Maybe drop my ISO even lower or something?
Use the CHDK menus to disable the ND filter.  The Canon firmware is engaging it in bright situations.
« Last Edit: 02 / April / 2014, 18:17:56 by waterwingz »
Ported :   A1200    SD940   G10    Powershot N    G16

Re: ELPH 110 HS (IXUS 125 HS) Porting Thread
« Reply #161 on: 02 / April / 2014, 19:47:39 »
Quote
Use the CHDK menus to disable the ND filter.  The Canon firmware is engaging it in bright situations.

Hmm... I see "off," "In," and "Out." It was in "off," so you're suggesting I move it to "out?"

Thanks! And sorry about the double post. I'm used to other threads where stuff gets lost/missed regularly so double posts are the norm (and things still go unseen!). I'll delete the other one right away.

-Colin

Re: ELPH 110 HS (IXUS 125 HS) Porting Thread
« Reply #162 on: 03 / April / 2014, 07:51:24 »
Hmm... I see "off," "In," and "Out." It was in "off," so you're suggesting I move it to "out?"
Yes.

Judging by your post,  you might also be interested in this :  http://chdk.wikia.com/wiki/KAP_UAV_Exposure_Control_Script
Ported :   A1200    SD940   G10    Powershot N    G16

Re: ELPH 110 HS (IXUS 125 HS) Porting Thread
« Reply #163 on: 03 / April / 2014, 12:30:03 »
Hm.... no change. I'm running two ELPH 110 hs with CHDK. One with my old config and one with the ND filter out. All of the pictures get taken at the same settings, including when both cameras hop to f 8.0 and get dark.

I've seen that script before and honestly didn't get why it was any different than the normal CHDK controls... Ranges and values and ND control. Then again, I can't seem to control the photos the way I want so I should try that script!

I'll update with my results, thanks!


Re: ELPH 110 HS (IXUS 125 HS) Porting Thread
« Reply #164 on: 03 / April / 2014, 15:48:01 »
Uh oh! The KAP-UAV lua told me I didn't have a recent enough version of CHDK so I went to update it (stupidly).

I deleted my CHDK stuff, loaded up stickx and it can't copy. Log file says

Quote
Command 'xcopy CHDK E:\CHDK /e /i /y' issued
   return code was 4
Output: '0 File(s) copied'
Installation failed - see log for details

Can't get Stick or stickx to work. I tried the old fashioned method and can't get either the ver.req/vers.req trick to show me the camera firmware NOR can I find the "update firmware" in the camera settings after unpacking the freshly downloaded CHDK package directly onto the card, as per the instructions.

Lastly, I tried just copy pasting my CHDK from my first camera SD card to the second one (which I'm pretty sure is how I did it originally for this second camera) and that didn't work either.

Help! Is there a trick I'm missing specific to this camera? Has Stick changed so it no longer works? I've tried all of these things multiple times as per the instructions, but no luck. What am I missing here?

Thanks a bunch for the help,
-Colin

Re: ELPH 110 HS (IXUS 125 HS) Porting Thread
« Reply #165 on: 03 / April / 2014, 17:51:26 »
I can't seem to get anything working other than just copying my old CHDK to my new SD card. Problem is, the KAP UAV 2.3 seems to require build 3276 or higher. I'm on 3216.

Anyone have an update procedure? I looked through this thread and see talks of how programmers don't build stuff for the firmware method anymore since "autoboots" are so easy to do. I can't find how/where to do those though. Stick isn't working and Wicks isn't working either. When I download 101a I the .bin is called PRIMARY instead of BOOTLOAD, dunno if that is something...

Can anyone point me in the direction of some more current reading for this camera and CHDK builds?

MANY THANKS!
-Colin
« Last Edit: 03 / April / 2014, 20:00:07 by cwylie »

Re: ELPH 110 HS (IXUS 125 HS) Porting Thread
« Reply #166 on: 03 / April / 2014, 21:24:40 »
Can anyone point me in the direction of some more current reading for this camera and CHDK builds?
This link will take you to the only complete and current guide to setting up CHDK on your camera : Prepare your SD card

It's not pretty and it contains a lot of information, only some of which is relevant to any particular camera.  It also contains a lot of historical information.  But it does have it all.

Still,  over the last couple of years,  many people new to CHDK have read it and suggested they could do a better page.  A few have even tried to do so - I can post a few links to their attempts  if you have time to kill but it's really not worth it.   Meanwhile, I'm still waiting hopefully

« Last Edit: 03 / April / 2014, 21:26:30 by waterwingz »
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline reyalp

  • ******
  • 13792
Re: ELPH 110 HS (IXUS 125 HS) Porting Thread
« Reply #167 on: 03 / April / 2014, 21:31:57 »
When I download 101a I the .bin is called PRIMARY instead of BOOTLOAD, dunno if that is something...
That sounds like a rom dump rather than a CHDK build.  There is no file called "BOOTLOAD", CHDK binaries would be called DISKBOOT.BIN or PS.FI2, but you need the rest of the files that go with the build too.

You should get CHDK build from the download links on the download page:http://chdk.wikia.com/wiki/Downloads

I don't know why stick isn't working for you (I don't use it) but once the card is set up, you can just extract the files in the zip onto the card using a card reader.
Don't forget what the H stands for.


Re: ELPH 110 HS (IXUS 125 HS) Porting Thread
« Reply #168 on: 04 / April / 2014, 12:19:16 »
Ha, yeah... That would be it. I was downloading from the wrong place I guess. Stick still doesn't work, but as you suggested, I downloaded it from http://chdk.wikia.com/wiki/Downloads and just unzipped it. I went back to find the link to download page I was using and can't find it now, but it's all I could find yesterday! Some code.google page if I remember correctly.

Anyway, the script works great now! Unfortunately it's totally overcast and windy here this morning. If it clears up in the afternoon I'll do some comparison testing between my old CHDK setup and the script control to see if I can get rid of these dark images.

Thanks SO much for the help, guys! I'll post my results!
-Colin

Re: ELPH 110 HS (IXUS 125 HS) Porting Thread
« Reply #169 on: 04 / April / 2014, 16:34:34 »
Anyway, the script works great now! Unfortunately it's totally overcast and windy here this morning. If it clears up in the afternoon I'll do some comparison testing between my old CHDK setup and the script control to see if I can get rid of these dark images.
Let me see if I understand this. 
  • You used the CHDK menu to set the shutter speed (Tv) and ISO setting (Sv) to fixed values.
  • You used the CHDK menu to set the ND filter state to "Out"
  • You take about 16 pictures in bright light and one or two appear to be 3 f-stops underexposed.
If this is so, then the ND filter code in the port for your camera seems to be broken.   Fixing Tv & Sv means the exposure of every shot should be the same.  Your camera does not have a variable aperture so Av is fixed by definition for a given zoom position.

The only thing that would cause the exposure change you are seeing is the ND filter moving into position (as I suggested earlier) in response to a bright lighting situation.
Ported :   A1200    SD940   G10    Powershot N    G16

 

Related Topics