supplierdeeply

ELPH 110 HS (IXUS 125 HS) Porting Thread

  • 245 Replies
  • 38682 Views
Re: ELPH 110 HS (IXUS 125 HS) Porting Thread
« Reply #240 on: 28 / March / 2017, 01:04:05 »
Advertisements
Well, guess what. I just installed the CHDK_DE build, and Snake works just fine.

*

Offline reyalp

  • ******
  • 10416
Re: ELPH 110 HS (IXUS 125 HS) Porting Thread
« Reply #241 on: 28 / March / 2017, 01:58:16 »
Well, guess what. I just installed the CHDK_DE build, and Snake works just fine.
This is very strange, it's built from the same source :-[
Don't forget what the H stands for.

Re: ELPH 110 HS (IXUS 125 HS) Porting Thread
« Reply #242 on: 21 / April / 2017, 05:50:37 »
I believe I found the scenario that reliably reproduces the bug.

1. Start Reversi
2. Exit Reversi
3. Start Snake

Re: ELPH 110 HS (IXUS 125 HS) Porting Thread
« Reply #243 on: 24 / April / 2017, 16:12:16 »
Here's another bug, this time in default.lua (probably applies to other models as well):

1. Change camera language to Russian
2. Run default script

Expected: CHDK language changed to russian
Actual: unknown language id (16)


*

Offline reyalp

  • ******
  • 10416
Re: ELPH 110 HS (IXUS 125 HS) Porting Thread
« Reply #244 on: 25 / April / 2017, 00:02:04 »
Here's another bug, this time in default.lua (probably applies to other models as well):
Yes, this seems to be another example of propcase values changing between propsets.

I get the same on elph130. The script can probably be fixed by adding more cases in get_cam_lang.

FWIW, I wasn't able to reproduce the reversi/snake issue on elph130. That doesn't mean it I don't believe you, just that I have less chance of fixing it ;)
Don't forget what the H stands for.

Re: ELPH 110 HS (IXUS 125 HS) Porting Thread
« Reply #245 on: 25 / April / 2017, 00:07:15 »
FWIW, I wasn't able to reproduce the reversi/snake issue on elph130.
Could not reproduce on an S100 or G10 either.
Ported : A1200  SD940  G10  Powershot N  G16*

 

Related Topics