supplierdeeply

Help with A460

  • 7 Replies
  • 1001 Views
Help with A460
« on: 12 / May / 2012, 07:49:40 »
Advertisements
Hello group.
I hope that a member can help me to get motion.bas or motion.lua working. I have managed to install them both on my A460, but both scrips are acting the same. When I start, the camera takes one picture, the lcd screen goes black, the orange light blinks for ten to fifteen seconds and then takes another picture, all without anything moving in the field of view. This carries on all by itself over and over again. Anyone any ideas how I can get it to work, or is the A460 not the best camera for motion detection? Thanks for anyones thoughts.
David Miles.

Re: Help with A460
« Reply #1 on: 12 / May / 2012, 09:12:47 »
Did you look at this :  http://chdk.wikia.com/wiki/Motion_Detection

You'll want to particularly look at parameter "f" - lowering that value will decrease the sensitivity of the motion detection algorithmn. 

*

Offline srsa_4c

  • ******
  • 3171
Re: Help with A460
« Reply #2 on: 12 / May / 2012, 09:28:48 »
The following thread might be also useful (it's listed at the bottom of that wikia page): CHDK Motion Detect Plus Script , especially where it states that
Quote
Note
There appears to be an issue where the motion detection function doesn't reset for the next photo unless the image review mode is disabled.
I have attached a build that makes the fast framebuffer address ( vid_get_viewport_live_fb() ) available for this camera. It should make the detection faster.

Re: Help with A460
« Reply #3 on: 12 / May / 2012, 09:39:55 »
I have attached a build that makes the fast framebuffer address ( vid_get_viewport_live_fb() ) available for this camera. It should make the detection faster.
Are you also going to post that here : http://chdk.setepontos.com/index.php?topic=650.0 ?


*

Offline srsa_4c

  • ******
  • 3171
Re: Help with A460
« Reply #4 on: 12 / May / 2012, 09:47:18 »
Are you also going to post that here : http://chdk.setepontos.com/index.php?topic=650.0 ?
I usually do, but I'd prefer it to be tested first (although I'm 99.99% sure it works, that piece of firmware code is easy to find).

Re: Help with A460
« Reply #5 on: 12 / May / 2012, 14:52:57 »
Thankyou waterwingz and srsa_4c for coming to my aid, but after trying lots of scrips, I have just found out that "fast MD with burst/preview mode" seems to work quite well on my A460. If others are having trouble getting MD to work on their A460's, this could be the answer. Thanks again to both of you.

David Miles./

*

Offline srsa_4c

  • ******
  • 3171
Re: Help with A460
« Reply #6 on: 13 / May / 2012, 13:31:49 »
@david miles

In case you tried the test build above, does motion detection still work with it?

Silent update: I've tested and committed the above changes (and more) in changesets 2166 and 2167.
« Last Edit: 21 / September / 2012, 17:51:45 by srsa_4c »

Re: Help with A460
« Reply #7 on: 13 / May / 2012, 13:49:41 »
I have just found out that "fast MD with burst/preview mode" seems to work quite well on my A460.
The real difference between that script and the simple one included with the CHDK distribution is the default value for three of the parameters.   

The threshold (difference in cell to trigger detection) is set to 10 (vs 5),   the triggering delay 5 (vs 0) and the pixel step is set to 6 (vs 2).  All three changes will substantially affect the motion detection response.
« Last Edit: 13 / May / 2012, 14:15:50 by waterwingz »


 

Related Topics