I seem to be incorrectly uploading newest updates - Hello, I'm a NEWBIE - HELP!! (Newbies assistance, User Guides and thank you notes) - CHDK Forum

I seem to be incorrectly uploading newest updates

  • 6 Replies
  • 1817 Views
I seem to be incorrectly uploading newest updates
« on: 31 / May / 2012, 16:24:34 »
Advertisements
I have tried manually and with cardtricks to upload the newest revision for my a540 Canon.

CHDK 0.9.9-1361 is the build currently on my camera.

I downloaded both manually and with cardtricks the newest version which I think was 1.0.0 plus the last 4 digits.

I targeted my 2 gig sd card in both cases for the unzip.

Everything seemed to move to the card, yet my firmware statement on opening chdk is the 9.9 version.

It is an eye-fi card, but in the past that has not been a problem.

I have forgotten something.

John Elliott

Re: I seem to be incorrectly uploading newest updates
« Reply #1 on: 31 / May / 2012, 18:20:08 »
Reformat the card in your PC before you start ?
Ported :   A1200    SD940   G10    Powershot N    G16

Re: I seem to be incorrectly uploading newest updates
« Reply #2 on: 31 / May / 2012, 21:06:54 »
I don't dare reformat when it alrady has eye-fi software.

Re: I seem to be incorrectly uploading newest updates
« Reply #3 on: 31 / May / 2012, 21:09:16 »
Can you at least manually delete the ps.fi2 file in the root directory of the card ?   Then try your install procedure and see if the new one is installed correctly.
Ported :   A1200    SD940   G10    Powershot N    G16


*

Offline reyalp

  • ******
  • 11895
Re: I seem to be incorrectly uploading newest updates
« Reply #4 on: 31 / May / 2012, 23:43:28 »
a540 is a vxworks cam, so it will have PS.FIR and DISKBOOT.BIN

If you delete both of these files, that should definitely prevent CHDK from loading. If it does, copy the new files. If it doesn't, you have some kind of partition problem.

A540 does not support multiple partitions, so there's no reason to have a multipartition card. If it does have multiple partitions, that could certainly be a problem.

Depending on your OS and settings, removing the card without using "safely remove" / eject / unmount in the OS can result in the files not actually being copied.
Don't forget what the H stands for.

Re: I seem to be incorrectly uploading newest updates
« Reply #5 on: 01 / June / 2012, 17:40:25 »
Problem fixed if not solved :)
Cardtricks had sent the new download to a different folder than I previously had used.  Found it; still no luck.  Then told cardtricks to overwrite (great fear my eye-fi might be overwritten}.
It works now, mainly because I must overwrite each time the old chdk in the card?

No new headings in the menus.  Were there any major changes since version 9.9.9?

Re: I seem to be incorrectly uploading newest updates
« Reply #6 on: 01 / June / 2012, 17:53:24 »
It works now, mainly because I must overwrite each time the old chdk in the card?
Yes.

Quote
No new headings in the menus.  Were there any major changes since version 9.9.9?
Mostly bug fixes and new camera ports in 1.0.0 

The major changes are all in the 1.1.0 release trunk - CardTricks does not know anything about that.
Ported :   A1200    SD940   G10    Powershot N    G16

 

Related Topics