Powershoot g10 and latest CHDK installation firmware problem - General Help and Assistance on using CHDK stable releases - CHDK Forum

Powershoot g10 and latest CHDK installation firmware problem

  • 13 Replies
  • 4901 Views
Advertisements
Hi, I have the canon powershoot 10. I want to install the latest CHDK firmware (g10-103b) which I got using Acid download function.

I have insert with my mac, the CHDK directory into an empty SD card and load into the camera.

I have followed the instructions. When I go to the firmware update settings i get a message to confirm to update from v 1.0.3 to version 1.1.0. I click yes, than a black monitor will appear and nothing will happen.
I did this many times, do firmware again, still issue. The update progress bar just do NOT start (I guess it crash immediately after I confirm the update). I am in playback mode.

Please help me!

*

Offline fe50

  • ******
  • 3117
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: Powershoot g10 and latest CHDK installation firmware problem
« Reply #1 on: 10 / June / 2012, 07:40:28 »
Hello & welcome !

I want to install the latest CHDK firmware (g10-103b) which I got using Acid download function.
Is your firmware version really 1.03b ?
Did ACID report 1.03b when you feed it with an image from your camera - or did you just download the g10 build with the "highest" number ?
If so - the camera's firmware version must fit to the CHDK build (e.g. 1.03b) version...

Quote
I click yes, than a black monitor will appear and nothing will happen.
When you call the "Firm update" process, do you see the CHDK splash screen ?
If so, just press or half-press the shutter button once to switch to record mode...

If the camera crashes (no response to any keys), most probably the CHDK version does not fit your camera's firmware version.

*

Offline zeno

  • *****
  • 889
Re: Powershoot g10 and latest CHDK installation firmware problem
« Reply #2 on: 10 / June / 2012, 07:56:19 »
Hi Puffo25 - from what you say, it seems you have the correct build. If fe50's suggestion (pressing the shutter button) does not work, then I suggest you try to make CHDK bootable using my SDMInst program (runs on your Mac). If the card is bigger than 4Gb you'll need 2 partitions, but SDMInst will do that for you.
See http://www.zenoshrdlu.com/clickpansdm/sdminst.html

Most of us find it more convenient to have CHDK auto-boot (just requires the card to be locked before you insert it into the camera).
A570, S100, Ixus 127
Author of ASSIST, STICK, WASP, ACID, SDMInst, LICKS, WICKS, MacBoot, UBDB, CFGEdit

Re: Powershoot g10 and latest CHDK installation firmware problem
« Reply #3 on: 10 / June / 2012, 16:55:15 »
I have used Acid to identify my camera status...

CHDK - searching for build for g10-103b
CHDK - build found - bins/g10-103b-1.0.0-1905-full.zip
CHDK - build found - bins/g10-103b-1.0.0-1905.zip
Downloading http://zenoshrdlu.com/acid/acidchde.properties
CHDK-DE - searching for build for g10-103b
CHDK-DE - build found - http://downloads.chdk-treff.de/autobuild/g10-103b-1.1.0-full_rev_1001.zip
CHDK-DE - build found - http://downloads.chdk-treff.de/autobuild/g10-103b-1.1.0_rev_1001.zip
Downloading http://zenoshrdlu.com/acid/acidsdm.properties
SDM - no build found for Canon PowerShot G10 103b
Processing completed
bins/g10-103b-1.0.0-1905-full.zip zip file being downloaded, please wait...
bins/g10-103b-1.0.0-1905-full.zip has been saved
Extracting DISKBOOT.BIN

I have get the firmware update dialog: from 1.0.3.0 to 1.1.0.0. When I click OK the screen will get dark and nothing will happen :-( What is going on?
« Last Edit: 10 / June / 2012, 17:03:46 by puffo25 »


Re: Powershoot g10 and latest CHDK installation firmware problem
« Reply #4 on: 10 / June / 2012, 17:01:47 »
I get nuts here. I have download the SDMinst app. Thanks. I have mac OS 10.6.8-
Why is that? What I am doing wrong?

cross posted here :  http://chdk.setepontos.com/index.php?topic=7956.msg86362#msg86362

please don't post the same question in multiple forums - the people who can answer your question usually watch all recent postings - duplicates only tend to annoy them ...
Ported :   A1200    SD940   G10    Powershot N    G16

Re: Powershoot g10 and latest CHDK installation firmware problem
« Reply #5 on: 10 / June / 2012, 17:04:41 »
waterwingz, I have changed the text in the main time.... sorry....

Re: Powershoot g10 and latest CHDK installation firmware problem
« Reply #6 on: 10 / June / 2012, 17:12:42 »
I have used Acid to identify my camera status...
I have get the firmware update dialog: from 1.0.3.0 to 1.1.0.0. When I click OK the screen will get dark and nothing will happen :-( What is going on?
Sounds like you are doing everything right.   Typically, if the screen goes dark on a firmware updated then you have the wrong firmware version - despite what ACID tells you.

Are you able to "lock" the SD card and get CHDK to boot ?
Ported :   A1200    SD940   G10    Powershot N    G16

Re: Powershoot g10 and latest CHDK installation firmware problem
« Reply #7 on: 10 / June / 2012, 17:18:33 »
Hi, I have replied in the other post about the specific versions of firmwares. Probably that is the problem. Thanks to look on it.
When I lock the SD card I do not see anything specific happen. For example I cannot get the CHDK boot logo automatically or something like that...


Re: Powershoot g10 and latest CHDK installation firmware problem
« Reply #8 on: 10 / June / 2012, 17:24:42 »
Hi, I have replied in the other post about the specific versions of firmwares. Probably that is the problem. Thanks to look on it.
When I lock the SD card I do not see anything specific happen. For example I cannot get the CHDK boot logo automatically or something like that...
Does the camera start normally and complain about the card being locked ?
Ported :   A1200    SD940   G10    Powershot N    G16

Re: Powershoot g10 and latest CHDK installation firmware problem
« Reply #9 on: 10 / June / 2012, 18:38:49 »
Correct. Yes.

 

Related Topics