Unable to create badpixel.bin - RAW Shooting and Processing - CHDK Forum

Unable to create badpixel.bin

  • 7 Replies
  • 3473 Views
Unable to create badpixel.bin
« on: 16 / June / 2012, 17:27:20 »
Advertisements
Hi,

I used an earlier version of chdk at the beginning of this year and was able to create badpixel.bin fine. Unfortunately I lost the SD card so took this opportunity to upgrade to the latest build of chdk but now no matter what I try I cannot create badpixel.bin, it just fails after taking a second photo and says please try again. I can't seem to find anywhere I can download an old build so am unable to prove/disprove if it's a problem with the build. I have tried both of the following builds and neither work:

ixus220_elph300hs-101e-1.1.0-1916-full_ALPHA.zip
ixus220_elph300hs-101e-1.0.0-1907-full_ALPHA.zip

One thing I have noticed with both of the above builds, if I check the chdk build details on the camera, both report it to be 101c.

I've also tried "touch badpixel.bin" too.

Anyone have any advice?

Cheers

*

Offline philmoz

  • *****
  • 3146
    • Photos
Re: Unable to create badpixel.bin
« Reply #1 on: 16 / June / 2012, 18:33:04 »
Hi,

I used an earlier version of chdk at the beginning of this year and was able to create badpixel.bin fine. Unfortunately I lost the SD card so took this opportunity to upgrade to the latest build of chdk but now no matter what I try I cannot create badpixel.bin, it just fails after taking a second photo and says please try again. I can't seem to find anywhere I can download an old build so am unable to prove/disprove if it's a problem with the build. I have tried both of the following builds and neither work:

ixus220_elph300hs-101e-1.1.0-1916-full_ALPHA.zip
ixus220_elph300hs-101e-1.0.0-1907-full_ALPHA.zip

One thing I have noticed with both of the above builds, if I check the chdk build details on the camera, both report it to be 101c.

I've also tried "touch badpixel.bin" too.

Anyone have any advice?

Cheers

The CHDK version (101c) is correct - this version is used for camera firmware versions 1.01c, 1.01d and 1.01e. The autobuild copies the 101c version to files with the other version names so people can find their version.

For the badpixel.bin I need some sample .DNG files to try and analyse the problem.

Use the latest development version (ixus220_elph300hs-101e-1.1.0-1916-full_ALPHA.zip).
Go into the Raw Parameters menu and select DNG version 1.3 (not 1.1) - you can now shoot DNG images without a badpixel.bin file. The badpixel mapping is done using opcodes but some software doesn't recognise them so you may see the bad pixels in your images.

With the above versions and settings take four images of a light colored wall - min zoom & min ISO, min zoom and max ISO, max zoom and min ISO and finally max zoom and max ISO.

Upload the files to a file share site (e.g. box.com) and post a link to the files here.

Phil.
CHDK ports:
  sx30is (1.00c, 1.00h, 1.00l, 1.00n & 1.00p)
  g12 (1.00c, 1.00e, 1.00f & 1.00g)
  sx130is (1.01d & 1.01f)
  ixus310hs (1.00a & 1.01a)
  sx40hs (1.00d, 1.00g & 1.00i)
  g1x (1.00e, 1.00f & 1.00g)
  g5x (1.00c, 1.01a, 1.01b)

Re: Unable to create badpixel.bin
« Reply #2 on: 17 / June / 2012, 08:38:10 »
Hi Phil,

Thanks for your help, I've uploaded the 4 DNGs here: http://danielhead.com/dngs.zip

I'm not sure what the max ISO setting is (I know chdk can go higher than the camera allows, not sure if it's ok to push beyond that limit?), so I've gone for ISO 1 and ISO 2500 for min and max respectively.

Let me know if that's not OK and I'll reupload some new files.

Thanks again,

Dan

Re: Unable to create badpixel.bin
« Reply #3 on: 17 / June / 2012, 22:55:28 »
I can't seem to find anywhere I can download an old build so am unable to prove/disprove if it's a problem with the build.
Here's a backup set from Feb 25, 2012.

https://www.box.com/chdk/1/215563400

Not sure it that's far enough back for you ?  If philmoz can't solve this (unlikely) then we could revert to whatever date you pick for your camera and rebuilt I guess.  The svn in wonderful that way.



Ported :   A1200    SD940   G10    Powershot N    G16


*

Offline philmoz

  • *****
  • 3146
    • Photos
Re: Unable to create badpixel.bin
« Reply #4 on: 18 / June / 2012, 04:09:49 »
Hi Phil,

Thanks for your help, I've uploaded the 4 DNGs here: http://danielhead.com/dngs.zip

I'm not sure what the max ISO setting is (I know chdk can go higher than the camera allows, not sure if it's ok to push beyond that limit?), so I've gone for ISO 1 and ISO 2500 for min and max respectively.

Let me know if that's not OK and I'll reupload some new files.

Thanks again,

Dan

Thanks for that; but I should have been clearer in my instructions.

Use the Canon min and max ISO values, disable ALL CHDK overrides (ISO 1 probably enables AUTO ISO on the camera).

Try and keep the exposures consistent so that the wall is bright and exposed to the right of the histogram but not overexposed in each shot.
Try and avoid any obstructions and light fall-off especially in the corners.
Adjust the aperture and shutter speed so that the resulting images are all similarly exposed.

Phil.
CHDK ports:
  sx30is (1.00c, 1.00h, 1.00l, 1.00n & 1.00p)
  g12 (1.00c, 1.00e, 1.00f & 1.00g)
  sx130is (1.01d & 1.01f)
  ixus310hs (1.00a & 1.01a)
  sx40hs (1.00d, 1.00g & 1.00i)
  g1x (1.00e, 1.00f & 1.00g)
  g5x (1.00c, 1.01a, 1.01b)

*

Offline Opal Lin

  • *
  • 7
  • I'm the QUEEN of da WORLD!!! :D... SO OBEY ME o_O
Re: Unable to create badpixel.bin
« Reply #5 on: 19 / June / 2012, 20:21:44 »
Same problem on my sd1200... then i realised... :lol Place the camera against a wall, mounted on a tripod. Make sure it is fairly bright. Lock exposure, ISO, and then very slowly and carefully tell the cam to create badpixel.bin, without sudden movements. Stay still, cross your fingers... and it WORKS!!!

(At least it does for me)
REMEMBER THESE THINGS :D

1. I'm AWESOME!
2. I'm ASIAN!
3. I'm STUNNINGLY GORGEOUS!
4. I RULE DA WORLD!
5. I'm ONLY 17... BE NICE!
6. Ok... THAT'S ALL!!! ^_^   [And I like CHDK :) ]

Re: Unable to create badpixel.bin
« Reply #6 on: 23 / June / 2012, 04:02:29 »
Thanks for that; but I should have been clearer in my instructions.

Use the Canon min and max ISO values, disable ALL CHDK overrides (ISO 1 probably enables AUTO ISO on the camera).

Try and keep the exposures consistent so that the wall is bright and exposed to the right of the histogram but not overexposed in each shot.
Try and avoid any obstructions and light fall-off especially in the corners.
Adjust the aperture and shutter speed so that the resulting images are all similarly exposed.

Phil.

Thanks Phil, I've been away for a few days so have been unable to look into this further. I'll retake the photos and upload them later on.

In the interim I reverted to an old build provided by waterwingz and badpixel.bin was created successfully first time, however when I view the DNGs (taken with an up to date build, using the existing badpixel.bin) in RawTherapee I can still see many black marks in the picture, I assume these are the bad pixels.

Cheers

Dan

Re: Unable to create badpixel.bin
« Reply #7 on: 28 / July / 2012, 21:31:10 »
Unfortunately I lost the SD card so took this opportunity to upgrade to the latest build of chdk but now no matter what I try I cannot create badpixel.bin, it just fails after taking a second photo and says please try again.

Even I encountered similar problem with my Ixus 115 HS when I switched to Firmware Update method.
Here's how my problem was solved. I formatted my FAT32 card to FAT using Cardtricks and loaded rev. 2018. Previously I was using rev. 2002. So I'm not quite sure which one worked; FAT formatting or new rev. I made the card bootable and dropped firmware update method. I hope it helps.
Ixus 115 HS / firmware 1.01c


 

Related Topics